summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-06-12 10:58:04 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-06-12 11:07:37 +0200
commit03b5070fa51fa15ac47489fae77811eaa07e1b91 (patch)
tree891706a5e6725e4f37f331422302e6d53a82aa6a /kde-plasma/kwallet-pam
parentwww-apps/mediawiki: fixed test in postupgrade file (diff)
downloadgentoo-03b5070fa51fa15ac47489fae77811eaa07e1b91.tar.gz
gentoo-03b5070fa51fa15ac47489fae77811eaa07e1b91.tar.bz2
gentoo-03b5070fa51fa15ac47489fae77811eaa07e1b91.zip
kde-plasma: Add KDE Plasma 5.16.0
Package-Manager: Portage-2.3.67, Repoman-2.3.14 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma/kwallet-pam')
-rw-r--r--kde-plasma/kwallet-pam/Manifest1
-rw-r--r--kde-plasma/kwallet-pam/kwallet-pam-5.16.0.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/kde-plasma/kwallet-pam/Manifest b/kde-plasma/kwallet-pam/Manifest
index af141fc454d6..ccc6035d9d80 100644
--- a/kde-plasma/kwallet-pam/Manifest
+++ b/kde-plasma/kwallet-pam/Manifest
@@ -1 +1,2 @@
DIST kwallet-pam-5.15.5.tar.xz 19332 BLAKE2B b5d552500584888d6fd2662e7332623f51ec4a90885c983f492fbff8768b144a5d0bfff8e7466f68b833bbea436b9424b55f221402e1c9ddc8626be63910b521 SHA512 4a1a0b6f4d607a71b2dee3317acd0af1c76991a628be50d67c8231d756255577fe90e0f938050c8f6d6f295d5299deb8a88afbd7eac28050d3b905267bfd7636
+DIST kwallet-pam-5.16.0.tar.xz 19648 BLAKE2B 58e1c50b7d1a479f97d81fb5815778f5cfe32c06f5fd8672a522b22fa6649e373b88810196319f1273cede3a32650b8b35ce4c3ccfeeec56aa34780c96b85653 SHA512 4b911d3e34d840616d230e27da80162a1940f8feaedd67bb9e1f18e1b92250d2812cdb260cedd16a5b5f9c122bb37d3473310229e55996ad5c7682bcfac275b5
diff --git a/kde-plasma/kwallet-pam/kwallet-pam-5.16.0.ebuild b/kde-plasma/kwallet-pam/kwallet-pam-5.16.0.ebuild
new file mode 100644
index 000000000000..f3e1c598ec6c
--- /dev/null
+++ b/kde-plasma/kwallet-pam/kwallet-pam-5.16.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit kde5
+
+DESCRIPTION="KWallet PAM module to not enter password again"
+LICENSE="LGPL-2.1"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE=""
+
+DEPEND="
+ $(add_frameworks_dep kwallet)
+ dev-libs/libgcrypt:0=
+ virtual/pam
+"
+RDEPEND="${DEPEND}
+ net-misc/socat
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_INSTALL_LIBDIR="/$(get_libdir)"
+ )
+ kde5_src_configure
+}
+
+pkg_postinst() {
+ kde5_pkg_postinst
+ elog "This package enables auto-unlocking of kde-frameworks/kwallet:5."
+ elog "See also: https://wiki.gentoo.org/wiki/KDE#KWallet_auto-unlocking"
+}