summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-02-22 09:58:52 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2023-02-22 11:22:27 +0100
commit52637a93dca85342eb019e7c9d91cee7b64a666a (patch)
tree9d590af6c43d48cf363e5f8a344d8948aae5d197 /kde-plasma/kwallet-pam
parentkde-plasma/ksystemstats: 5.27.1 version bump (diff)
downloadgentoo-52637a93dca85342eb019e7c9d91cee7b64a666a.tar.gz
gentoo-52637a93dca85342eb019e7c9d91cee7b64a666a.tar.bz2
gentoo-52637a93dca85342eb019e7c9d91cee7b64a666a.zip
kde-plasma/kwallet-pam: 5.27.1 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma/kwallet-pam')
-rw-r--r--kde-plasma/kwallet-pam/Manifest1
-rw-r--r--kde-plasma/kwallet-pam/kwallet-pam-5.27.1.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/kde-plasma/kwallet-pam/Manifest b/kde-plasma/kwallet-pam/Manifest
index 3fefdc66c94f..17eeaff63de1 100644
--- a/kde-plasma/kwallet-pam/Manifest
+++ b/kde-plasma/kwallet-pam/Manifest
@@ -1,2 +1,3 @@
DIST kwallet-pam-5.26.5.tar.xz 22808 BLAKE2B 42543b6c08dfbe873b6e2ad6503ac35b63022935ab8c40a93da432bb4d3cc240cf5da75565ef839f4cededb5c41a2a485614e47105161456f3310abcb5b79102 SHA512 bf1aeab2c4db2e0ce6e282890326b78b92ce2079f59a50d5729b0af79a7562bf845027f1f1af510181f851f7c02e4fa67c97ab58514981eca21e02ecb1ed36a3
DIST kwallet-pam-5.27.0.tar.xz 22844 BLAKE2B 6c41f9686b9d3b8375b58c53bb6fb805df91644f5b882d1b8b7d0e06365d7f2b1c1a8168aabe7500a2e7c8db0f394df2b59c81daa3ce81c59cc09a1be509895f SHA512 eb1170c0d53fe6e6e13a9fac8bdbaca73c3c491f470e654aadf0ba46b4c91a1b56b50669398c560b5f92895a45ac2d3153b5ceee2bb08f34831c1991236d5fe1
+DIST kwallet-pam-5.27.1.tar.xz 22844 BLAKE2B 52ee60bd2defd80b942e7ed65a0a572a83553b4e95c1b7aa973419247ec22eefb86fd37924f8004b303428daf1a20ab9cb743479e87ec5ad25729618c55667c6 SHA512 a1f4a6ab97a35c35547472219fc3d6a4de55dc0dba9909b4830c09a424f2561284d708362d37531716764fe1c47cd8f234aff9b1b6511bdd51828d55dd6f0c0b
diff --git a/kde-plasma/kwallet-pam/kwallet-pam-5.27.1.ebuild b/kde-plasma/kwallet-pam/kwallet-pam-5.27.1.ebuild
new file mode 100644
index 000000000000..cfb8a1b64668
--- /dev/null
+++ b/kde-plasma/kwallet-pam/kwallet-pam-5.27.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+KFMIN=5.102.0
+PVCUT=$(ver_cut 1-3)
+inherit ecm plasma.kde.org
+
+DESCRIPTION="PAM module to not enter KWallet password again after login"
+
+LICENSE="LGPL-2.1"
+SLOT="5"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+IUSE=""
+
+DEPEND="
+ dev-libs/libgcrypt:0=
+ >=kde-frameworks/kwallet-${KFMIN}:5
+ sys-libs/pam
+"
+RDEPEND="${DEPEND}
+ net-misc/socat
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_INSTALL_LIBDIR="/$(get_libdir)"
+ )
+ ecm_src_configure
+}
+
+pkg_postinst() {
+ ecm_pkg_postinst
+ elog "This package enables auto-unlocking of kde-frameworks/kwallet:5."
+ elog "See also: https://wiki.gentoo.org/wiki/KDE#KWallet_auto-unlocking"
+}