summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-12-01 15:26:27 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2020-12-01 17:07:15 +0100
commit4be8b1bd2cbf4e764ca0658c74dbf06834b0b0f8 (patch)
tree317fb168edea3603505051326b288a2af11bafec /kde-plasma/kwayland-server/kwayland-server-5.20.4.ebuild
parentkde-plasma/kwayland-integration: 5.20.4 version bump (diff)
downloadgentoo-4be8b1bd2cbf4e764ca0658c74dbf06834b0b0f8.tar.gz
gentoo-4be8b1bd2cbf4e764ca0658c74dbf06834b0b0f8.tar.bz2
gentoo-4be8b1bd2cbf4e764ca0658c74dbf06834b0b0f8.zip
kde-plasma/kwayland-server: 5.20.4 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma/kwayland-server/kwayland-server-5.20.4.ebuild')
-rw-r--r--kde-plasma/kwayland-server/kwayland-server-5.20.4.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/kde-plasma/kwayland-server/kwayland-server-5.20.4.ebuild b/kde-plasma/kwayland-server/kwayland-server-5.20.4.ebuild
new file mode 100644
index 000000000000..32972b455ede
--- /dev/null
+++ b/kde-plasma/kwayland-server/kwayland-server-5.20.4.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ECM_QTHELP="true"
+ECM_TEST="true"
+KFMIN=5.74.0
+PVCUT=$(ver_cut 1-2)
+QTMIN=5.15.1
+inherit ecm kde.org
+
+DESCRIPTION="Wayland Server Components built on KDE Frameworks"
+HOMEPAGE="https://invent.kde.org/plasma/kwayland-server"
+
+LICENSE="LGPL-2.1"
+SLOT="5"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE=""
+
+RDEPEND="
+ >=dev-libs/wayland-1.18.0
+ >=dev-qt/qtconcurrent-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5[egl]
+ >=dev-qt/qtwayland-${QTMIN}:5
+ >=kde-frameworks/kwayland-${KFMIN}:5
+ media-libs/mesa[egl]
+"
+DEPEND="${RDEPEND}
+ >=dev-libs/plasma-wayland-protocols-1.1.1
+ >=dev-libs/wayland-protocols-1.18
+"
+
+# All failing, I guess we need a virtual wayland server
+RESTRICT+=" test"