summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-06-12 10:58:04 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-06-12 11:07:37 +0200
commit03b5070fa51fa15ac47489fae77811eaa07e1b91 (patch)
tree891706a5e6725e4f37f331422302e6d53a82aa6a /kde-plasma/oxygen/oxygen-5.16.0.ebuild
parentwww-apps/mediawiki: fixed test in postupgrade file (diff)
downloadgentoo-03b5070fa51fa15ac47489fae77811eaa07e1b91.tar.gz
gentoo-03b5070fa51fa15ac47489fae77811eaa07e1b91.tar.bz2
gentoo-03b5070fa51fa15ac47489fae77811eaa07e1b91.zip
kde-plasma: Add KDE Plasma 5.16.0
Package-Manager: Portage-2.3.67, Repoman-2.3.14 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma/oxygen/oxygen-5.16.0.ebuild')
-rw-r--r--kde-plasma/oxygen/oxygen-5.16.0.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/kde-plasma/oxygen/oxygen-5.16.0.ebuild b/kde-plasma/oxygen/oxygen-5.16.0.ebuild
new file mode 100644
index 000000000000..fd828b90b4c1
--- /dev/null
+++ b/kde-plasma/oxygen/oxygen-5.16.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit kde5
+
+DESCRIPTION="Oxygen visual style for the Plasma desktop"
+HOMEPAGE="https://cgit.kde.org/oxygen.git"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="wayland"
+
+RDEPEND="
+ $(add_frameworks_dep frameworkintegration)
+ $(add_frameworks_dep kcmutils)
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kguiaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_plasma_dep kdecoration)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtdeclarative)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtx11extras)
+ x11-libs/libxcb
+ wayland? ( $(add_frameworks_dep kwayland) )
+"
+DEPEND="${RDEPEND}
+ $(add_frameworks_dep kservice)
+"
+PDEPEND="
+ $(add_plasma_dep kde-cli-tools)
+"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package wayland KF5Wayland)
+ )
+ kde5_src_configure
+}