summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-10-23 12:16:38 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-10-23 18:46:25 +0200
commit04b7a5abc61721150cbdaefb391c4365903d11a1 (patch)
tree17167a551e6bc11df15961a74f7e0e1dbbb04cf6 /kde-plasma/plasma-integration
parentapp-crypt/argon2: Use optimized code on x86 only (diff)
downloadgentoo-04b7a5abc61721150cbdaefb391c4365903d11a1.tar.gz
gentoo-04b7a5abc61721150cbdaefb391c4365903d11a1.tar.bz2
gentoo-04b7a5abc61721150cbdaefb391c4365903d11a1.zip
kde-plasma: KDE Plasma 5.17.1 version bump
Package-Manager: Portage-2.3.76, Repoman-2.3.16 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma/plasma-integration')
-rw-r--r--kde-plasma/plasma-integration/Manifest1
-rw-r--r--kde-plasma/plasma-integration/plasma-integration-5.17.1.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/kde-plasma/plasma-integration/Manifest b/kde-plasma/plasma-integration/Manifest
index c234326228a6..bbf5034b4c2c 100644
--- a/kde-plasma/plasma-integration/Manifest
+++ b/kde-plasma/plasma-integration/Manifest
@@ -1 +1,2 @@
DIST plasma-integration-5.16.5.tar.xz 55672 BLAKE2B a953d06cb13cb6c248124fbdeb8ed7e52d82bb8411e53a7c86b95c8e3fe90464f9e9fdc0a271a697bd95df0865ee7939f8a71d973b82bf5016b64c369a95ba70 SHA512 f974db9c85fb22e7dfeb8154d5c51c7106f2b95aeb783843701234a4b7186fd6b4be6298809d73b1a776399420a0e451908e5466aca622fd69800f0cfa2e3a91
+DIST plasma-integration-5.17.1.tar.xz 56360 BLAKE2B 0945bba0375f80efe87fa6924f0287296c0979ef9183bca7086c8312d2fa098b23fd7c6e313a3e119969a22e0c737e7fd560c2343710c52eabbf62c63161e936 SHA512 2e281766948d53a499608bf72637269b4d5f86da7c24f57d9cdcfe5db16e710524d476ff8868767fbb62e1f52c7064fa0ba40e69c8f25460ba001c7bcecf73a9
diff --git a/kde-plasma/plasma-integration/plasma-integration-5.17.1.ebuild b/kde-plasma/plasma-integration/plasma-integration-5.17.1.ebuild
new file mode 100644
index 000000000000..b28163426a43
--- /dev/null
+++ b/kde-plasma/plasma-integration/plasma-integration-5.17.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Qt Platform Theme integration plugins for the Plasma workspaces"
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE=""
+
+DEPEND="
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kjobwidgets)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep kwayland)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_frameworks_dep kxmlgui)
+ $(add_plasma_dep breeze)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui 'dbus' '' '5=')
+ $(add_qt_dep qtquickcontrols2)
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtx11extras)
+ x11-libs/libXcursor
+ x11-libs/libxcb
+"
+RDEPEND="${DEPEND}
+ media-fonts/hack
+ media-fonts/noto
+"
+
+# requires running kde environment
+RESTRICT+=" test"