summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2022-10-08 20:15:54 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2022-10-11 14:39:54 +0200
commit25a1395122e48820a4179830dc7fe983e7a8eae5 (patch)
tree405ff2dd1fb07b56925546bccd8ae87fa338bdfd /kde-plasma/plasma-integration
parentkde-plasma/plasma-firewall: add 5.26.0 (diff)
downloadgentoo-25a1395122e48820a4179830dc7fe983e7a8eae5.tar.gz
gentoo-25a1395122e48820a4179830dc7fe983e7a8eae5.tar.bz2
gentoo-25a1395122e48820a4179830dc7fe983e7a8eae5.zip
kde-plasma/plasma-integration: add 5.26.0
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma/plasma-integration')
-rw-r--r--kde-plasma/plasma-integration/Manifest1
-rw-r--r--kde-plasma/plasma-integration/plasma-integration-5.26.0.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/kde-plasma/plasma-integration/Manifest b/kde-plasma/plasma-integration/Manifest
index f243d96a1c5c..9afc5fb60ad2 100644
--- a/kde-plasma/plasma-integration/Manifest
+++ b/kde-plasma/plasma-integration/Manifest
@@ -1 +1,2 @@
DIST plasma-integration-5.25.5.tar.xz 86432 BLAKE2B dbd06f375ee4b852a35337f8137ee37e64433bf458e076c17538131d3b5746d872eae57ebb45b69a99af2f8b24c2901be9ce17ede079dd69bfba966844f0f956 SHA512 8595ce9026dbd2943c6579611a06889c2d41e6a2433837809d91b430d4b683931df065b9f681e8857f1a56d98d7703769d97a903056d0fe06bf1ed29986b26e9
+DIST plasma-integration-5.26.0.tar.xz 88916 BLAKE2B 4d008336f5655234a0ec0f958c365b8351aaf6729328cd2f5a0b77139ce459105b34dd7fff81c57508e72551d0217ac60161c9473d2a82e9343dd00a35f783ec SHA512 c1b74368eee3a41ddc58caf9202e6ab00e032b91d976951cf64706d56c58031a3be43d95419a611c5624cec872389c68d8b5e2fc7c2c4bccb5481180de8b0e5f
diff --git a/kde-plasma/plasma-integration/plasma-integration-5.26.0.ebuild b/kde-plasma/plasma-integration/plasma-integration-5.26.0.ebuild
new file mode 100644
index 000000000000..cd11319277fc
--- /dev/null
+++ b/kde-plasma/plasma-integration/plasma-integration-5.26.0.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+KFMIN=5.99.0
+PVCUT=$(ver_cut 1-3)
+QTMIN=5.15.5
+VIRTUALX_REQUIRED="test"
+inherit ecm plasma.kde.org
+
+DESCRIPTION="Qt Platform Theme integration plugins for the Plasma workspaces"
+
+LICENSE="LGPL-2+"
+SLOT="5"
+KEYWORDS="~amd64"
+IUSE=""
+
+# requires running kde environment
+RESTRICT="test"
+
+COMMON_DEPEND="
+ dev-libs/wayland
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5=[dbus]
+ >=dev-qt/qtquickcontrols2-${QTMIN}:5
+ >=dev-qt/qtwayland-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=dev-qt/qtx11extras-${QTMIN}:5
+ >=kde-frameworks/kcompletion-${KFMIN}:5
+ >=kde-frameworks/kconfig-${KFMIN}:5
+ >=kde-frameworks/kconfigwidgets-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kiconthemes-${KFMIN}:5
+ >=kde-frameworks/kio-${KFMIN}:5
+ >=kde-frameworks/kjobwidgets-${KFMIN}:5
+ >=kde-frameworks/knotifications-${KFMIN}:5
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:5
+ >=kde-frameworks/kwindowsystem-${KFMIN}:5
+ >=kde-frameworks/kxmlgui-${KFMIN}:5
+ >=kde-plasma/breeze-${PVCUT}:5
+ x11-libs/libXcursor
+ x11-libs/libxcb
+"
+DEPEND="${COMMON_DEPEND}
+ >=dev-libs/plasma-wayland-protocols-1.6.0
+"
+RDEPEND="${COMMON_DEPEND}
+ media-fonts/hack
+ media-fonts/noto
+"
+BDEPEND="
+ >=dev-qt/qtwaylandscanner-${QTMIN}:5
+"