summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2016-03-02 03:33:46 +1100
committerMichael Palimaka <kensington@gentoo.org>2016-03-02 03:37:34 +1100
commitaf29e6da29eaa68ab7405582b99137194c80de5a (patch)
tree28d6d946ed0b04314d3e1a763315d10a58d07f62 /kde-plasma/plasma-mediacenter/plasma-mediacenter-5.5.5.ebuild
parentkde-apps: version bump kdeadmin 15.12.2 (diff)
downloadgentoo-af29e6da29eaa68ab7405582b99137194c80de5a.tar.gz
gentoo-af29e6da29eaa68ab7405582b99137194c80de5a.tar.bz2
gentoo-af29e6da29eaa68ab7405582b99137194c80de5a.zip
kde-plasma: version bump 5.5.5
Package-Manager: portage-2.2.27
Diffstat (limited to 'kde-plasma/plasma-mediacenter/plasma-mediacenter-5.5.5.ebuild')
-rw-r--r--kde-plasma/plasma-mediacenter/plasma-mediacenter-5.5.5.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/kde-plasma/plasma-mediacenter/plasma-mediacenter-5.5.5.ebuild b/kde-plasma/plasma-mediacenter/plasma-mediacenter-5.5.5.ebuild
new file mode 100644
index 000000000000..166b7ffce3ba
--- /dev/null
+++ b/kde-plasma/plasma-mediacenter/plasma-mediacenter-5.5.5.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+KDE_PUNT_BOGUS_DEPS="true"
+inherit kde5
+
+DESCRIPTION="Unified media experience for any device capable of running KDE"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="semantic-desktop"
+
+DEPEND="
+ $(add_frameworks_dep kactivities)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdeclarative)
+ $(add_frameworks_dep kguiaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep plasma)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtdeclarative)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtnetwork)
+ $(add_qt_dep qtxml)
+ media-libs/taglib
+ semantic-desktop? (
+ $(add_frameworks_dep baloo)
+ $(add_frameworks_dep kfilemetadata)
+ )
+"
+RDEPEND="${DEPEND}
+ $(add_plasma_dep plasma-workspace)
+ $(add_qt_dep qtmultimedia 'qml')
+ !media-video/plasma-mediacenter
+"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package semantic-desktop KF5Baloo)
+ $(cmake-utils_use_find_package semantic-desktop KF5FileMetadata)
+ )
+
+ kde5_src_configure
+}