summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-04-02 20:21:46 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-04-02 23:05:24 +0200
commit55391d594cbb90254c591743415442484c3b0d02 (patch)
tree0495277eae519b0471a036e40a57ebd77d661530 /kde-plasma/plasma-nm
parentdev-python/pillow: bump to 6.0.0 (diff)
downloadgentoo-55391d594cbb90254c591743415442484c3b0d02.tar.gz
gentoo-55391d594cbb90254c591743415442484c3b0d02.tar.bz2
gentoo-55391d594cbb90254c591743415442484c3b0d02.zip
kde-plasma: Add KDE Plasma 5.15.4
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma/plasma-nm')
-rw-r--r--kde-plasma/plasma-nm/Manifest1
-rw-r--r--kde-plasma/plasma-nm/plasma-nm-5.15.4.ebuild74
2 files changed, 75 insertions, 0 deletions
diff --git a/kde-plasma/plasma-nm/Manifest b/kde-plasma/plasma-nm/Manifest
index db926d3e960b..3fe43765d6a5 100644
--- a/kde-plasma/plasma-nm/Manifest
+++ b/kde-plasma/plasma-nm/Manifest
@@ -1,2 +1,3 @@
DIST plasma-nm-5.14.5.tar.xz 721144 BLAKE2B f9537e742be74b50ffeecee007ef91d93d108b566cf081cb4d25bc4d62c98847a74e7e69ec01b2f10e4e75eac4bc75cef90a3a47ad5ad199cec9f20c31bdaf20 SHA512 54667ff01db16bfadc1663dcf51668aed4eabcb70c3903538044bb478aeb4625d27777df13867cdf03048b6575a540de5c7baaef9e2dc2c41f458d2800daba96
DIST plasma-nm-5.15.3.tar.xz 771904 BLAKE2B dc25cfe840797442e64a0033e9982f7fc26919c5d33d0d7a16e5ea661256bd50f59fb7f52ef89da0f806e47dbb654cf019f5457667c0d111b4971cf7d92cf674 SHA512 357d8fac2e13daee846d685de28f79de9bc95b159dd9fcc2b960b4af37f3838f1c8682c694430999f175bd88a096d927622b407db541f75cfa07d9c1e3339637
+DIST plasma-nm-5.15.4.tar.xz 774236 BLAKE2B ae1fa25e68b05840d7a98aed8941da96477544349465aff722d3f47690f4bc7c21d4c00d7f9d5d6410ae0655b1b7a0854ea060528972153c86f78db348365031 SHA512 1d44adf022833069414440cca08c387eeaa2c3ac6fc5675dc198d53b6c1e5bdfeec22f1ac2d3f25b248f1c51e056844b89c67f5bf899f1321057168d214da6c3
diff --git a/kde-plasma/plasma-nm/plasma-nm-5.15.4.ebuild b/kde-plasma/plasma-nm/plasma-nm-5.15.4.ebuild
new file mode 100644
index 000000000000..995f4b6b6b89
--- /dev/null
+++ b/kde-plasma/plasma-nm/plasma-nm-5.15.4.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KDE_TEST="true"
+inherit kde5
+
+DESCRIPTION="KDE Plasma applet for NetworkManager"
+LICENSE="GPL-2 LGPL-2.1"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="modemmanager openconnect teamd"
+
+DEPEND="
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep kdeclarative)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kitemviews)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep kwallet)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_frameworks_dep kxmlgui)
+ $(add_frameworks_dep networkmanager-qt 'teamd=')
+ $(add_frameworks_dep plasma)
+ $(add_frameworks_dep solid)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtdeclarative)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtnetwork)
+ $(add_qt_dep qtwidgets)
+ >=app-crypt/qca-2.1.1:2[qt5(+)]
+ net-misc/networkmanager[teamd=]
+ modemmanager? (
+ $(add_frameworks_dep modemmanager-qt)
+ $(add_qt_dep qtxml)
+ net-misc/mobile-broadband-provider-info
+ )
+ openconnect? (
+ $(add_qt_dep qtxml)
+ net-vpn/networkmanager-openconnect
+ net-vpn/openconnect:=
+ )
+"
+RDEPEND="${DEPEND}
+ $(add_plasma_dep kde-cli-tools)
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DDISABLE_MODEMMANAGER_SUPPORT=$(usex !modemmanager)
+ $(cmake-utils_use_find_package modemmanager KF5ModemManagerQt)
+ $(cmake-utils_use_find_package openconnect OpenConnect)
+ )
+
+ kde5_src_configure
+}
+
+pkg_postinst() {
+ kde5_pkg_postinst
+
+ if ! has_version "kde-plasma/plasma-workspace:5"; then
+ elog "${PN} is not terribly useful without kde-plasma/plasma-workspace:5."
+ elog "However, the networkmanagement KCM can be called from either systemsettings"
+ elog "or manually: $ kcmshell5 kcm_networkmanagement"
+ fi
+}