summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-05-16 22:29:55 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-05-17 00:38:08 +0200
commite0e020e6cccd19a9c14277ef7fd0a159c227f3fd (patch)
treeefbafbc610975129e339ae0e77e63cdb4742b1b5 /kde-plasma/plasma-nm
parentkde-plasma/plasma-workspace: Drop 5.18.5 (r0) (diff)
downloadgentoo-e0e020e6cccd19a9c14277ef7fd0a159c227f3fd.tar.gz
gentoo-e0e020e6cccd19a9c14277ef7fd0a159c227f3fd.tar.bz2
gentoo-e0e020e6cccd19a9c14277ef7fd0a159c227f3fd.zip
kde-plasma/plasma-nm: WireGuard systray icon missing on startup
KDE-Bug: https://bugs.kde.org/show_bug.cgi?id=420983 Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma/plasma-nm')
-rw-r--r--kde-plasma/plasma-nm/files/plasma-nm-5.18.5-missing-wireguard-icon.patch50
-rw-r--r--kde-plasma/plasma-nm/plasma-nm-5.18.5-r1.ebuild83
2 files changed, 133 insertions, 0 deletions
diff --git a/kde-plasma/plasma-nm/files/plasma-nm-5.18.5-missing-wireguard-icon.patch b/kde-plasma/plasma-nm/files/plasma-nm-5.18.5-missing-wireguard-icon.patch
new file mode 100644
index 000000000000..85902e504096
--- /dev/null
+++ b/kde-plasma/plasma-nm/files/plasma-nm-5.18.5-missing-wireguard-icon.patch
@@ -0,0 +1,50 @@
+From da52d01788f5f07aa60ed7a6f21d7943a2e0c8d3 Mon Sep 17 00:00:00 2001
+From: Bruce Anderson <banderson19com@san.rr.com>
+Date: Wed, 6 May 2020 08:03:11 +0200
+Subject: Icon in system tray missing when WireGuard connection active on
+ startup
+
+Summary:
+If a WireGuard connection is made prior to start of the
+plasma-nm applet, no icon is displayed in the system tray.
+
+BUG: 420983
+
+Test Plan:
+1. Setup a Wired connection to autostart
+2. Setup a WireGuard connection which uses the Wired
+ connection and set to autostart
+3. Logout and login to start a new Plasma session
+4. Verify that the standard Wired connection icon with a
+ padlock symbol on it is shown in the system tray
+
+Reviewers: jgrulich
+
+Reviewed By: jgrulich
+
+Subscribers: plasma-devel
+
+Tags: #plasma
+
+Differential Revision: https://phabricator.kde.org/D29469
+---
+ libs/declarative/connectionicon.cpp | 4 +++-
+ 1 file changed, 3 insertions(+), 1 deletion(-)
+
+diff --git a/libs/declarative/connectionicon.cpp b/libs/declarative/connectionicon.cpp
+index cefe6df..58c0cce 100644
+--- a/libs/declarative/connectionicon.cpp
++++ b/libs/declarative/connectionicon.cpp
+@@ -317,7 +317,9 @@ void ConnectionIcon::setIcons()
+
+ // Set icon based on the current primary connection if the activating connection is virtual
+ // since we're not setting icons for virtual connections
+- if (!connection || (connection && UiUtils::isConnectionTypeVirtual(connection->type()))) {
++ if (!connection
++ || (connection && UiUtils::isConnectionTypeVirtual(connection->type()))
++ || connection->type() == NetworkManager::ConnectionSettings::WireGuard) {
+ connection = NetworkManager::primaryConnection();
+ }
+
+--
+cgit v1.1
diff --git a/kde-plasma/plasma-nm/plasma-nm-5.18.5-r1.ebuild b/kde-plasma/plasma-nm/plasma-nm-5.18.5-r1.ebuild
new file mode 100644
index 000000000000..1920bf9e1b7e
--- /dev/null
+++ b/kde-plasma/plasma-nm/plasma-nm-5.18.5-r1.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ECM_TEST="true"
+KFMIN=5.66.0
+PVCUT=$(ver_cut 1-3)
+QTMIN=5.12.3
+inherit ecm kde.org
+
+DESCRIPTION="KDE Plasma applet for NetworkManager"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="5"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE="modemmanager openconnect teamd"
+
+DEPEND="
+ >=app-crypt/qca-2.1.1:2[qt5(+)]
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtdeclarative-${QTMIN}:5[widgets]
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtnetwork-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=kde-frameworks/kcompletion-${KFMIN}:5
+ >=kde-frameworks/kconfig-${KFMIN}:5
+ >=kde-frameworks/kconfigwidgets-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/kdbusaddons-${KFMIN}:5
+ >=kde-frameworks/kdeclarative-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kiconthemes-${KFMIN}:5
+ >=kde-frameworks/kio-${KFMIN}:5
+ >=kde-frameworks/kitemviews-${KFMIN}:5
+ >=kde-frameworks/knotifications-${KFMIN}:5
+ >=kde-frameworks/kservice-${KFMIN}:5
+ >=kde-frameworks/kwallet-${KFMIN}:5
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:5
+ >=kde-frameworks/kwindowsystem-${KFMIN}:5
+ >=kde-frameworks/kxmlgui-${KFMIN}:5
+ >=kde-frameworks/networkmanager-qt-${KFMIN}:5[teamd=]
+ >=kde-frameworks/plasma-${KFMIN}:5
+ >=kde-frameworks/solid-${KFMIN}:5
+ net-misc/networkmanager[teamd=]
+ modemmanager? (
+ >=kde-frameworks/modemmanager-qt-${KFMIN}:5
+ >=dev-qt/qtxml-${QTMIN}:5
+ net-misc/mobile-broadband-provider-info
+ )
+ openconnect? (
+ >=dev-qt/qtxml-${QTMIN}:5
+ net-vpn/networkmanager-openconnect
+ net-vpn/openconnect:=
+ )
+"
+RDEPEND="${DEPEND}
+ >=dev-qt/qtquickcontrols-${QTMIN}:5
+ >=dev-qt/qtquickcontrols2-${QTMIN}:5
+ >=kde-plasma/kde-cli-tools-${PVCUT}:5
+"
+
+PATCHES=( "${FILESDIR}/${P}-missing-wireguard-icon.patch" ) # in Plasma/5.18
+
+src_configure() {
+ local mycmakeargs=(
+ -DDISABLE_MODEMMANAGER_SUPPORT=$(usex !modemmanager)
+ $(cmake_use_find_package modemmanager KF5ModemManagerQt)
+ $(cmake_use_find_package openconnect OpenConnect)
+ )
+
+ ecm_src_configure
+}
+
+pkg_postinst() {
+ ecm_pkg_postinst
+
+ if ! has_version "kde-plasma/plasma-workspace:5"; then
+ elog "${PN} is not terribly useful without kde-plasma/plasma-workspace:5."
+ elog "However, the networkmanagement KCM can be called from either systemsettings"
+ elog "or manually: $ kcmshell5 kcm_networkmanagement"
+ fi
+}