summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2022-07-12 17:32:28 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2022-07-13 11:15:57 +0200
commit80d992eef0d811a310775c88ad337a9b1d806282 (patch)
tree9bd68635d6a864dc3bd05b26467bd2a2979d7c1f /kde-plasma/plasma-thunderbolt/plasma-thunderbolt-5.24.6.ebuild
parentkde-plasma/plasma-systemmonitor: 5.24.6 version bump (diff)
downloadgentoo-80d992eef0d811a310775c88ad337a9b1d806282.tar.gz
gentoo-80d992eef0d811a310775c88ad337a9b1d806282.tar.bz2
gentoo-80d992eef0d811a310775c88ad337a9b1d806282.zip
kde-plasma/plasma-thunderbolt: 5.24.6 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma/plasma-thunderbolt/plasma-thunderbolt-5.24.6.ebuild')
-rw-r--r--kde-plasma/plasma-thunderbolt/plasma-thunderbolt-5.24.6.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/kde-plasma/plasma-thunderbolt/plasma-thunderbolt-5.24.6.ebuild b/kde-plasma/plasma-thunderbolt/plasma-thunderbolt-5.24.6.ebuild
new file mode 100644
index 000000000000..b00c8cbc647c
--- /dev/null
+++ b/kde-plasma/plasma-thunderbolt/plasma-thunderbolt-5.24.6.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_TEST="true"
+KFMIN=5.92.0
+PVCUT=$(ver_cut 1-3)
+QTMIN=5.15.4
+inherit ecm plasma.kde.org
+
+DESCRIPTION="Plasma integration for controlling Thunderbolt devices"
+HOMEPAGE="https://invent.kde.org/plasma/plasma-thunderbolt"
+
+LICENSE="|| ( GPL-2 GPL-3+ )"
+SLOT="5"
+KEYWORDS="~amd64 ~riscv ~x86"
+IUSE=""
+
+# tests require DBus
+RESTRICT="test"
+
+DEPEND="
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=kde-frameworks/kcmutils-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/kdbusaddons-${KFMIN}:5
+ >=kde-frameworks/kdeclarative-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/knotifications-${KFMIN}:5
+"
+RDEPEND="${DEPEND}
+ >=dev-qt/qtquickcontrols2-${QTMIN}:5
+ >=kde-frameworks/kirigami-${KFMIN}:5
+ sys-apps/bolt
+"