summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-09-22 22:53:47 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2021-09-22 23:59:09 +0200
commit61988d92de81544b00167a289258360b61c7261e (patch)
treeb2ba42049c2890caaf5c562d8094b219a20b3e3f /kde-plasma/plasma-workspace
parentmedia-libs/libsoundtouch: Stabilize 2.3.0 ppc, #814290 (diff)
downloadgentoo-61988d92de81544b00167a289258360b61c7261e.tar.gz
gentoo-61988d92de81544b00167a289258360b61c7261e.tar.bz2
gentoo-61988d92de81544b00167a289258360b61c7261e.zip
kde-plasma/plasma-workspace: Fix krunner cwd, device notifications
krunner starts applications with cwd "/" with init system other than systemd KDE-bug: https://bugs.kde.org/show_bug.cgi?id=432975 Disk & Devices applet doesn't show removable devices after eject and reconnect Upstream commit 61e2ea2323ae63c5805c87353701ba6fb722205a KDE-bug: https://bugs.kde.org/show_bug.cgi?id=438874 Thanks-to: Eric F. Garioud <eric-f.garioud@wanadoo.fr> Thanks-to: Andrea Arcangeli <aarcange@redhat.com> Bug: https://bugs.gentoo.org/767478 Bug: https://bugs.gentoo.org/814284 Package-Manager: Portage-3.0.23, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma/plasma-workspace')
-rw-r--r--kde-plasma/plasma-workspace/files/plasma-workspace-5.22.5-fix-hotplug-notifications.patch33
-rw-r--r--kde-plasma/plasma-workspace/files/plasma-workspace-5.22.5-krunner-cwd-at-home.patch30
-rw-r--r--kde-plasma/plasma-workspace/plasma-workspace-5.22.5-r2.ebuild210
3 files changed, 273 insertions, 0 deletions
diff --git a/kde-plasma/plasma-workspace/files/plasma-workspace-5.22.5-fix-hotplug-notifications.patch b/kde-plasma/plasma-workspace/files/plasma-workspace-5.22.5-fix-hotplug-notifications.patch
new file mode 100644
index 000000000000..e7cd0627a269
--- /dev/null
+++ b/kde-plasma/plasma-workspace/files/plasma-workspace-5.22.5-fix-hotplug-notifications.patch
@@ -0,0 +1,33 @@
+From 61e2ea2323ae63c5805c87353701ba6fb722205a Mon Sep 17 00:00:00 2001
+From: Fabio Bas <fabio.bas@officineinformatiche.net>
+Date: Fri, 3 Sep 2021 19:23:12 +0200
+Subject: [PATCH] Update solid connectedSources when a new source gets added by
+ hotplug BUG: 438874
+
+---
+ applets/devicenotifier/package/contents/ui/devicenotifier.qml | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/applets/devicenotifier/package/contents/ui/devicenotifier.qml b/applets/devicenotifier/package/contents/ui/devicenotifier.qml
+index a1dc20b83..404ae95e6 100644
+--- a/applets/devicenotifier/package/contents/ui/devicenotifier.qml
++++ b/applets/devicenotifier/package/contents/ui/devicenotifier.qml
+@@ -75,6 +75,7 @@ Item {
+ onSourceAdded: {
+ disconnectSource(source);
+ connectSource(source);
++ sdSource.connectedSources = sources
+ }
+ onSourceRemoved: {
+ disconnectSource(source);
+@@ -98,7 +99,6 @@ Item {
+ PlasmaCore.DataSource {
+ id: sdSource
+ engine: "soliddevice"
+- connectedSources: hpSource.sources
+ interval: 0
+ property string last
+ onSourceAdded: {
+--
+GitLab
+
diff --git a/kde-plasma/plasma-workspace/files/plasma-workspace-5.22.5-krunner-cwd-at-home.patch b/kde-plasma/plasma-workspace/files/plasma-workspace-5.22.5-krunner-cwd-at-home.patch
new file mode 100644
index 000000000000..27db136c2949
--- /dev/null
+++ b/kde-plasma/plasma-workspace/files/plasma-workspace-5.22.5-krunner-cwd-at-home.patch
@@ -0,0 +1,30 @@
+Commit 7ca34e0baa7fa65efc929eee5b6b0c3d2104db8e already reverted one
+change that caused the cwd of all apps spawned by krunner to
+erroneously be set to the root dir.
+
+That regressions is back so it's more robust to fix in within krunner.
+
+Signed-off-by: Andrea Arcangeli <aarcange@redhat.com>
+---
+ krunner/main.cpp | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/krunner/main.cpp b/krunner/main.cpp
+index 4593687ca..fa4a62ac4 100644
+--- a/krunner/main.cpp
++++ b/krunner/main.cpp
+@@ -12,6 +12,7 @@
+ #include <QDBusConnection>
+ #include <QDBusMessage>
+ #include <QDebug>
++#include <QDir>
+ #include <QQuickWindow>
+ #include <QSessionManager>
+ #include <QUrl>
+@@ -112,5 +113,6 @@ int main(int argc, char **argv)
+ }
+ });
+
++ QDir::setCurrent(QDir::homePath());
+ return app.exec();
+ }
diff --git a/kde-plasma/plasma-workspace/plasma-workspace-5.22.5-r2.ebuild b/kde-plasma/plasma-workspace/plasma-workspace-5.22.5-r2.ebuild
new file mode 100644
index 000000000000..2a5454791b8e
--- /dev/null
+++ b/kde-plasma/plasma-workspace/plasma-workspace-5.22.5-r2.ebuild
@@ -0,0 +1,210 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_HANDBOOK="forceoptional"
+ECM_TEST="forceoptional"
+KFMIN=5.82.0
+PVCUT=$(ver_cut 1-3)
+QTMIN=5.15.2
+VIRTUALX_REQUIRED="test"
+inherit ecm kde.org
+
+DESCRIPTION="KDE Plasma workspace"
+
+LICENSE="GPL-2" # TODO: CHECK
+SLOT="5"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="appstream +calculator +calendar +fontconfig geolocation gps screencast
++semantic-desktop systemd telemetry"
+
+REQUIRED_USE="gps? ( geolocation )"
+RESTRICT="test"
+
+COMMON_DEPEND="
+ >=dev-libs/wayland-1.15
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtdeclarative-${QTMIN}:5[widgets]
+ >=dev-qt/qtgui-${QTMIN}:5=[jpeg,libinput]
+ >=dev-qt/qtnetwork-${QTMIN}:5
+ >=dev-qt/qtsql-${QTMIN}:5
+ >=dev-qt/qtsvg-${QTMIN}:5
+ >=dev-qt/qtwayland-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=dev-qt/qtx11extras-${QTMIN}:5
+ >=dev-qt/qtxml-${QTMIN}:5
+ >=kde-frameworks/kactivities-${KFMIN}:5
+ >=kde-frameworks/kactivities-stats-${KFMIN}:5
+ >=kde-frameworks/karchive-${KFMIN}:5
+ >=kde-frameworks/kauth-${KFMIN}:5
+ >=kde-frameworks/kbookmarks-${KFMIN}:5
+ >=kde-frameworks/kcompletion-${KFMIN}:5
+ >=kde-frameworks/kconfig-${KFMIN}:5
+ >=kde-frameworks/kconfigwidgets-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/kcrash-${KFMIN}:5
+ >=kde-frameworks/kdbusaddons-${KFMIN}:5
+ >=kde-frameworks/kdeclarative-${KFMIN}:5
+ >=kde-frameworks/kded-${KFMIN}:5
+ >=kde-frameworks/kglobalaccel-${KFMIN}:5
+ >=kde-frameworks/kguiaddons-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kiconthemes-${KFMIN}:5
+ >=kde-frameworks/kidletime-${KFMIN}:5
+ >=kde-frameworks/kinit-${KFMIN}:5
+ >=kde-frameworks/kio-${KFMIN}:5
+ >=kde-frameworks/kitemmodels-${KFMIN}:5
+ >=kde-frameworks/kitemviews-${KFMIN}:5
+ >=kde-frameworks/kjobwidgets-${KFMIN}:5
+ >=kde-frameworks/knewstuff-${KFMIN}:5
+ >=kde-frameworks/knotifications-${KFMIN}:5
+ >=kde-frameworks/knotifyconfig-${KFMIN}:5
+ >=kde-frameworks/kpackage-${KFMIN}:5
+ >=kde-frameworks/kpeople-${KFMIN}:5
+ >=kde-frameworks/krunner-${KFMIN}:5
+ >=kde-frameworks/kservice-${KFMIN}:5
+ >=kde-frameworks/ktexteditor-${KFMIN}:5
+ >=kde-frameworks/ktextwidgets-${KFMIN}:5
+ >=kde-frameworks/kunitconversion-${KFMIN}:5
+ >=kde-frameworks/kwallet-${KFMIN}:5
+ >=kde-frameworks/kwayland-${KFMIN}:5
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:5
+ >=kde-frameworks/kwindowsystem-${KFMIN}:5
+ >=kde-frameworks/kxmlgui-${KFMIN}:5
+ >=kde-frameworks/plasma-${KFMIN}:5
+ >=kde-frameworks/prison-${KFMIN}:5[qml]
+ >=kde-frameworks/solid-${KFMIN}:5
+ >=kde-plasma/breeze-${PVCUT}:5
+ >=kde-plasma/kscreenlocker-${PVCUT}:5
+ >=kde-plasma/kwin-${PVCUT}:5
+ >=kde-plasma/layer-shell-qt-${PVCUT}:5
+ >=kde-plasma/libkscreen-${PVCUT}:5
+ >=kde-plasma/libksysguard-${PVCUT}:5
+ >=kde-plasma/libkworkspace-${PVCUT}:5
+ >=media-libs/phonon-4.11.0
+ sys-libs/zlib
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXau
+ x11-libs/libxcb
+ x11-libs/libXcursor
+ x11-libs/libXfixes
+ x11-libs/libXrender
+ x11-libs/libXtst
+ x11-libs/xcb-util
+ x11-libs/xcb-util-image
+ appstream? ( dev-libs/appstream[qt5] )
+ calculator? ( sci-libs/libqalculate:= )
+ calendar? ( >=kde-frameworks/kholidays-${KFMIN}:5 )
+ fontconfig? (
+ >=dev-qt/qtprintsupport-${QTMIN}:5
+ media-libs/fontconfig
+ x11-libs/libXft
+ x11-libs/xcb-util-image
+ )
+ geolocation? ( >=kde-frameworks/networkmanager-qt-${KFMIN}:5 )
+ gps? ( sci-geosciences/gpsd )
+ screencast? (
+ >=dev-qt/qtgui-${QTMIN}:5=[egl]
+ media-libs/libglvnd
+ >=media-video/pipewire-0.3:=
+ x11-libs/libdrm
+ )
+ semantic-desktop? ( >=kde-frameworks/baloo-${KFMIN}:5 )
+ telemetry? ( dev-libs/kuserfeedback:5 )
+"
+DEPEND="${COMMON_DEPEND}
+ >=dev-libs/plasma-wayland-protocols-1.1.1
+ >=dev-qt/qtconcurrent-${QTMIN}:5
+ >=dev-util/wayland-scanner-1.19.0
+ x11-base/xorg-proto
+ fontconfig? ( x11-libs/libXrender )
+"
+RDEPEND="${COMMON_DEPEND}
+ app-text/iso-codes
+ >=dev-qt/qdbus-${QTMIN}:5
+ >=dev-qt/qtgraphicaleffects-${QTMIN}:5
+ >=dev-qt/qtpaths-${QTMIN}:5
+ >=dev-qt/qtquickcontrols-${QTMIN}:5[widgets]
+ >=dev-qt/qtquickcontrols2-${QTMIN}:5
+ kde-apps/kio-extras:5
+ >=kde-frameworks/kdesu-${KFMIN}:5
+ >=kde-frameworks/kirigami-${KFMIN}:5
+ >=kde-frameworks/kquickcharts-${KFMIN}:5
+ >=kde-plasma/milou-${PVCUT}:5
+ >=kde-plasma/plasma-integration-${PVCUT}:5
+ x11-apps/xmessage
+ x11-apps/xprop
+ x11-apps/xrdb
+ x11-apps/xsetroot
+ systemd? ( sys-apps/dbus[user-session] )
+ !systemd? ( sys-apps/dbus )
+ !<kde-plasma/plasma-desktop-5.21.90:5
+"
+BDEPEND="virtual/pkgconfig"
+PDEPEND=">=kde-plasma/kde-cli-tools-${PVCUT}:5"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-5.21.5-split-libkworkspace.patch" # downstream
+ "${FILESDIR}/${P}-krunner-cwd-at-home.patch" # TODO upstream: KDE-bug 432975, bug 767478
+ "${FILESDIR}/${P}-fix-powermanagement-inhibition.patch" # KDE-bug 433675
+ "${FILESDIR}/${P}-fix-hotplug-notifications.patch" # KDE-bug 438874, bug 814284
+)
+
+src_prepare() {
+ ecm_src_prepare
+
+ cmake_comment_add_subdirectory libkworkspace
+ # delete colliding libkworkspace translations
+ if [[ ${KDE_BUILD_TYPE} = release ]]; then
+ find po -type f -name "*po" -and -name "libkworkspace*" -delete || die
+ fi
+
+ # TODO: try to get a build switch upstreamed
+ if ! use screencast; then
+ sed -e "s/^pkg_check_modules.*PipeWire/#&/" -i CMakeLists.txt || die
+ fi
+
+ # KDE-bug: 433730
+ use calculator ||
+ cmake_run_in runners cmake_comment_add_subdirectory calculator
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_xembed-sni-proxy=OFF
+ -DCMAKE_DISABLE_FIND_PACKAGE_PackageKitQt5=ON
+ $(cmake_use_find_package appstream AppStreamQt)
+ $(cmake_use_find_package calendar KF5Holidays)
+ $(cmake_use_find_package fontconfig Fontconfig)
+ $(cmake_use_find_package geolocation KF5NetworkManagerQt)
+ $(cmake_use_find_package semantic-desktop KF5Baloo)
+ $(cmake_use_find_package telemetry KUserFeedback)
+ )
+
+ use geolocation && mycmakeargs+=( $(cmake_use_find_package gps libgps) )
+
+ ecm_src_configure
+}
+
+src_install() {
+ ecm_src_install
+
+ # default startup and shutdown scripts
+ insinto /etc/xdg/plasma-workspace/env
+ doins "${FILESDIR}"/10-agent-startup.sh
+
+ insinto /etc/xdg/plasma-workspace/shutdown
+ doins "${FILESDIR}"/10-agent-shutdown.sh
+ fperms +x /etc/xdg/plasma-workspace/shutdown/10-agent-shutdown.sh
+}
+
+pkg_postinst () {
+ ecm_pkg_postinst
+
+ elog "To enable gpg-agent and/or ssh-agent in Plasma sessions,"
+ elog "edit ${EPREFIX}/etc/xdg/plasma-workspace/env/10-agent-startup.sh"
+ elog "and ${EPREFIX}/etc/xdg/plasma-workspace/shutdown/10-agent-shutdown.sh"
+}