summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2022-11-08 16:56:58 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2022-11-08 17:00:01 +0100
commit6f1e5f871077bc8484c0fd3815333ab90800c7ff (patch)
treea6a3da7e3e5d2461b40d5b330ba6483926a9c5ce /kde-plasma/xdg-desktop-portal-kde/xdg-desktop-portal-kde-5.26.3.ebuild
parentkde-plasma/systemsettings: 5.26.3 version bump (diff)
downloadgentoo-6f1e5f871077bc8484c0fd3815333ab90800c7ff.tar.gz
gentoo-6f1e5f871077bc8484c0fd3815333ab90800c7ff.tar.bz2
gentoo-6f1e5f871077bc8484c0fd3815333ab90800c7ff.zip
kde-plasma/xdg-desktop-portal-kde: 5.26.3 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma/xdg-desktop-portal-kde/xdg-desktop-portal-kde-5.26.3.ebuild')
-rw-r--r--kde-plasma/xdg-desktop-portal-kde/xdg-desktop-portal-kde-5.26.3.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/kde-plasma/xdg-desktop-portal-kde/xdg-desktop-portal-kde-5.26.3.ebuild b/kde-plasma/xdg-desktop-portal-kde/xdg-desktop-portal-kde-5.26.3.ebuild
new file mode 100644
index 000000000000..24aeacb55647
--- /dev/null
+++ b/kde-plasma/xdg-desktop-portal-kde/xdg-desktop-portal-kde-5.26.3.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+KFMIN=5.99.0
+PVCUT=$(ver_cut 1-3)
+QTMIN=5.15.5
+inherit ecm plasma.kde.org
+
+DESCRIPTION="Backend implementation for xdg-desktop-portal that is using Qt/KDE Frameworks"
+
+LICENSE="LGPL-2+"
+SLOT="5"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv"
+IUSE=""
+
+COMMON_DEPEND="
+ >=dev-libs/wayland-1.15
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtprintsupport-${QTMIN}:5[cups]
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5[dbus]
+ >=kde-frameworks/kconfig-${KFMIN}:5
+ >=kde-frameworks/kdeclarative-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kiconthemes-${KFMIN}:5
+ >=kde-frameworks/kio-${KFMIN}:5
+ >=kde-frameworks/kirigami-${KFMIN}:5
+ >=kde-frameworks/knotifications-${KFMIN}:5
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:5
+ >=kde-frameworks/kwindowsystem-${KFMIN}:5
+ >=kde-frameworks/kwayland-${KFMIN}:5
+ >=kde-frameworks/plasma-${KFMIN}:5
+"
+DEPEND="${COMMON_DEPEND}
+ >=dev-libs/plasma-wayland-protocols-1.7.0
+ >=dev-qt/qtconcurrent-${QTMIN}:5
+"
+RDEPEND="${COMMON_DEPEND}
+ kde-misc/kio-fuse:5
+ sys-apps/xdg-desktop-portal
+"
+BDEPEND=">=dev-qt/qtwaylandscanner-${QTMIN}:5"