summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-10-23 12:16:38 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-10-23 18:46:25 +0200
commit04b7a5abc61721150cbdaefb391c4365903d11a1 (patch)
tree17167a551e6bc11df15961a74f7e0e1dbbb04cf6 /kde-plasma/xdg-desktop-portal-kde
parentapp-crypt/argon2: Use optimized code on x86 only (diff)
downloadgentoo-04b7a5abc61721150cbdaefb391c4365903d11a1.tar.gz
gentoo-04b7a5abc61721150cbdaefb391c4365903d11a1.tar.bz2
gentoo-04b7a5abc61721150cbdaefb391c4365903d11a1.zip
kde-plasma: KDE Plasma 5.17.1 version bump
Package-Manager: Portage-2.3.76, Repoman-2.3.16 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma/xdg-desktop-portal-kde')
-rw-r--r--kde-plasma/xdg-desktop-portal-kde/Manifest1
-rw-r--r--kde-plasma/xdg-desktop-portal-kde/xdg-desktop-portal-kde-5.17.1.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/kde-plasma/xdg-desktop-portal-kde/Manifest b/kde-plasma/xdg-desktop-portal-kde/Manifest
index c416a6ce2a6f..64cf44edde99 100644
--- a/kde-plasma/xdg-desktop-portal-kde/Manifest
+++ b/kde-plasma/xdg-desktop-portal-kde/Manifest
@@ -1 +1,2 @@
DIST xdg-desktop-portal-kde-5.16.5.tar.xz 61576 BLAKE2B b9d186e3269aae6c079bae8abf01e790300da5ba255ecaa37ca2b139bb5c017f0cc118adbaca8d4f846cfbf5d563d574cddca4703e9d917f7001468b27734db6 SHA512 381298cc001795902343512f8bb08c363acfb6e3ef398e0f170f305572ca9a5caaf458e85b6f48ac84bcd963a34e535c666b0ddc1bb910a894a8b8de8801467e
+DIST xdg-desktop-portal-kde-5.17.1.tar.xz 62660 BLAKE2B 2a05547c3f269e9ffceb4e5cb9f20f8771dbf5ec8502d7c3ae1d54205fad7e12f02c462a2048dbff390b27fc498f2ea69c14ee4fe1ca96450be7f2661f9082a8 SHA512 9a9ebae7a0abdcd40f3ecb4965d04cc4506238f4685fea16e614c52bc82c4c1583d18d04e0708d7c5eac90df2635b86675e4bf9e73fb83b37d2700279dcd3c03
diff --git a/kde-plasma/xdg-desktop-portal-kde/xdg-desktop-portal-kde-5.17.1.ebuild b/kde-plasma/xdg-desktop-portal-kde/xdg-desktop-portal-kde-5.17.1.ebuild
new file mode 100644
index 000000000000..ac89d1e1c4f0
--- /dev/null
+++ b/kde-plasma/xdg-desktop-portal-kde/xdg-desktop-portal-kde-5.17.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Backend implementation for xdg-desktop-portal that is using Qt/KDE Frameworks"
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="screencast"
+
+COMMON_DEPEND="
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtprintsupport 'cups')
+ $(add_qt_dep qtwidgets)
+ screencast? (
+ dev-libs/glib:2
+ media-libs/libepoxy
+ media-libs/mesa[gbm]
+ media-video/pipewire:=
+ )
+"
+DEPEND="${COMMON_DEPEND}
+ $(add_frameworks_dep kwayland)
+ $(add_qt_dep qtconcurrent)
+"
+RDEPEND="${COMMON_DEPEND}
+ screencast? ( sys-apps/xdg-desktop-portal[screencast] )
+ !screencast? ( sys-apps/xdg-desktop-portal )
+"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package screencast GLIB2)
+ $(cmake-utils_use_find_package screencast PipeWire)
+ $(cmake-utils_use_find_package screencast GBM)
+ $(cmake-utils_use_find_package screencast Epoxy)
+ )
+ kde5_src_configure
+}