summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-09-03 15:30:16 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-09-03 18:39:51 +0200
commit0be4355642c0cdc8d1c79a1d5c297a8af6f87cde (patch)
tree65ba6d089b154a30a28b2d60ba3d324776d0b418 /kde-plasma/xdg-desktop-portal-kde
parentprofiles/arch/sparc: enable ieee1275 support for grub (diff)
downloadgentoo-0be4355642c0cdc8d1c79a1d5c297a8af6f87cde.tar.gz
gentoo-0be4355642c0cdc8d1c79a1d5c297a8af6f87cde.tar.bz2
gentoo-0be4355642c0cdc8d1c79a1d5c297a8af6f87cde.zip
kde-plasma: Add KDE Plasma 5.16.5
Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma/xdg-desktop-portal-kde')
-rw-r--r--kde-plasma/xdg-desktop-portal-kde/Manifest1
-rw-r--r--kde-plasma/xdg-desktop-portal-kde/xdg-desktop-portal-kde-5.16.5.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/kde-plasma/xdg-desktop-portal-kde/Manifest b/kde-plasma/xdg-desktop-portal-kde/Manifest
index c48694e531fb..1064764f107a 100644
--- a/kde-plasma/xdg-desktop-portal-kde/Manifest
+++ b/kde-plasma/xdg-desktop-portal-kde/Manifest
@@ -1,2 +1,3 @@
DIST xdg-desktop-portal-kde-5.15.5.tar.xz 60292 BLAKE2B 5e0f07ec5e57d978c444fc65e1aa70b04dea458d34d9c091da5699501995499fb877e90ae0272634fc7dd62fa192a99d7f800bf7627612e2eafb6763e3f732ca SHA512 f575c9a5273cef3ab34a7eb4be520cdec3344fd6729f79d4475f200a177fba40b265815136c4af18ce6e48c9736bb835af4d972c5563171ead2e4390e938fcbf
DIST xdg-desktop-portal-kde-5.16.4.tar.xz 61804 BLAKE2B b32366b815c076b24350c65fd86ad7cbbf0063c9167b5694b897257b4dc1aa78fd9e4bd2be34027d9f9b8f3514503334802475fb1e6410e8c60c0240b055ce76 SHA512 401d25bff09c844f9f214234bc8a2ce0975f03adc959079744a4550f56e4b2d38db2105e1392559c681ff04eb9e586d1916cbf7fc59ba6758e610eba927c8009
+DIST xdg-desktop-portal-kde-5.16.5.tar.xz 61616 BLAKE2B 938b2122807fdf075dfda4f11dad0033a75b079b443f419b0c0f52c53439ded6446a260f1d04487502e0ad1b12246bf3a3acc62c3fb3a3421bd5b0bd7c09b729 SHA512 5fa83616a880502646f18886b82fc44419867c1c373fc8095aee6c752900e38980e56b04c87207e030838ce4b75bf35bf16f680acf1f6c22ec5c8a10cbaec30e
diff --git a/kde-plasma/xdg-desktop-portal-kde/xdg-desktop-portal-kde-5.16.5.ebuild b/kde-plasma/xdg-desktop-portal-kde/xdg-desktop-portal-kde-5.16.5.ebuild
new file mode 100644
index 000000000000..ac89d1e1c4f0
--- /dev/null
+++ b/kde-plasma/xdg-desktop-portal-kde/xdg-desktop-portal-kde-5.16.5.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Backend implementation for xdg-desktop-portal that is using Qt/KDE Frameworks"
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="screencast"
+
+COMMON_DEPEND="
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtprintsupport 'cups')
+ $(add_qt_dep qtwidgets)
+ screencast? (
+ dev-libs/glib:2
+ media-libs/libepoxy
+ media-libs/mesa[gbm]
+ media-video/pipewire:=
+ )
+"
+DEPEND="${COMMON_DEPEND}
+ $(add_frameworks_dep kwayland)
+ $(add_qt_dep qtconcurrent)
+"
+RDEPEND="${COMMON_DEPEND}
+ screencast? ( sys-apps/xdg-desktop-portal[screencast] )
+ !screencast? ( sys-apps/xdg-desktop-portal )
+"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package screencast GLIB2)
+ $(cmake-utils_use_find_package screencast PipeWire)
+ $(cmake-utils_use_find_package screencast GBM)
+ $(cmake-utils_use_find_package screencast Epoxy)
+ )
+ kde5_src_configure
+}