summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-02-13 11:37:16 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2023-02-14 12:26:25 +0100
commit7fd547a4bad6fe6b3040c44957309c116c1fd6c0 (patch)
treedecc54b08fcc29962eab7d42be1cf2d0ffb8392a /kde-plasma/xdg-desktop-portal-kde
parentkde-plasma/systemsettings: 5.27.0 version bump (diff)
downloadgentoo-7fd547a4bad6fe6b3040c44957309c116c1fd6c0.tar.gz
gentoo-7fd547a4bad6fe6b3040c44957309c116c1fd6c0.tar.bz2
gentoo-7fd547a4bad6fe6b3040c44957309c116c1fd6c0.zip
kde-plasma/xdg-desktop-portal-kde: 5.27.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma/xdg-desktop-portal-kde')
-rw-r--r--kde-plasma/xdg-desktop-portal-kde/Manifest1
-rw-r--r--kde-plasma/xdg-desktop-portal-kde/xdg-desktop-portal-kde-5.27.0.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/kde-plasma/xdg-desktop-portal-kde/Manifest b/kde-plasma/xdg-desktop-portal-kde/Manifest
index 59a2e78622a8..74bd5d1ec362 100644
--- a/kde-plasma/xdg-desktop-portal-kde/Manifest
+++ b/kde-plasma/xdg-desktop-portal-kde/Manifest
@@ -1,2 +1,3 @@
DIST xdg-desktop-portal-kde-5.26.5.tar.xz 110164 BLAKE2B 0eff7ac5fadce31831b9479fc812aede2f540917b186da0c71f9e85a4277923fd39e68ff4acb488772905cc296644b7a5e2f8c0fa12ef7e5cd7d5f7ccaf843d8 SHA512 d79ea70b476e08e0ff554e7a9b261abca21b07a177a576cf4c6e8d36b08dc8f48f5ccebf25d72b293439fafce53ae29e77b6289fce1ccccfabe69a5d21f6389c
DIST xdg-desktop-portal-kde-5.26.90.tar.xz 127416 BLAKE2B 56fc2beb2e46896d434de4f4b2fd4a36033662b0d054c95249d4eaeda96ddbbb6a3f09f7ab46400746d416c87e197b7b83563ff66fdfdbe28c312a72ab0589bf SHA512 286e12016aceb2dd7d72e62d40a623b12e0cf5aaa43d29b4f20959acc8e4eb6df4eac774d46179320ad65356561b140c7b17d43f1341d057e0208d32dfc76ca0
+DIST xdg-desktop-portal-kde-5.27.0.tar.xz 128024 BLAKE2B d8965377a71aad63315af68818e91be879f81dd85eae9387558b07d610eb28760390b2a262bf6bcdd2e01773b0acf556d25fc291efe716a6c5e7a365fb66a9dd SHA512 231f7168eaea5726289193bd84a4ce9cfbdcc13f230f9ab3e5030687277963746ad0fdb9af7f8a54b4d06ccaea675d8bcab9fdfdce509d64cce853c45d9cb383
diff --git a/kde-plasma/xdg-desktop-portal-kde/xdg-desktop-portal-kde-5.27.0.ebuild b/kde-plasma/xdg-desktop-portal-kde/xdg-desktop-portal-kde-5.27.0.ebuild
new file mode 100644
index 000000000000..73acc3e14c3d
--- /dev/null
+++ b/kde-plasma/xdg-desktop-portal-kde/xdg-desktop-portal-kde-5.27.0.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_TEST="forceoptional"
+KFMIN=5.102.0
+PVCUT=$(ver_cut 1-3)
+QTMIN=5.15.7
+inherit ecm plasma.kde.org
+
+DESCRIPTION="Backend implementation for xdg-desktop-portal that is using Qt/KDE Frameworks"
+
+LICENSE="LGPL-2+"
+SLOT="5"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+IUSE=""
+
+# dev-qt/qtgui: QtXkbCommonSupport is provided by either IUSE libinput or X
+COMMON_DEPEND="
+ >=dev-libs/wayland-1.15
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ || (
+ >=dev-qt/qtgui-${QTMIN}:5[libinput]
+ >=dev-qt/qtgui-${QTMIN}:5[X]
+ )
+ >=dev-qt/qtprintsupport-${QTMIN}:5[cups]
+ >=dev-qt/qtwayland-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5[dbus]
+ >=kde-frameworks/kconfig-${KFMIN}:5
+ >=kde-frameworks/kdeclarative-${KFMIN}:5
+ >=kde-frameworks/kglobalaccel-${KFMIN}:5
+ >=kde-frameworks/kguiaddons-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kiconthemes-${KFMIN}:5
+ >=kde-frameworks/kio-${KFMIN}:5
+ >=kde-frameworks/kirigami-${KFMIN}:5
+ >=kde-frameworks/knotifications-${KFMIN}:5
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:5
+ >=kde-frameworks/kwindowsystem-${KFMIN}:5
+ >=kde-frameworks/kwayland-${KFMIN}:5
+ >=kde-frameworks/plasma-${KFMIN}:5
+ x11-libs/libxkbcommon
+"
+DEPEND="${COMMON_DEPEND}
+ >=dev-libs/plasma-wayland-protocols-1.7.0
+ >=dev-libs/wayland-protocols-1.25
+ >=dev-qt/qtconcurrent-${QTMIN}:5
+"
+RDEPEND="${COMMON_DEPEND}
+ kde-misc/kio-fuse:5
+ sys-apps/xdg-desktop-portal
+"
+BDEPEND="
+ >=dev-qt/qtwaylandscanner-${QTMIN}:5
+ virtual/pkgconfig
+"