summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2022-03-29 17:38:52 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2022-03-29 17:56:25 +0200
commit1b6436a4d559957920569d0303fc3ed5b99bfb05 (patch)
tree4ca4a480d8fbb52f8ceaa8614f7486385838b452 /kde-plasma
parentkde-plasma/kscreenlocker: 5.24.4 version bump (diff)
downloadgentoo-1b6436a4d559957920569d0303fc3ed5b99bfb05.tar.gz
gentoo-1b6436a4d559957920569d0303fc3ed5b99bfb05.tar.bz2
gentoo-1b6436a4d559957920569d0303fc3ed5b99bfb05.zip
kde-plasma/ksshaskpass: 5.24.4 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma')
-rw-r--r--kde-plasma/ksshaskpass/Manifest1
-rw-r--r--kde-plasma/ksshaskpass/ksshaskpass-5.24.4.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/kde-plasma/ksshaskpass/Manifest b/kde-plasma/ksshaskpass/Manifest
index 07f9eb495dd6..d3064fd3d7ab 100644
--- a/kde-plasma/ksshaskpass/Manifest
+++ b/kde-plasma/ksshaskpass/Manifest
@@ -1,2 +1,3 @@
DIST ksshaskpass-5.23.5.tar.xz 24068 BLAKE2B 42b366d66690e0bc2a0bd1abf78fc9ded0f62c71b3abd512601805ca05828449808ff87bed3dbd3cb2e421d8b50b794c207def51a73e5c0a2a53b79a51e64953 SHA512 e1bf158cc199406648afae537c73178aa5230a108371cb0d4d150849c16201d225a863c5154d52ab5b09a947671a2d91ae33dcb227d9a28c31a4d4d4f404c817
DIST ksshaskpass-5.24.3.tar.xz 24716 BLAKE2B b66c38b60df0ff0f9825b64a1021f6873bfa42924f66ee21cb8962ed8f3f73ec20e0f1cf5e7b765ae5c86c6970a08f1f62c066c65bfea49ad9cfc8bd349e4c67 SHA512 3d08341c55eed27555775e9bb9dea84845641b66e6ee110cdb28d08775107aa88434c48892d5de0529216ad89c3b0035c3e97b98c53e55a82d6f07d80bc7f75a
+DIST ksshaskpass-5.24.4.tar.xz 24720 BLAKE2B fc204675ed6590e263b97b10490b1d5e60e97cdabf76c3bd7effa8c9106182740f90e400232a865cd12dd9db2d246a5f59288d3e69e6cdcb48c04fe2e68a1138 SHA512 181788f8b8ce72f3d0e17d2d8cf46eb5ca31eef5533d275f86b8f573c3b1365eaea48a9fb940177c701b071caf241ab4ca7cbf1d0e2bda29e0d153b7574cf79d
diff --git a/kde-plasma/ksshaskpass/ksshaskpass-5.24.4.ebuild b/kde-plasma/ksshaskpass/ksshaskpass-5.24.4.ebuild
new file mode 100644
index 000000000000..6cc8bba6f520
--- /dev/null
+++ b/kde-plasma/ksshaskpass/ksshaskpass-5.24.4.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+KFMIN=5.90.0
+QTMIN=5.15.2
+inherit ecm kde.org
+
+DESCRIPTION="Implementation of ssh-askpass with KDE Wallet integration"
+HOMEPAGE+=" https://invent.kde.org/plasma/ksshaskpass"
+
+LICENSE="GPL-2" # TODO: CHECK
+SLOT="5"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+IUSE=""
+
+DEPEND="
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kwallet-${KFMIN}:5
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:5
+"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ ecm_src_install
+
+ insinto /etc/xdg/plasma-workspace/env/
+ doins "${FILESDIR}/05-ksshaskpass.sh"
+}
+
+pkg_postinst() {
+ ecm_pkg_postinst
+
+ elog "In order to have ssh-agent start with Plasma 5,"
+ elog "edit /etc/xdg/plasma-workspace/env/10-agent-startup.sh"
+ elog "and uncomment the lines enabling ssh-agent."
+ elog
+ elog "If you do so, do not forget to uncomment the respective"
+ elog "lines in /etc/xdg/plasma-workspace/shutdown/10-agent-shutdown.sh"
+ elog "to properly kill the agent when the session ends."
+ elog
+ elog "${PN} has been installed as your default askpass application"
+ elog "for Plasma 5 sessions."
+ elog "If that's not desired, select the one you want to use in"
+ elog "/etc/xdg/plasma-workspace/env/05-ksshaskpass.sh"
+
+ # Clean up pre-5.17.4 dirs
+ rmdir -v "${EROOT}"/etc/plasma{/startup,} 2> /dev/null
+}