summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-12-17 22:47:30 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-12-18 00:48:40 +0100
commit4c69321d140593a2dd786a6bef5c8cafffa8741f (patch)
tree4d75be1dacae571b7771b3d048d41e224c83ca5d /kde-plasma
parentkde-plasma/plasma-integration: Resize file dialog window before size restore (diff)
downloadgentoo-4c69321d140593a2dd786a6bef5c8cafffa8741f.tar.gz
gentoo-4c69321d140593a2dd786a6bef5c8cafffa8741f.tar.bz2
gentoo-4c69321d140593a2dd786a6bef5c8cafffa8741f.zip
kde-plasma/kwin: Possible fix for KDecoration crash in systemsettings
KDE-Bug: https://bugs.kde.org/show_bug.cgi?id=411166 Package-Manager: Portage-2.3.82, Repoman-2.3.20 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma')
-rw-r--r--kde-plasma/kwin/files/kwin-5.17.4-possible-kdecoration-crash-in-systemsettings.patch58
-rw-r--r--kde-plasma/kwin/kwin-5.17.4-r1.ebuild111
2 files changed, 169 insertions, 0 deletions
diff --git a/kde-plasma/kwin/files/kwin-5.17.4-possible-kdecoration-crash-in-systemsettings.patch b/kde-plasma/kwin/files/kwin-5.17.4-possible-kdecoration-crash-in-systemsettings.patch
new file mode 100644
index 000000000000..b738fd7b013f
--- /dev/null
+++ b/kde-plasma/kwin/files/kwin-5.17.4-possible-kdecoration-crash-in-systemsettings.patch
@@ -0,0 +1,58 @@
+From 1a13015d2d1de3ffb9450143480e729057992c45 Mon Sep 17 00:00:00 2001
+From: David Edmundson <kde@davidedmundson.co.uk>
+Date: Sat, 14 Dec 2019 16:08:16 +0100
+Subject: Possible fix for KDecoration crash in systemsettings
+
+Summary:
+I could never reproduce the crash, but we know from gdb that it's from
+the decorationSettings object
+
+We are setting the same QObject instance as a context property in
+multiple contexts at once. This is already slightly odd especially from the POV of
+Qt's internal property cache.
+
+Given we want one object to be exposed to all contexts, we can expose it
+to the parent context only once and achieve the same result in a simpler
+way.
+
+BUG: 411166
+
+Test Plan:
+Verified opening and closing system settings still worked for me.
+I could never reproduce the original crash.
+
+Reviewers: #kwin, ngraham
+
+Reviewed By: ngraham
+
+Subscribers: ngraham, apol, kwin
+
+Tags: #kwin
+
+Differential Revision: https://phabricator.kde.org/D25913
+---
+ plugins/kdecorations/aurorae/src/aurorae.cpp | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/plugins/kdecorations/aurorae/src/aurorae.cpp b/plugins/kdecorations/aurorae/src/aurorae.cpp
+index f3ad059..c37f00e 100644
+--- a/plugins/kdecorations/aurorae/src/aurorae.cpp
++++ b/plugins/kdecorations/aurorae/src/aurorae.cpp
+@@ -262,6 +262,7 @@ Decoration::Decoration(QObject *parent, const QVariantList &args)
+ {
+ m_themeName = findTheme(args);
+ Helper::instance().ref();
++ Helper::instance().rootContext()->setContextProperty(QStringLiteral("decorationSettings"), settings().data());
+ }
+
+ Decoration::~Decoration()
+@@ -289,7 +290,6 @@ void Decoration::init()
+
+ m_qmlContext = new QQmlContext(Helper::instance().rootContext(), this);
+ m_qmlContext->setContextProperty(QStringLiteral("decoration"), this);
+- m_qmlContext->setContextProperty(QStringLiteral("decorationSettings"), s.data());
+ auto component = Helper::instance().component(m_themeName);
+ if (!component) {
+ return;
+--
+cgit v1.1
diff --git a/kde-plasma/kwin/kwin-5.17.4-r1.ebuild b/kde-plasma/kwin/kwin-5.17.4-r1.ebuild
new file mode 100644
index 000000000000..c3c1312bc8da
--- /dev/null
+++ b/kde-plasma/kwin/kwin-5.17.4-r1.ebuild
@@ -0,0 +1,111 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ECM_HANDBOOK="optional"
+ECM_TEST="optional"
+VIRTUALX_REQUIRED="test"
+KFMIN=5.64.0
+PVCUT=$(ver_cut 1-3)
+QTMIN=5.12.3
+inherit ecm kde.org
+
+DESCRIPTION="Flexible, composited Window Manager for windowing systems on Linux"
+LICENSE="GPL-2+"
+SLOT="5"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="caps gles2 multimedia"
+
+COMMON_DEPEND="
+ >=kde-frameworks/kactivities-${KFMIN}:5
+ >=kde-frameworks/kauth-${KFMIN}:5
+ >=kde-frameworks/kcmutils-${KFMIN}:5
+ >=kde-frameworks/kcompletion-${KFMIN}:5
+ >=kde-frameworks/kconfig-${KFMIN}:5
+ >=kde-frameworks/kconfigwidgets-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/kcrash-${KFMIN}:5
+ >=kde-frameworks/kdeclarative-${KFMIN}:5
+ >=kde-frameworks/kglobalaccel-${KFMIN}:5=
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kiconthemes-${KFMIN}:5
+ >=kde-frameworks/kidletime-${KFMIN}:5=
+ >=kde-frameworks/kinit-${KFMIN}:5
+ >=kde-frameworks/kio-${KFMIN}:5
+ >=kde-frameworks/knewstuff-${KFMIN}:5
+ >=kde-frameworks/knotifications-${KFMIN}:5
+ >=kde-frameworks/kpackage-${KFMIN}:5
+ >=kde-frameworks/kservice-${KFMIN}:5
+ >=kde-frameworks/ktextwidgets-${KFMIN}:5
+ >=kde-frameworks/kwayland-${KFMIN}:5
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:5
+ >=kde-frameworks/kwindowsystem-${KFMIN}:5[X]
+ >=kde-frameworks/kxmlgui-${KFMIN}:5
+ >=kde-frameworks/plasma-${KFMIN}:5
+ >=kde-plasma/breeze-${PVCUT}:5
+ >=kde-plasma/kdecoration-${PVCUT}:5
+ >=kde-plasma/kscreenlocker-${PVCUT}:5
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5=[gles2=]
+ >=dev-qt/qtscript-${QTMIN}:5
+ >=dev-qt/qtsensors-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=dev-qt/qtx11extras-${QTMIN}:5
+ >=dev-libs/libinput-1.9
+ >=dev-libs/wayland-1.2
+ media-libs/fontconfig
+ media-libs/freetype
+ media-libs/libepoxy
+ media-libs/mesa[egl,gbm,gles2?,wayland,X(+)]
+ virtual/libudev:=
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXi
+ x11-libs/libdrm
+ >=x11-libs/libxcb-1.10
+ >=x11-libs/libxkbcommon-0.7.0
+ x11-libs/xcb-util-cursor
+ x11-libs/xcb-util-image
+ x11-libs/xcb-util-keysyms
+ x11-libs/xcb-util-wm
+ caps? ( sys-libs/libcap )
+"
+RDEPEND="${COMMON_DEPEND}
+ >=kde-frameworks/kirigami-${KFMIN}:5
+ >=dev-qt/qtquickcontrols-${QTMIN}:5
+ >=dev-qt/qtquickcontrols2-${QTMIN}:5
+ >=dev-qt/qtvirtualkeyboard-${QTMIN}:5
+ multimedia? ( >=dev-qt/qtmultimedia-${QTMIN}:5[gstreamer,qml] )
+"
+DEPEND="${COMMON_DEPEND}
+ >=dev-qt/designer-${QTMIN}:5
+ >=dev-qt/qtconcurrent-${QTMIN}:5
+ x11-base/xorg-proto
+"
+PDEPEND="
+ >=kde-plasma/kde-cli-tools-${PVCUT}:5
+"
+
+RESTRICT+=" test"
+
+PATCHES=( "${FILESDIR}"/${P}-possible-kdecoration-crash-in-systemsettings.patch )
+
+src_prepare() {
+ ecm_src_prepare
+ use multimedia || eapply "${FILESDIR}/${PN}-5.16.80-gstreamer-optional.patch"
+
+ # Access violations, bug #640432
+ sed -e "s/^ecm_find_qmlmodule.*QtMultimedia/#&/" \
+ -i CMakeLists.txt || die
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package caps Libcap)
+ )
+
+ ecm_src_configure
+}