summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-12-06 23:17:48 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2023-12-07 10:05:58 +0100
commitfcca991ff80521fe7b106e31fcd539c153d441cf (patch)
treeeb033ff18be6e5449cced3eaf283e9e8c8bfd304 /kde-plasma
parentkde-plasma/kwallet-pam: 5.27.10 version bump (diff)
downloadgentoo-fcca991ff80521fe7b106e31fcd539c153d441cf.tar.gz
gentoo-fcca991ff80521fe7b106e31fcd539c153d441cf.tar.bz2
gentoo-fcca991ff80521fe7b106e31fcd539c153d441cf.zip
kde-plasma/kwayland-integration: 5.27.10 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma')
-rw-r--r--kde-plasma/kwayland-integration/Manifest1
-rw-r--r--kde-plasma/kwayland-integration/kwayland-integration-5.27.10.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/kde-plasma/kwayland-integration/Manifest b/kde-plasma/kwayland-integration/Manifest
index e220af766d5a..2d7ce375e965 100644
--- a/kde-plasma/kwayland-integration/Manifest
+++ b/kde-plasma/kwayland-integration/Manifest
@@ -1 +1,2 @@
+DIST kwayland-integration-5.27.10.tar.xz 25776 BLAKE2B dbd1b2cedf1128f59318e41036bde63c8062538804a6b26418bce2210860a0b0f1dcbf217f9b823924ec8865b2bc3d6ceae7a06339d8ea1a508d67763e697027 SHA512 c66b08ba2af7675add7d603e0b8bdd20578abfc71af15574c389c8bec9856f309fe856c236f9fc8832e38c0125f5d55a3cc3d649b9d49733ee93d656b9c293fe
DIST kwayland-integration-5.27.9.tar.xz 25776 BLAKE2B dba48b7405edbaa885e1abe938806022546ab5c485f1ef20799399bbd7e97c618a7a2c0755561880f45a28e57b0cd17bb2e219f7af102f86bff638787d4460cf SHA512 aaea32038eb9098387d819e9c9dcff4f5b4634841614a0a5c5db9528a6f51d5197cab5ee24dccfbba400b7c012f6360248b4d8c64948c79ee7a545009a64594f
diff --git a/kde-plasma/kwayland-integration/kwayland-integration-5.27.10.ebuild b/kde-plasma/kwayland-integration/kwayland-integration-5.27.10.ebuild
new file mode 100644
index 000000000000..e17c313843cf
--- /dev/null
+++ b/kde-plasma/kwayland-integration/kwayland-integration-5.27.10.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+KFMIN=5.106.0
+QTMIN=5.15.9
+inherit ecm plasma.kde.org
+
+DESCRIPTION="Provides KWindowSystem integration plugin for Wayland"
+HOMEPAGE="https://invent.kde.org/plasma/kwayland-integration"
+
+LICENSE="LGPL-2.1"
+SLOT="5"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+IUSE=""
+
+# dev-qt/qtgui: QtXkbCommonSupport is provided by either IUSE libinput or X
+# slot ops:
+# dev-qt/qtgui: QtXkbCommonSupportPrivate
+# dev-qt/qtwayland: Qt::WaylandClientPrivate (private/qwayland*_p.h) stuff
+# kde-frameworks/kwindowsystem: Various private headers
+DEPEND="
+ >=dev-libs/wayland-1.15
+ >=dev-qt/qtgui-${QTMIN}:5=
+ || (
+ >=dev-qt/qtgui-${QTMIN}:5[libinput]
+ >=dev-qt/qtgui-${QTMIN}:5[X]
+ )
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=dev-qt/qtwayland-${QTMIN}:5=
+ >=kde-frameworks/kwindowsystem-${KFMIN}:5=
+ >=kde-plasma/kwayland-${KFMIN}:5
+ x11-libs/libxkbcommon
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ >=dev-qt/qtwaylandscanner-${QTMIN}:5
+ dev-util/wayland-scanner
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ ecm_src_prepare
+ ecm_punt_kf_module IdleTime
+ cmake_comment_add_subdirectory autotests # only contains idletime test
+ cmake_run_in src cmake_comment_add_subdirectory idletime
+}