summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authororbea <orbea@riseup.net>2022-07-11 19:28:05 -0700
committerSam James <sam@gentoo.org>2022-07-12 03:32:15 +0100
commit48b7cc4daf05dd7e5d5dc550b4972d4550fbe356 (patch)
treed85da89252118383bc70603486cb8260ab01fb70 /lxde-base/lxappearance/lxappearance-0.6.3-r3.ebuild
parentwww-apache/mod_musicindex: update HOMEPAGE (diff)
downloadgentoo-48b7cc4daf05dd7e5d5dc550b4972d4550fbe356.tar.gz
gentoo-48b7cc4daf05dd7e5d5dc550b4972d4550fbe356.tar.bz2
gentoo-48b7cc4daf05dd7e5d5dc550b4972d4550fbe356.zip
lxde-base/lxappearance: Fix patch
Fixes: https://github.com/gentoo/gentoo/commit/26734c3900e4e41aa7820b6f4afcf30bec26a441 Signed-off-by: orbea <orbea@riseup.net> Closes: https://github.com/gentoo/gentoo/pull/26359 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'lxde-base/lxappearance/lxappearance-0.6.3-r3.ebuild')
-rw-r--r--lxde-base/lxappearance/lxappearance-0.6.3-r3.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/lxde-base/lxappearance/lxappearance-0.6.3-r3.ebuild b/lxde-base/lxappearance/lxappearance-0.6.3-r3.ebuild
new file mode 100644
index 000000000000..bdd7fc588a95
--- /dev/null
+++ b/lxde-base/lxappearance/lxappearance-0.6.3-r3.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="LXDE GTK+ theme switcher"
+HOMEPAGE="https://wiki.lxde.org/en/LXAppearance"
+SRC_URI="mirror://sourceforge/lxde/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~arm ~arm64 ~mips ~ppc ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+IUSE="dbus"
+
+RDEPEND="
+ dev-libs/glib:2
+ x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:3
+ x11-libs/libX11
+ dbus? ( dev-libs/dbus-glib )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_configure() {
+ econf \
+ --enable-gtk3 \
+ $(use_enable dbus)
+}