summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2016-08-14 14:12:24 -0400
committerBrian Evans <grknight@gentoo.org>2016-08-14 14:13:07 -0400
commite793c45267a4028b487fe55a7a46d9fdeaa684f6 (patch)
treeb2e505aefe3285530d2a031915bd6fa8fa751f27 /lxde-base/lxdm/lxdm-0.5.3.ebuild
parentlxde-base/lxdm: Add myself as maintainer (diff)
downloadgentoo-e793c45267a4028b487fe55a7a46d9fdeaa684f6.tar.gz
gentoo-e793c45267a4028b487fe55a7a46d9fdeaa684f6.tar.bz2
gentoo-e793c45267a4028b487fe55a7a46d9fdeaa684f6.zip
lxde-base/lxdm: Version bump
Package-Manager: portage-2.3.0
Diffstat (limited to 'lxde-base/lxdm/lxdm-0.5.3.ebuild')
-rw-r--r--lxde-base/lxdm/lxdm-0.5.3.ebuild67
1 files changed, 67 insertions, 0 deletions
diff --git a/lxde-base/lxdm/lxdm-0.5.3.ebuild b/lxde-base/lxdm/lxdm-0.5.3.ebuild
new file mode 100644
index 000000000000..0665f7b4b28d
--- /dev/null
+++ b/lxde-base/lxdm/lxdm-0.5.3.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit eutils autotools systemd
+
+DESCRIPTION="LXDE Display Manager"
+HOMEPAGE="http://lxde.org"
+SRC_URI="mirror://sourceforge/lxde/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86"
+
+IUSE="consolekit debug gtk3 nls pam"
+
+RDEPEND="consolekit? ( sys-auth/consolekit )
+ x11-libs/libxcb
+ gtk3? ( x11-libs/gtk+:3 )
+ !gtk3? ( x11-libs/gtk+:2 )
+ nls? ( sys-devel/gettext )
+ pam? ( virtual/pam )"
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.40
+ virtual/pkgconfig"
+DOCS=( AUTHORS README TODO )
+
+src_prepare() {
+ # Upstream bug, tarball contains pre-made lxdm.conf
+ rm "${S}"/data/lxdm.conf || die
+
+ # Fix consolekit and selinux
+ eapply "${FILESDIR}/${P}-pam_console-disable.patch"
+
+ eapply_user
+
+ # this replaces the bootstrap/autogen script in most packages
+ eautoreconf
+
+ # process LINGUAS
+ if use nls; then
+ einfo "Running intltoolize ..."
+ intltoolize --force --copy --automake || die
+ strip-linguas -i "${S}/po" || die
+ fi
+}
+src_configure() {
+ econf --enable-password \
+ --with-x \
+ --with-xconn=xcb \
+ --with-systemdsystemunitdir=$(systemd_get_systemunitdir) \
+ $(use_enable consolekit) \
+ $(use_enable gtk3) \
+ $(use_enable nls) \
+ $(use_enable debug) \
+ $(use_with pam)
+}
+
+src_install() {
+ default_src_install
+
+ #Use Gentoo specific Xsession startup file
+ exeinto /etc/${PN}
+ doexe "${FILESDIR}"/Xsession
+}