summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorcharIes17 <charles17@arcor.de>2019-05-07 10:48:05 +0200
committerHanno <hanno@gentoo.org>2019-05-24 20:37:36 +0200
commitb7562dd71d9cf6c1da469cb284a26174bb3ebe94 (patch)
tree1bb90d1510e750a73984e9d5ebd30d6e84d94ec4 /lxde-base/lxtask/lxtask-0.1.9.ebuild
parentlxde-base/lxsession: Version bump. (diff)
downloadgentoo-b7562dd71d9cf6c1da469cb284a26174bb3ebe94.tar.gz
gentoo-b7562dd71d9cf6c1da469cb284a26174bb3ebe94.tar.bz2
gentoo-b7562dd71d9cf6c1da469cb284a26174bb3ebe94.zip
lxde-base/lxtask: Version bump to 0.1.9 and EAPI=7
Closes: https://bugs.gentoo.org/681966 Closes: https://github.com/gentoo/gentoo/pull/11926 Signed-off-by: Hanno Boeck <hanno@gentoo.org>
Diffstat (limited to 'lxde-base/lxtask/lxtask-0.1.9.ebuild')
-rw-r--r--lxde-base/lxtask/lxtask-0.1.9.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/lxde-base/lxtask/lxtask-0.1.9.ebuild b/lxde-base/lxtask/lxtask-0.1.9.ebuild
new file mode 100644
index 000000000000..71ab48b914c6
--- /dev/null
+++ b/lxde-base/lxtask/lxtask-0.1.9.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PLOCALES="af ar ast be bg bn_IN bn ca cs da de el en_GB es et eu fa fi fo fr
+frp gl he hr hu id is it ja kk ko lg lt lv ml ms nb nl nn pa pl ps pt_BR pt
+ro ru sk sl sq sr@latin sr sv te th tr tt_RU ug uk ur_PK ur vi zh_CN zh_TW"
+
+PLOCALE_BACKUP="en_GB"
+
+inherit l10n
+
+DESCRIPTION="LXDE Task manager"
+HOMEPAGE="https://wiki.lxde.org/en/LXTask"
+SRC_URI="mirror://sourceforge/lxde/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ppc ~x86 ~x86-linux"
+IUSE=""
+
+RDEPEND="x11-libs/gtk+:2
+ dev-libs/glib:2"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ sys-devel/gettext
+ >=dev-util/intltool-0.40.0"
+
+# Upstream report:
+# https://sourceforge.net/p/lxde/patches/535/
+PATCHES=( "${FILESDIR}/lxtask-0.1.7-fix-no-common.patch" )
+
+src_prepare() {
+ default
+
+ export LINGUAS="${LINGUAS:-${PLOCALE_BACKUP}}"
+ l10n_get_locales > po/LINGUAS || die
+}