summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorcharIes17 <charles17@arcor.de>2017-12-13 20:51:53 +0100
committerPatrice Clement <monsieurp@gentoo.org>2018-03-05 22:56:38 +0100
commitbfe2786432826bec81d7685001c3eca663ed1c26 (patch)
treea8ef9c2a160379f57fc8bf7b19ea781f49e53503 /lxde-base
parentapp-text/languagetool: use HTTPS. (diff)
downloadgentoo-bfe2786432826bec81d7685001c3eca663ed1c26.tar.gz
gentoo-bfe2786432826bec81d7685001c3eca663ed1c26.tar.bz2
gentoo-bfe2786432826bec81d7685001c3eca663ed1c26.zip
lxde-base/lxterminal: version bump to 0.3.1 (CVE-2016-10369).
Bug: https://bugs.gentoo.org/635992 Closes: https://bugs.gentoo.org/607838 Closes: https://bugs.gentoo.org/595904 - Adjusted HOMEPAGE (avoid redirect). - Adjusted tarball from.gz to .xz. - Make repoman happy by re-adding ~arm64. - Add LINGUAS handling. - Add handling of live ebuild. Package-Manager: Portage-2.3.13, Repoman-2.3.3 Closes: https://github.com/gentoo/gentoo/pull/5362
Diffstat (limited to 'lxde-base')
-rw-r--r--lxde-base/lxterminal/Manifest1
-rw-r--r--lxde-base/lxterminal/lxterminal-0.3.1.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/lxde-base/lxterminal/Manifest b/lxde-base/lxterminal/Manifest
index b5881aed7388..52158f9a06d1 100644
--- a/lxde-base/lxterminal/Manifest
+++ b/lxde-base/lxterminal/Manifest
@@ -1,2 +1,3 @@
DIST lxterminal-0.1.11.tar.gz 304025 BLAKE2B 88e0172bcfa5e310f9ac726fc2cb03d6300eed8876203f641721d3b3b81b05af143e6184abb45748b02ae100ab6e16494e7d42facdd1f28d8b45c6ace59676aa SHA512 4f929e9177775c78dcf4c440e1cff4f4824f56ff5bd165cb76ab42208db350feeb08d22449a482b3979160873b0120a78ace43069d910b5aeeec0736aa550139
DIST lxterminal-0.2.0.tar.gz 248698 BLAKE2B ca65e08baf22410a4e93d18ecc05e27329b9aaa555a945d81dd4f0e74a88205ff3345c34524304ab216a81fe21cc266fee1dc74381d1b6c3d315f3e50efce2a2 SHA512 5bec0e16fa4d929203e4c206fb59fb0c88e02f29adbf527c31fa2a0007d3dddbdf12f2219e204360b5dd95a68a89410fcf937325f3a7eb1229b568c9c10c0e78
+DIST lxterminal-0.3.1.tar.xz 197628 BLAKE2B 9448855b6d1bfc3fc272ec40f7e5b4fde1dfcb861254db3ed35b73611fd2dc5ca5d760542251f297289a051913e6eb6d669b2c04b194e01862ff7e79305c2e14 SHA512 3063eb7bc7426293d35dc1d9c32d5841e4c3f0b417f3cfa3e5a7bf4d9b71df9c9d375d53d6dd6694b318085ba07167bd8403b2caea9c6e9197aef4b7802877fc
diff --git a/lxde-base/lxterminal/lxterminal-0.3.1.ebuild b/lxde-base/lxterminal/lxterminal-0.3.1.ebuild
new file mode 100644
index 000000000000..c6b5993d83cd
--- /dev/null
+++ b/lxde-base/lxterminal/lxterminal-0.3.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PLOCALES="af ar be bg bn bn_IN ca cs da de el en_GB eo es et eu fa fi fo fr frp gl
+he hr hu id is it ja kk ko lg lt ml ms nb nl nn pa pl ps pt pt_BR ro ru sk sl sr
+sr@latin sv te th tr tt_RU ug uk ur ur_PK vi zh_CN zh_TW"
+PLOCALE_BACKUP="en_GB"
+
+inherit autotools l10n
+
+DESCRIPTION="Lightweight vte-based tabbed terminal emulator for LXDE"
+HOMEPAGE="https://wiki.lxde.org/en/LXTerminal"
+
+if [[ ${PV} == *9999* ]]; then
+ EGIT_REPO_URI="https://git.code.sf.net/p/lxde/${PN}"
+ inherit git-r3
+ KEYWORDS=""
+else
+ SRC_URI="mirror://sourceforge/lxde/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~mips ~ppc ~x86 ~amd64-linux ~arm-linux ~x86-linux"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="gtk3"
+
+RDEPEND="dev-libs/glib:2
+ !gtk3? ( x11-libs/gtk+:2 x11-libs/vte:0 )
+ gtk3? ( x11-libs/gtk+:3 x11-libs/vte:2.91 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ sys-devel/gettext
+ >=dev-util/intltool-0.40.0"
+
+src_prepare() {
+ default
+ eautoreconf
+
+ export LINGUAS="${LINGUAS:-${PLOCALE_BACKUP}}"
+ l10n_get_locales > po/LINGUAS || die
+}
+
+src_configure() {
+ econf --enable-man $(use_enable gtk3)
+}