summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJimi Huotari <chiitoo@gentoo.org>2022-04-19 00:35:56 +0300
committerSam James <sam@gentoo.org>2022-05-15 00:12:12 +0000
commite2667060432f9e98b5f1a186f4137dc44e811d7f (patch)
treee86b6ad2e3ebcb96f9ab5dd146b491f505b4036d /lxqt-base/lxqt-admin
parentlxqt-base/lxqt-openssh-askpass: add version 1.1.0 (diff)
downloadgentoo-e2667060432f9e98b5f1a186f4137dc44e811d7f.tar.gz
gentoo-e2667060432f9e98b5f1a186f4137dc44e811d7f.tar.bz2
gentoo-e2667060432f9e98b5f1a186f4137dc44e811d7f.zip
lxqt-base/lxqt-admin: add version 1.1.0
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Jimi Huotari <chiitoo@gentoo.org> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'lxqt-base/lxqt-admin')
-rw-r--r--lxqt-base/lxqt-admin/Manifest1
-rw-r--r--lxqt-base/lxqt-admin/lxqt-admin-1.1.0.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/lxqt-base/lxqt-admin/Manifest b/lxqt-base/lxqt-admin/Manifest
index a3b98f3ee584..1d6b01e922fe 100644
--- a/lxqt-base/lxqt-admin/Manifest
+++ b/lxqt-base/lxqt-admin/Manifest
@@ -1,2 +1,3 @@
DIST lxqt-admin-0.17.0.tar.xz 145620 BLAKE2B 3f1bc0870ef33a85a14dca559951826c56a2ebe81f6cad53917db87ce38b909aed4daed7964d202715dd4d9c7947b23f2aba0fdcb020b6b418c91d9f12c90573 SHA512 5d807b1bbde586130ab03cecf43dc190cbbed5c16842d14779f67f7b514689e7ea330f6c75916c733e4e840242d7feaceb4b6e0932ece1ca70bff208eb5e8072
DIST lxqt-admin-1.0.0.tar.xz 148732 BLAKE2B 0d3b654f90bd2573629ebb6c61faec621d3c7f547c7690e071d42bab2c062b495043bfa6c2e1d8107b2d2457635dc02ce6d0323906ae25203a4f84a17f0f0fda SHA512 af1cbdd0e04116ad575b652b4eef0fd0a403b37e169961797cc365fe69e5655c6291205165baab4bb3337506785d70149f2b6175758448bd06800fa6f4eb4617
+DIST lxqt-admin-1.1.0.tar.xz 149236 BLAKE2B 912c0bba56e46d654c1facdb1ec084fa16221364f12457186d331d684c08159c726663181b6bc9bed18e14acf6e0b834e46ef1e2df1d50636c3607ca9a5245b5 SHA512 f49e0c3e3b90f5b7fec2e304f45288c685447152bb80bdcf4bfdaa9051fd79ac557e363340e49c04dfe56a5454997d7f3b9488141056789fa2e22873ab1afa3c
diff --git a/lxqt-base/lxqt-admin/lxqt-admin-1.1.0.ebuild b/lxqt-base/lxqt-admin/lxqt-admin-1.1.0.ebuild
new file mode 100644
index 000000000000..a5dfea460c5b
--- /dev/null
+++ b/lxqt-base/lxqt-admin/lxqt-admin-1.1.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="LXQt system administration tool"
+HOMEPAGE="https://lxqt-project.org/"
+
+MY_PV="$(ver_cut 1-2)"
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+ SRC_URI="https://github.com/lxqt/${PN}/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+fi
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+
+BDEPEND=">=dev-util/lxqt-build-tools-0.11.0"
+DEPEND="
+ >=dev-qt/qtcore-5.15:5
+ >=dev-qt/qtdbus-5.15:5
+ >=dev-qt/qtgui-5.15:5
+ >=dev-qt/qtwidgets-5.15:5
+ =lxqt-base/liblxqt-${MY_PV}*
+ kde-frameworks/kwindowsystem:5
+ >=sys-auth/polkit-qt-0.113.0
+ =lxqt-base/liblxqt-${MY_PV}*:=
+"
+RDEPEND="${DEPEND}"