summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Scruggs <j.scruggs@gmail.com>2018-07-11 16:13:48 +0100
committerJonathan Scruggs <dracwyrm@gentoo.org>2018-08-11 11:09:15 +0100
commit2da39a98096bae76422ceec565aa820d2a0b26a6 (patch)
treec3a2edbd4f793c24da7bdfc97cd8b73c5020f0c9 /lxqt-base/lxqt-config/files
parentlxqt-base/lxqt-admin: version update to 0.13.0 (diff)
downloadgentoo-2da39a98096bae76422ceec565aa820d2a0b26a6.tar.gz
gentoo-2da39a98096bae76422ceec565aa820d2a0b26a6.tar.bz2
gentoo-2da39a98096bae76422ceec565aa820d2a0b26a6.zip
lxqt-base/lxqt-config: version update to 0.13.0
Added patch from Alec Moskvin <alecm@gmx.com> to remove the Qt5Concurrent dependency.
Diffstat (limited to 'lxqt-base/lxqt-config/files')
-rw-r--r--lxqt-base/lxqt-config/files/lxqt-config-0.13.0-remove-dependency-on-QtConcurrent.patch34
1 files changed, 34 insertions, 0 deletions
diff --git a/lxqt-base/lxqt-config/files/lxqt-config-0.13.0-remove-dependency-on-QtConcurrent.patch b/lxqt-base/lxqt-config/files/lxqt-config-0.13.0-remove-dependency-on-QtConcurrent.patch
new file mode 100644
index 000000000000..39bf078ae13f
--- /dev/null
+++ b/lxqt-base/lxqt-config/files/lxqt-config-0.13.0-remove-dependency-on-QtConcurrent.patch
@@ -0,0 +1,34 @@
+From e49e5ebabbf8bbe30d4955bc6cb785303f94c6f6 Mon Sep 17 00:00:00 2001
+From: Alec Moskvin <alecm@gmx.com>
+Date: Sun, 15 Jul 2018 11:26:16 -0400
+Subject: [PATCH] Remove dependency on QtConcurrent
+
+---
+ CMakeLists.txt | 1 -
+ lxqt-config-file-associations/CMakeLists.txt | 1 -
+ 2 files changed, 2 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 9c42ddc..5fb2548 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -22,7 +22,6 @@ set(CMAKE_AUTORCC ON)
+ find_package(Qt5Widgets REQUIRED)
+ find_package(Qt5DBus REQUIRED)
+ find_package(Qt5Xml REQUIRED)
+-find_package(Qt5Concurrent REQUIRED)
+ find_package(Qt5X11Extras REQUIRED)
+ find_package(Qt5LinguistTools REQUIRED)
+ find_package(lxqt REQUIRED)
+diff --git a/lxqt-config-file-associations/CMakeLists.txt b/lxqt-config-file-associations/CMakeLists.txt
+index 0506723..2500cf3 100644
+--- a/lxqt-config-file-associations/CMakeLists.txt
++++ b/lxqt-config-file-associations/CMakeLists.txt
+@@ -61,7 +61,6 @@ target_link_libraries(${PROJECT_NAME}
+ Qt5::Xml
+ Qt5::DBus
+ Qt5::Widgets
+- Qt5::Concurrent
+ ${LIBRARIES}
+ )
+