summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Scruggs <j.scruggs@gmail.com>2018-07-11 16:16:39 +0100
committerJonathan Scruggs <dracwyrm@gentoo.org>2018-08-11 11:09:16 +0100
commit0856bc0720cdccca2b0adb572a375e0673a41721 (patch)
tree70c1b58256b534b81e09eca6c69079b3d9baea44 /lxqt-base/lxqt-policykit/lxqt-policykit-0.13.0.ebuild
parentlxqt-base/lxqt-openssh-askpass: version update to 0.13.0 (diff)
downloadgentoo-0856bc0720cdccca2b0adb572a375e0673a41721.tar.gz
gentoo-0856bc0720cdccca2b0adb572a375e0673a41721.tar.bz2
gentoo-0856bc0720cdccca2b0adb572a375e0673a41721.zip
lxqt-base/lxqt-policykit: version update to 0.13.0
Diffstat (limited to 'lxqt-base/lxqt-policykit/lxqt-policykit-0.13.0.ebuild')
-rw-r--r--lxqt-base/lxqt-policykit/lxqt-policykit-0.13.0.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/lxqt-base/lxqt-policykit/lxqt-policykit-0.13.0.ebuild b/lxqt-base/lxqt-policykit/lxqt-policykit-0.13.0.ebuild
new file mode 100644
index 000000000000..59179a687c14
--- /dev/null
+++ b/lxqt-base/lxqt-policykit/lxqt-policykit-0.13.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils eapi7-ver
+
+DESCRIPTION="LXQt PolKit authentication agent"
+HOMEPAGE="https://lxqt.org/"
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+ SRC_URI="https://downloads.lxqt.org/downloads/${PN}/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+
+RDEPEND="
+ dev-libs/glib:2
+ >=dev-libs/libqtxdg-3.0.0
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ =lxqt-base/liblxqt-$(ver_cut 1-2)*
+ sys-auth/polkit-qt[qt5(+)]
+ !lxqt-base/lxqt-common
+"
+DEPEND="${RDEPEND}
+ >=dev-util/lxqt-build-tools-0.5.0
+ dev-qt/linguist-tools:5
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DPULL_TRANSLATIONS=OFF
+ )
+ cmake-utils_src_configure
+}
+
+src_install(){
+ cmake-utils_src_install
+ doman man/*.1
+}