summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJimi Huotari <chiitoo@gentoo.org>2020-11-05 22:38:27 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-11-23 08:11:34 +0100
commit1705ee39c10876100437bcf20b02ffb204ca1ea0 (patch)
treee40c071c5c5da429d87b5dae669d1b30f801962c /lxqt-base/lxqt-powermanagement
parentlxqt-base/lxqt-policykit: add version 0.16.0 (diff)
downloadgentoo-1705ee39c10876100437bcf20b02ffb204ca1ea0.tar.gz
gentoo-1705ee39c10876100437bcf20b02ffb204ca1ea0.tar.bz2
gentoo-1705ee39c10876100437bcf20b02ffb204ca1ea0.zip
lxqt-base/lxqt-powermanagement: add version 0.16.0
Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Jimi Huotari <chiitoo@gentoo.org> Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'lxqt-base/lxqt-powermanagement')
-rw-r--r--lxqt-base/lxqt-powermanagement/Manifest1
-rw-r--r--lxqt-base/lxqt-powermanagement/lxqt-powermanagement-0.16.0.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/lxqt-base/lxqt-powermanagement/Manifest b/lxqt-base/lxqt-powermanagement/Manifest
index ecf3c284f37c..05078ee989e8 100644
--- a/lxqt-base/lxqt-powermanagement/Manifest
+++ b/lxqt-base/lxqt-powermanagement/Manifest
@@ -1 +1,2 @@
DIST lxqt-powermanagement-0.15.0.tar.xz 64748 BLAKE2B 1a41e22e87c4af8b891d56d1a328d3c81ef1b5b6810fcdf392548bf497482d4c425901311f57f0a1be89e9ea49569dabb8a01be9ef90dfd8648460e2d7899507 SHA512 8ea0765bad3885e6a8e574b382d6bea0bd5065b760241b5fa641e17096fffb43c5472577729365c36918caa4ca0d058fa1a24538dfe157e32ac519d94a4db039
+DIST lxqt-powermanagement-0.16.0.tar.xz 69784 BLAKE2B 44ecfc540c60ceba4cbf3408d246b70a1cfef84c2bdff7b0e5e386cc020345aa2e3d1a1b5f916f71e421501208ec67faa76b327875e3bc9f7c69fd338ad5a5e5 SHA512 d262dc5b182678389d7ac38da5fd3c9bef75ceb9c9733aae3fae9f59d8b2c5e87524fdcdafcf9ec98ad107c23db946e30431f743c6ef8011f70ec4d9fc63a72e
diff --git a/lxqt-base/lxqt-powermanagement/lxqt-powermanagement-0.16.0.ebuild b/lxqt-base/lxqt-powermanagement/lxqt-powermanagement-0.16.0.ebuild
new file mode 100644
index 000000000000..475fb96897b7
--- /dev/null
+++ b/lxqt-base/lxqt-powermanagement/lxqt-powermanagement-0.16.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="LXQt daemon for power management and auto-suspend"
+HOMEPAGE="https://lxqt.github.io/"
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+ SRC_URI="https://github.com/lxqt/${PN}/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+LICENSE="LGPL-2.1 LGPL-2.1+"
+SLOT="0"
+
+BDEPEND="
+ dev-qt/linguist-tools:5
+ >=dev-util/lxqt-build-tools-0.8.0
+ virtual/pkgconfig
+"
+DEPEND="
+ >=dev-libs/libqtxdg-3.3.1
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5
+ dev-qt/qtsvg:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
+ kde-frameworks/kidletime:5
+ kde-frameworks/solid:5
+ =lxqt-base/liblxqt-$(ver_cut 1-2)*
+ sys-power/upower
+"
+RDEPEND="${DEPEND}
+ !lxqt-base/lxqt-l10n
+"