summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2016-09-27 01:29:38 +0200
committerManuel Rüger <mrueg@gentoo.org>2016-09-27 01:29:38 +0200
commit8001cc41a3f91f2d4229dcf597525cf79c46be60 (patch)
tree3e3ddd51c7508d419751087eec2afb8bcd637819 /lxqt-base/lxqt-qtplugin/lxqt-qtplugin-0.11.0.ebuild
parentlxqt-base/lxqt-policykit: Version bump to 0.11.0 (diff)
downloadgentoo-8001cc41a3f91f2d4229dcf597525cf79c46be60.tar.gz
gentoo-8001cc41a3f91f2d4229dcf597525cf79c46be60.tar.bz2
gentoo-8001cc41a3f91f2d4229dcf597525cf79c46be60.zip
lxqt-base/lxqt-qtplugin: Version bump to 0.11.0
Package-Manager: portage-2.3.1
Diffstat (limited to 'lxqt-base/lxqt-qtplugin/lxqt-qtplugin-0.11.0.ebuild')
-rw-r--r--lxqt-base/lxqt-qtplugin/lxqt-qtplugin-0.11.0.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/lxqt-base/lxqt-qtplugin/lxqt-qtplugin-0.11.0.ebuild b/lxqt-base/lxqt-qtplugin/lxqt-qtplugin-0.11.0.ebuild
new file mode 100644
index 000000000000..9da44367b4fa
--- /dev/null
+++ b/lxqt-base/lxqt-qtplugin/lxqt-qtplugin-0.11.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit cmake-utils
+
+DESCRIPTION="LXQt system integration plugin for Qt"
+HOMEPAGE="http://lxqt.org/"
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="git://git.lxde.org/git/lxde/${PN}.git"
+else
+ SRC_URI="https://downloads.lxqt.org/lxqt/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+
+RDEPEND="
+ dev-libs/libdbusmenu-qt[qt5]
+ >=dev-libs/libqtxdg-2.0.0
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ ~lxqt-base/liblxqt-${PV}
+ x11-libs/libX11"
+DEPEND="${RDEPEND}
+ dev-qt/linguist-tools:5"
+
+src_configure() {
+ local mycmakeargs=( -DPULL_TRANSLATIONS=OFF )
+ cmake-utils_src_configure
+}