summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2016-10-15 23:30:56 +0200
committerManuel Rüger <mrueg@gentoo.org>2016-10-15 23:30:56 +0200
commit9fe48ec7fed6018eaf6455779392662c36c21643 (patch)
treedcb79fffdc2489d6b6556110d6281500fc2634dd /lxqt-base/lxqt-runner/lxqt-runner-0.11.0.ebuild
parentdev-cpp/muParser: Add ~arm keyword (diff)
downloadgentoo-9fe48ec7fed6018eaf6455779392662c36c21643.tar.gz
gentoo-9fe48ec7fed6018eaf6455779392662c36c21643.tar.bz2
gentoo-9fe48ec7fed6018eaf6455779392662c36c21643.zip
lxqt-base/lxqt-runner: Version bump to 0.11.0
Package-Manager: portage-2.3.2
Diffstat (limited to 'lxqt-base/lxqt-runner/lxqt-runner-0.11.0.ebuild')
-rw-r--r--lxqt-base/lxqt-runner/lxqt-runner-0.11.0.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/lxqt-base/lxqt-runner/lxqt-runner-0.11.0.ebuild b/lxqt-base/lxqt-runner/lxqt-runner-0.11.0.ebuild
new file mode 100644
index 000000000000..1f65f79101e1
--- /dev/null
+++ b/lxqt-base/lxqt-runner/lxqt-runner-0.11.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit cmake-utils
+
+DESCRIPTION="LXQt quick launcher"
+HOMEPAGE="http://lxqt.org/"
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="git://git.lxde.org/git/lxde/${PN}.git"
+else
+ SRC_URI="https://downloads.lxqt.org/lxqt/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+LICENSE="GPL-2 LGPL-2.1+"
+SLOT="0"
+
+RDEPEND=">=dev-cpp/muParser-2.2.3
+ dev-libs/glib:2
+ >=dev-libs/libqtxdg-1.0.0
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
+ dev-qt/qtxml:5
+ kde-frameworks/kwindowsystem:5
+ >=lxde-base/menu-cache-0.5.1
+ ~lxqt-base/liblxqt-${PV}
+ ~lxqt-base/lxqt-globalkeys-${PV}"
+DEPEND="${RDEPEND}
+ >=dev-util/cmake-3.6.2
+ dev-qt/linguist-tools:5
+ virtual/pkgconfig"
+
+src_configure() {
+ local mycmakeargs=( -DPULL_TRANSLATIONS=OFF )
+ cmake-utils_src_configure
+}
+
+src_install(){
+ cmake-utils_src_install
+ doman man/*.1
+}