summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Scruggs <j.scruggs@gmail.com>2018-07-11 16:22:35 +0100
committerJonathan Scruggs <dracwyrm@gentoo.org>2018-08-11 11:09:18 +0100
commit572c40f0df889a2c3586df938da2c61ae69030a8 (patch)
tree9da7ac4b77cb1ec2578b9d12e648925832e55a7b /lxqt-base/lxqt-runner/lxqt-runner-0.13.0.ebuild
parentlxqt-base/lxqt-panel: version update to 0.13.0 (diff)
downloadgentoo-572c40f0df889a2c3586df938da2c61ae69030a8.tar.gz
gentoo-572c40f0df889a2c3586df938da2c61ae69030a8.tar.bz2
gentoo-572c40f0df889a2c3586df938da2c61ae69030a8.zip
lxqt-base/lxqt-runner: version update to 0.13.0
Diffstat (limited to 'lxqt-base/lxqt-runner/lxqt-runner-0.13.0.ebuild')
-rw-r--r--lxqt-base/lxqt-runner/lxqt-runner-0.13.0.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/lxqt-base/lxqt-runner/lxqt-runner-0.13.0.ebuild b/lxqt-base/lxqt-runner/lxqt-runner-0.13.0.ebuild
new file mode 100644
index 000000000000..7afdf29a5631
--- /dev/null
+++ b/lxqt-base/lxqt-runner/lxqt-runner-0.13.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils eapi7-ver
+
+DESCRIPTION="LXQt quick launcher"
+HOMEPAGE="https://lxqt.org/"
+
+MY_PV="$(ver_cut 1-2)*"
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+ SRC_URI="https://downloads.lxqt.org/downloads/${PN}/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+
+RDEPEND="
+ >=dev-cpp/muParser-2.2.3:=
+ >=dev-libs/libqtxdg-3.0.0
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtxml:5
+ kde-frameworks/kwindowsystem:5
+ >=lxde-base/menu-cache-0.5.1
+ =lxqt-base/liblxqt-${MY_PV}
+ =lxqt-base/lxqt-globalkeys-${MY_PV}
+ !lxqt-base/lxqt-common
+"
+DEPEND="${RDEPEND}
+ dev-qt/linguist-tools:5
+ >=dev-util/lxqt-build-tools-0.5.0
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DPULL_TRANSLATIONS=OFF
+ )
+ cmake-utils_src_configure
+}
+
+src_install(){
+ cmake-utils_src_install
+ doman man/*.1
+}