summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJimi Huotari <chiitoo@gentoo.org>2021-04-16 19:56:19 +0300
committerJoonas Niilola <juippis@gentoo.org>2021-04-18 08:00:35 +0300
commitfe0819fbe96c79392ff3a17fcfe8204b83cf8c58 (patch)
tree6aacb89fe1935ba09f4e4ac2808b1080914582f1 /lxqt-base/lxqt-sudo/lxqt-sudo-0.17.0.ebuild
parentlxqt-base/lxqt-session: add version 0.17.0 (diff)
downloadgentoo-fe0819fbe96c79392ff3a17fcfe8204b83cf8c58.tar.gz
gentoo-fe0819fbe96c79392ff3a17fcfe8204b83cf8c58.tar.bz2
gentoo-fe0819fbe96c79392ff3a17fcfe8204b83cf8c58.zip
lxqt-base/lxqt-sudo: add version 0.17.0
Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Jimi Huotari <chiitoo@gentoo.org> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'lxqt-base/lxqt-sudo/lxqt-sudo-0.17.0.ebuild')
-rw-r--r--lxqt-base/lxqt-sudo/lxqt-sudo-0.17.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/lxqt-base/lxqt-sudo/lxqt-sudo-0.17.0.ebuild b/lxqt-base/lxqt-sudo/lxqt-sudo-0.17.0.ebuild
new file mode 100644
index 000000000000..3153b0b042a8
--- /dev/null
+++ b/lxqt-base/lxqt-sudo/lxqt-sudo-0.17.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="LXQt GUI frontend for sudo"
+HOMEPAGE="https://lxqt.github.io/"
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+ SRC_URI="https://github.com/lxqt/${PN}/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+LICENSE="LGPL-2.1 LGPL-2.1+"
+SLOT="0"
+
+BDEPEND=">=dev-util/lxqt-build-tools-0.9.0"
+DEPEND="
+ app-admin/sudo
+ >=dev-libs/libqtxdg-3.3.1
+ dev-qt/qtcore:5
+ dev-qt/qtwidgets:5
+ =lxqt-base/liblxqt-$(ver_cut 1-2)*
+"
+RDEPEND="${DEPEND}"