summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAdel KARA SLIMANE <adel.ks@zegrapher.com>2021-11-06 13:50:13 +0100
committerSam James <sam@gentoo.org>2022-01-21 19:06:45 +0000
commit3774b753fa70e81548e8462ecce7114a1d88329c (patch)
tree4b3f9f4113d2487b7e22057aad794543cdf013aa /lxqt-base
parentlxqt-base/lxqt-config: version bump to 1.0.0 (diff)
downloadgentoo-3774b753fa70e81548e8462ecce7114a1d88329c.tar.gz
gentoo-3774b753fa70e81548e8462ecce7114a1d88329c.tar.bz2
gentoo-3774b753fa70e81548e8462ecce7114a1d88329c.zip
lxqt-base/lxqt-notificationd: version bump to 1.0.0
Signed-off-by: Adel KARA SLIMANE <adel.ks@zegrapher.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'lxqt-base')
-rw-r--r--lxqt-base/lxqt-notificationd/Manifest1
-rw-r--r--lxqt-base/lxqt-notificationd/lxqt-notificationd-1.0.0.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/lxqt-base/lxqt-notificationd/Manifest b/lxqt-base/lxqt-notificationd/Manifest
index f08d8a5f501d..4dff6c2cf75b 100644
--- a/lxqt-base/lxqt-notificationd/Manifest
+++ b/lxqt-base/lxqt-notificationd/Manifest
@@ -1 +1,2 @@
DIST lxqt-notificationd-0.17.0.tar.xz 53712 BLAKE2B d15f00179eb24c43add51f246b46738d4da6f9ce89f041a65ce4acc252ebd0a832519c0e9e7ac2ee86d23806a2ac6a9a740b57fc5e88d73a09d1170e405386ef SHA512 042d69e01c3015d254ae3472867de0b41587af2285cd26445cd9d6d455de8ef713413431dea9997f2d2e19f70c2c8c73af39ce880d54ecb9fd6c50cd05a7dba4
+DIST lxqt-notificationd-1.0.0.tar.xz 57160 BLAKE2B 518822c8fc4e5d8d68ae8181d64f80dc4dd0ffb7cc192f69432efaa7f35242c8e222b45cf51eaad473c8b55df09fd66475f7c1f9343d7d9b24c757304cef061a SHA512 e8953c06be5821d875027692589dd80bfc7bca8ff9d7e590dcab2ab80b17ed530983119b0cf9d254ba5b15bf863eb6283896e6ae38a999437e5ccd7d3a50adf9
diff --git a/lxqt-base/lxqt-notificationd/lxqt-notificationd-1.0.0.ebuild b/lxqt-base/lxqt-notificationd/lxqt-notificationd-1.0.0.ebuild
new file mode 100644
index 000000000000..6d7af2965070
--- /dev/null
+++ b/lxqt-base/lxqt-notificationd/lxqt-notificationd-1.0.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="LXQt notification daemon and library"
+HOMEPAGE="https://lxqt.github.io/"
+
+MY_PV="$(ver_cut 1-2)"
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+ SRC_URI="https://github.com/lxqt/${PN}/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+fi
+
+LICENSE="LGPL-2.1 LGPL-2.1+"
+SLOT="0"
+
+BDEPEND="
+ dev-qt/linguist-tools:5
+ >=dev-util/lxqt-build-tools-0.10.0
+"
+DEPEND="
+ >=dev-libs/libqtxdg-3.3.1
+ >=dev-qt/qtcore-5.15:5
+ >=dev-qt/qtdbus-5.15:5
+ >=dev-qt/qtgui-5.15:5
+ >=dev-qt/qtwidgets-5.15:5
+ kde-frameworks/kwindowsystem:5
+ =lxqt-base/liblxqt-${MY_PV}*
+"
+RDEPEND="${DEPEND}"