summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJimi Huotari <chiitoo@gentoo.org>2023-11-09 21:25:05 +0200
committerJimi Huotari <chiitoo@gentoo.org>2023-11-09 23:45:32 +0200
commit8928aa2261dc69ef465b77de697a55f8d3b57019 (patch)
treebf0b1123811d12ea244299fea2e7bb59fedc9a31 /lxqt-base
parentlxqt-base/lxqt-runner: add 1.4.0 (diff)
downloadgentoo-8928aa2261dc69ef465b77de697a55f8d3b57019.tar.gz
gentoo-8928aa2261dc69ef465b77de697a55f8d3b57019.tar.bz2
gentoo-8928aa2261dc69ef465b77de697a55f8d3b57019.zip
lxqt-base/lxqt-qtplugin: add 1.4.0
Signed-off-by: Jimi Huotari <chiitoo@gentoo.org>
Diffstat (limited to 'lxqt-base')
-rw-r--r--lxqt-base/lxqt-qtplugin/Manifest1
-rw-r--r--lxqt-base/lxqt-qtplugin/lxqt-qtplugin-1.4.0.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/lxqt-base/lxqt-qtplugin/Manifest b/lxqt-base/lxqt-qtplugin/Manifest
index 158a6f8a26d2..e888f051316b 100644
--- a/lxqt-base/lxqt-qtplugin/Manifest
+++ b/lxqt-base/lxqt-qtplugin/Manifest
@@ -1 +1,2 @@
DIST lxqt-qtplugin-1.3.0.tar.xz 23864 BLAKE2B 4aa79eb0513a3efac265707864137ec935042d3357395fa9e08e1b735015e665c95afe45c8c32c262a76e2d8bd92e80956965cd65e64eef0d409094e4e56b7c1 SHA512 a1fefe5af7aacfb3c594fa1c181c2146c702fe0fabaf269c7e22e5755026accc68745d4ba64cd725ba66691f704c5a5d69658b55188b9919586601efbadc27ff
+DIST lxqt-qtplugin-1.4.0.tar.xz 23880 BLAKE2B b9a6a5ac280bb27546a463bd1ab75db3b116d45b5327d6239a1f40cb4dac0d4605035d63fea8c4274272ef8bbeda0189449c2df2bbe45c6d2559945dc72e9549 SHA512 1d6306d396e560fbab1c64e2dda47e0456e6d8fcff077bcb7104adb8f89ef73bfef9457ab5b65aa07101acc3d7d2701efb88e8d36a0c74780a187480288acbea
diff --git a/lxqt-base/lxqt-qtplugin/lxqt-qtplugin-1.4.0.ebuild b/lxqt-base/lxqt-qtplugin/lxqt-qtplugin-1.4.0.ebuild
new file mode 100644
index 000000000000..f7665c9def7a
--- /dev/null
+++ b/lxqt-base/lxqt-qtplugin/lxqt-qtplugin-1.4.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_PV="$(ver_cut 1-2)"
+
+inherit cmake
+
+DESCRIPTION="LXQt system integration plugin for Qt"
+HOMEPAGE="https://lxqt-project.org/"
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+ SRC_URI="https://github.com/lxqt/${PN}/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+
+BDEPEND="
+ >=dev-qt/linguist-tools-5.15:5
+ >=dev-util/lxqt-build-tools-0.13.0
+"
+DEPEND="
+ dev-libs/libdbusmenu-qt[qt5(+)]
+ >=dev-libs/libqtxdg-3.12.0
+ >=dev-qt/qtcore-5.15:5
+ >=dev-qt/qtdbus-5.15:5
+ >=dev-qt/qtgui-5.15:5=
+ >=dev-qt/qtwidgets-5.15:5
+ =x11-libs/libfm-qt-${MY_PV}*
+"
+RDEPEND="${DEPEND}"