summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Vetter <jubalh@iodoru.org>2023-04-15 18:53:03 +0000
committerJimi Huotari <chiitoo@gentoo.org>2023-04-18 01:05:44 +0300
commit916fa9db03ec06c3fc2508d6f3dddc006f43b4e8 (patch)
tree787f9056978e3f75bd0b7aa6a03bc5904c3b253b /lxqt-base
parentlxqt-base/lxqt-notification: add 1.3.0 (diff)
downloadgentoo-916fa9db03ec06c3fc2508d6f3dddc006f43b4e8.tar.gz
gentoo-916fa9db03ec06c3fc2508d6f3dddc006f43b4e8.tar.bz2
gentoo-916fa9db03ec06c3fc2508d6f3dddc006f43b4e8.zip
lxqt-base/lxqt-openssh-askpass: add 1.3.0
Signed-off-by: Michael Vetter <jubalh@iodoru.org> Signed-off-by: Jimi Huotari <chiitoo@gentoo.org>
Diffstat (limited to 'lxqt-base')
-rw-r--r--lxqt-base/lxqt-openssh-askpass/Manifest1
-rw-r--r--lxqt-base/lxqt-openssh-askpass/lxqt-openssh-askpass-1.3.0.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/lxqt-base/lxqt-openssh-askpass/Manifest b/lxqt-base/lxqt-openssh-askpass/Manifest
index a1eba98df18e..a8734ce7e1a1 100644
--- a/lxqt-base/lxqt-openssh-askpass/Manifest
+++ b/lxqt-base/lxqt-openssh-askpass/Manifest
@@ -1 +1,2 @@
DIST lxqt-openssh-askpass-1.2.0.tar.xz 17476 BLAKE2B d5bfe5e7081beb527cc8dda54aac28514af1d683cb24e931d1175d941c4928f7186b3f42310d95b034138d0021612f16b1bf274ad54ac59586d9a8df287400e1 SHA512 8093516f6e1616a5e012d9af2c491580ab8a35053d4c47045b95a151e2e0e0c6f4055e2cb009140883b31057911d5fec80d5a1f84be8e15f7470dbc0e348960e
+DIST lxqt-openssh-askpass-1.3.0.tar.xz 17560 BLAKE2B 509ce775ffe3030017d5a37e31a8c979ab1c5c7e963cdc36bb9c70cd34e860d2c017e894e58d905be7a3b86d3efccae7ab464804640b1e958422a3b89a272614 SHA512 82f632577cc5b73dda54c8cdea0feadfb4a1f768e7b1d58b2c9e1f12eb40cbec88e7e31a4afc76efe153b5e424c205dde8a19c2249ed7ab6655f7376e54f1950
diff --git a/lxqt-base/lxqt-openssh-askpass/lxqt-openssh-askpass-1.3.0.ebuild b/lxqt-base/lxqt-openssh-askpass/lxqt-openssh-askpass-1.3.0.ebuild
new file mode 100644
index 000000000000..774ad3d3fe66
--- /dev/null
+++ b/lxqt-base/lxqt-openssh-askpass/lxqt-openssh-askpass-1.3.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="LXQt OpenSSH user password prompt tool"
+HOMEPAGE="https://lxqt-project.org/"
+
+MY_PV="$(ver_cut 1-2)"
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+ SRC_URI="https://github.com/lxqt/${PN}/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+fi
+
+LICENSE="LGPL-2.1 LGPL-2.1+"
+SLOT="0"
+
+BDEPEND="
+ >=dev-qt/linguist-tools-5.15:5
+"
+DEPEND="
+ >=dev-qt/qtcore-5.15:5
+ >=dev-qt/qtwidgets-5.15:5
+ =lxqt-base/liblxqt-${MY_PV}*:=
+"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ cmake_src_install
+ doman man/*.1
+
+ newenvd - 99${PN} <<- _EOF_
+ SSH_ASKPASS='${EPREFIX}/usr/bin/lxqt-openssh-askpass'
+ _EOF_
+}