summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJimi Huotari <chiitoo@gentoo.org>2021-04-16 19:45:48 +0300
committerJoonas Niilola <juippis@gentoo.org>2021-04-18 08:00:34 +0300
commitb79e511a90035e9d19f7738d0cd31d4b0097428d (patch)
tree43bcffcc379acaf5ee6d123b57398c5e705af6b0 /lxqt-base
parentlxqt-base/lxqt-policykit: add version 0.17.0 (diff)
downloadgentoo-b79e511a90035e9d19f7738d0cd31d4b0097428d.tar.gz
gentoo-b79e511a90035e9d19f7738d0cd31d4b0097428d.tar.bz2
gentoo-b79e511a90035e9d19f7738d0cd31d4b0097428d.zip
lxqt-base/lxqt-powermanagement: add version 0.17.0
Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Jimi Huotari <chiitoo@gentoo.org> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'lxqt-base')
-rw-r--r--lxqt-base/lxqt-powermanagement/Manifest1
-rw-r--r--lxqt-base/lxqt-powermanagement/lxqt-powermanagement-0.17.0.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/lxqt-base/lxqt-powermanagement/Manifest b/lxqt-base/lxqt-powermanagement/Manifest
index 15480764f090..0be201ca16d8 100644
--- a/lxqt-base/lxqt-powermanagement/Manifest
+++ b/lxqt-base/lxqt-powermanagement/Manifest
@@ -1 +1,2 @@
DIST lxqt-powermanagement-0.16.0.tar.xz 69784 BLAKE2B 44ecfc540c60ceba4cbf3408d246b70a1cfef84c2bdff7b0e5e386cc020345aa2e3d1a1b5f916f71e421501208ec67faa76b327875e3bc9f7c69fd338ad5a5e5 SHA512 d262dc5b182678389d7ac38da5fd3c9bef75ceb9c9733aae3fae9f59d8b2c5e87524fdcdafcf9ec98ad107c23db946e30431f743c6ef8011f70ec4d9fc63a72e
+DIST lxqt-powermanagement-0.17.0.tar.xz 76080 BLAKE2B afd12f55d5274263707044c77f3c556dfbb4e2adebda600650e32130ea88a08b0b009c14c31217f85010182edae17cb0d58cd9bb83ba47a1d437e661ee7af6ea SHA512 24bd9a136dddd35b0fdedd5051764109965f3cd32c74acd78cbca1e5fcfc91cddf9a756665c6e700bf882ca0307bfcbc855bde5fbdb2509390e16366e7ee9548
diff --git a/lxqt-base/lxqt-powermanagement/lxqt-powermanagement-0.17.0.ebuild b/lxqt-base/lxqt-powermanagement/lxqt-powermanagement-0.17.0.ebuild
new file mode 100644
index 000000000000..e957ba744cda
--- /dev/null
+++ b/lxqt-base/lxqt-powermanagement/lxqt-powermanagement-0.17.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="LXQt daemon for power management and auto-suspend"
+HOMEPAGE="https://lxqt.github.io/"
+
+LXQTPV="$(ver_cut 1-2)*"
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+ SRC_URI="https://github.com/lxqt/${PN}/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+LICENSE="LGPL-2.1 LGPL-2.1+"
+SLOT="0"
+
+BDEPEND="
+ dev-qt/linguist-tools:5
+ >=dev-util/lxqt-build-tools-0.9.0
+ virtual/pkgconfig
+"
+DEPEND="
+ >=dev-libs/libqtxdg-3.3.1
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5
+ dev-qt/qtsvg:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
+ kde-frameworks/kidletime:5
+ kde-frameworks/solid:5
+ =lxqt-base/liblxqt-${LXQTPV}
+ =lxqt-base/lxqt-globalkeys-${LXQTPV}
+ sys-power/upower
+"
+RDEPEND="${DEPEND}"