summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJimi Huotari <chiitoo@gentoo.org>2022-04-19 00:30:34 +0300
committerSam James <sam@gentoo.org>2022-05-15 00:12:05 +0000
commitfa89479e6123ec6fc6a595ddd4ab9d64feaee14e (patch)
treed8d809b04c0121e5e29bdabe443df01360b986b8 /lxqt-base
parentlxqt-base/lxqt-notificationd: add version 1.1.0 (diff)
downloadgentoo-fa89479e6123ec6fc6a595ddd4ab9d64feaee14e.tar.gz
gentoo-fa89479e6123ec6fc6a595ddd4ab9d64feaee14e.tar.bz2
gentoo-fa89479e6123ec6fc6a595ddd4ab9d64feaee14e.zip
lxqt-base/lxqt-policykit: add version 1.1.0
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Jimi Huotari <chiitoo@gentoo.org> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'lxqt-base')
-rw-r--r--lxqt-base/lxqt-policykit/Manifest1
-rw-r--r--lxqt-base/lxqt-policykit/lxqt-policykit-1.1.0.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/lxqt-base/lxqt-policykit/Manifest b/lxqt-base/lxqt-policykit/Manifest
index a2524c4a0df3..7d51b74e8829 100644
--- a/lxqt-base/lxqt-policykit/Manifest
+++ b/lxqt-base/lxqt-policykit/Manifest
@@ -1,2 +1,3 @@
DIST lxqt-policykit-0.17.0.tar.xz 38272 BLAKE2B e141d0ff7a583b22ddddcde3875cf82a5215cef0c6270774b3b31e21608f16bc78dd45b3b36b8ba1fde3bbeda30b2f638a47ecf7dee1797da151cb701fecc866 SHA512 1cfd4b2d21840704e4b15ae71098e9c6f3d51031293f1fdf6e134ffee867fe4e845caaf24fbd2c107317372b90b6d415a76854977fa8f6b703e708bd09120328
DIST lxqt-policykit-1.0.0.tar.xz 39040 BLAKE2B 0bbf68cd6ad4edf9c2553332855099317a852174baa7ef42e47c50d8a37eb8f87caa8f7698a84de9ed14d8c6afda3be93cef5113ec7019583345acdfcd82e5ad SHA512 c0d7c5ff8a5e95e74eefd094625d71603026e9d30c033e224fc4e62eba63f1bfe76ddf666eb1875a14c2c1bea3d21e4ac6d191e90bc2442f7e4e62845a63a3f0
+DIST lxqt-policykit-1.1.0.tar.xz 39280 BLAKE2B 190ab41a7de867cceff0b363b0474466e5740dbcfbd5342678d839058d8791e19799363ea34ca7b0a90e14b6d687f571c4d044f51a539f1431e57c603844a7fd SHA512 41592a2f086c5308ed71ef856bba8c3f81aa392700696e8a82554ce049bec07f41221a9862244d22f732b8f09a7c157596a50ef48bd30f1acf491317c4e21d12
diff --git a/lxqt-base/lxqt-policykit/lxqt-policykit-1.1.0.ebuild b/lxqt-base/lxqt-policykit/lxqt-policykit-1.1.0.ebuild
new file mode 100644
index 000000000000..2904482d6228
--- /dev/null
+++ b/lxqt-base/lxqt-policykit/lxqt-policykit-1.1.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="LXQt PolKit authentication agent"
+HOMEPAGE="https://lxqt-project.org/"
+
+MY_PV="$(ver_cut 1-2)"
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+ SRC_URI="https://github.com/lxqt/${PN}/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+fi
+
+LICENSE="LGPL-2.1 LGPL-2.1+"
+SLOT="0"
+
+BDEPEND="
+ >=dev-qt/linguist-tools-5.15:5
+ >=dev-util/lxqt-build-tools-0.11.0
+ virtual/pkgconfig
+"
+DEPEND="
+ >=dev-qt/qtcore-5.15:5
+ >=dev-qt/qtgui-5.15:5
+ >=dev-qt/qtwidgets-5.15:5
+ =lxqt-base/liblxqt-${MY_PV}*:=
+ >=sys-auth/polkit-qt-0.113.0
+"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ cmake_src_install
+ doman man/*.1
+}