summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /mail-client/etpan-ng
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'mail-client/etpan-ng')
-rw-r--r--mail-client/etpan-ng/Manifest1
-rw-r--r--mail-client/etpan-ng/etpan-ng-0.7.1-r1.ebuild40
-rw-r--r--mail-client/etpan-ng/files/etpan-ng-0.7.1-as-needed.patch58
-rw-r--r--mail-client/etpan-ng/metadata.xml9
4 files changed, 108 insertions, 0 deletions
diff --git a/mail-client/etpan-ng/Manifest b/mail-client/etpan-ng/Manifest
new file mode 100644
index 000000000000..8fce1e1eb6e6
--- /dev/null
+++ b/mail-client/etpan-ng/Manifest
@@ -0,0 +1 @@
+DIST etpan-ng-0.7.1.tar.gz 364394 SHA256 085b030e6ddebd816600b5fc9ca92eae1b6301e60691cfaf36e38140934d5dc3
diff --git a/mail-client/etpan-ng/etpan-ng-0.7.1-r1.ebuild b/mail-client/etpan-ng/etpan-ng-0.7.1-r1.ebuild
new file mode 100644
index 000000000000..d5a6b1b43b50
--- /dev/null
+++ b/mail-client/etpan-ng/etpan-ng-0.7.1-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils autotools
+
+DESCRIPTION="etPan is a console mail client that is based on libEtPan"
+HOMEPAGE="http://www.etpan.org/other.html"
+SRC_URI="mirror://sourceforge/libetpan/${P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 x86"
+IUSE="debug ldap"
+
+RDEPEND=">=net-libs/libetpan-0.35
+ sys-libs/ncurses
+ ldap? ( net-nds/openldap )"
+DEPEND="${RDEPEND}
+ virtual/yacc"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-as-needed.patch"
+ eautoreconf
+}
+
+src_compile() {
+ sed -i -e "s:@bindir@:${D}/@bindir@:" src/Makefile.in
+
+ econf \
+ `use_enable debug` \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ dodoc Changelog NEWS README TODO contrib/etpan-make-vtree.pl doc/*
+}
diff --git a/mail-client/etpan-ng/files/etpan-ng-0.7.1-as-needed.patch b/mail-client/etpan-ng/files/etpan-ng-0.7.1-as-needed.patch
new file mode 100644
index 000000000000..146f25e678fa
--- /dev/null
+++ b/mail-client/etpan-ng/files/etpan-ng-0.7.1-as-needed.patch
@@ -0,0 +1,58 @@
+--- etpan-ng-0.7.1.orig/configure.in 2006-01-09 11:44:20.000000000 +0100
++++ etpan-ng-0.7.1/configure.in 2010-01-10 14:51:40.788046570 +0100
+@@ -11,18 +11,25 @@
+ libetpan_major_required=0
+ libetpan_minor_required=42
+
+-debug=no
++AC_MSG_CHECKING(whether debug flag was used)
+ AC_ARG_ENABLE(debug, [ --enable-debug setup flags (gcc) for debugging (default=no)],
+-debug=yes
+-CFLAGS="$CFLAGS -O2 -W -Wall -g"
+-LDFLAGS="$LDFLAGS",)
++ [enable_debug=$enableval],[enable_debug="no"])
++AC_MSG_RESULT($enable_debug)
++if test "$enable_debug" = "yes"; then
++ CFLAGS="$CFLAGS -O2 -W -Wall -g"
++ LDFLAGS="$LDFLAGS"
++fi
++
+ AC_ARG_ENABLE(optim, [ --enable-optim setup flags (gcc) for optimizations (default=no)],
+-if test "x$enable_debug" != "xyes" ; then
+- CFLAGS="$CFLAGS -O3 -g0"
+- LDFLAGS="$LDFLAGS -s"
++ [enable_optim=$enableval],[enable_debug="no"])
++if test "$enable_debug" != "yes"; then
++ if test "$enable_optim" = "yes"; then
++ CFLAGS="$CFLAGS -O3 -g0"
++ LDFLAGS="$LDFLAGS -s"
++ fi
+ else
+ AC_MSG_WARN([enable-optim and enable-debug are incompatible -- disabling optimizations])
+-fi,)
++fi
+
+ AC_CONFIG_HEADER(config.h)
+
+@@ -67,10 +74,10 @@
+ if test "x$checkpthread" = "xyes"; then
+ AC_MSG_CHECKING([for pthread_create with -$flag])
+ OLDFLAGS="$LDFLAGS"
+- LDFLAGS="-$flag $LDFLAGS"
++ LDFLAGS="$LDFLAGS -$flag"
+ AC_TRY_LINK([], [pthread_create();],
+ [pthflag=yes; checkpthread=no],
+- [pthflag=no; LDFLAGS="$OLDCFLAGS"])
++ [pthflag=no; LDFLAGS="$OLDFLAGS"])
+ AC_MSG_RESULT($pthflag)
+ fi
+ done
+@@ -127,7 +134,7 @@
+ AC_CHECK_HEADER(libetpan/libetpan.h, [libetpan=yes])
+ if test "x$libetpan" = "xyes"; then
+ AC_MSG_CHECKING([whether libetpan-config hints compiles and links fine])
+- LDFLAGS="$LDFLAGS `$libetpanconfig --libs 2>/dev/null`"
++ LIBS="$LIBS `$libetpanconfig --libs 2>/dev/null`"
+ AC_TRY_LINK([], [db_mailstorage_init();], [libetpan=yes], [libetpan=no])
+ AC_MSG_RESULT([$libetpan])
+ fi
diff --git a/mail-client/etpan-ng/metadata.xml b/mail-client/etpan-ng/metadata.xml
new file mode 100644
index 000000000000..b2f66f193014
--- /dev/null
+++ b/mail-client/etpan-ng/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>net-mail</herd>
+ <longdescription>etPan is a console mail client that is based on libEtPan!</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">libetpan</remote-id>
+ </upstream>
+</pkgmetadata>