summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoonas Niilola <juippis@gentoo.org>2021-04-29 14:12:17 +0300
committerJoonas Niilola <juippis@gentoo.org>2021-04-29 14:43:43 +0300
commitab158443b2d8870be2de8b1709e7638d2dfd4720 (patch)
tree9d80225d264bf03d8ee229b7a97b2c1f8dd7c070 /mail-client/mutt-wizard/mutt-wizard-3.1.1-r1.ebuild
parentmail-client/mutt-wizard: add sasl runtime neomutt dependency (diff)
downloadgentoo-ab158443b2d8870be2de8b1709e7638d2dfd4720.tar.gz
gentoo-ab158443b2d8870be2de8b1709e7638d2dfd4720.tar.bz2
gentoo-ab158443b2d8870be2de8b1709e7638d2dfd4720.zip
mail-client/mutt-wizard: revbump to populate previous changes
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'mail-client/mutt-wizard/mutt-wizard-3.1.1-r1.ebuild')
-rw-r--r--mail-client/mutt-wizard/mutt-wizard-3.1.1-r1.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/mail-client/mutt-wizard/mutt-wizard-3.1.1-r1.ebuild b/mail-client/mutt-wizard/mutt-wizard-3.1.1-r1.ebuild
new file mode 100644
index 000000000000..17c4d75f3c78
--- /dev/null
+++ b/mail-client/mutt-wizard/mutt-wizard-3.1.1-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 2019-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit optfeature
+
+DESCRIPTION="A system for automatically configuring neomutt and isync"
+HOMEPAGE="https://github.com/LukeSmithxyz/mutt-wizard"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/LukeSmithxyz/mutt-wizard.git"
+else
+ SRC_URI="https://github.com/LukeSmithxyz/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+
+RDEPEND="
+ app-admin/pass
+ mail-client/neomutt[notmuch,sasl]
+ mail-mta/msmtp
+ net-mail/isync[ssl]
+"
+
+# needed because there is no 'all' target defined in MAKEFILE
+src_compile() {
+ return 0;
+}
+
+src_install() {
+ emake PREFIX="/usr" DESTDIR="${D}" install
+ einstalldocs
+}
+
+pkg_postinst() {
+ optfeature "enable viewing html mails" www-client/lynx
+ optfeature "enable periodic syncing of mails" virtual/cron
+ optfeature "enable viewing of simple images" media-gfx/imagemagick
+ optfeature "enable notifications when syncing using mailsync" x11-libs/libnotify
+ optfeature "enable command line address book" app-misc/abook
+ optfeature "enable use of gpg for signing and verifying" app-crypt/gnupg
+}