summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAisha Tammy <gentoo@aisha.cc>2020-02-19 23:00:22 -0500
committerJoonas Niilola <juippis@gentoo.org>2020-06-08 10:45:18 +0300
commitcfb881f34b6b0be64a8fe737760ff16f4d5dab91 (patch)
treeddf2d472c8be9e43374a82b5894b0469ebc0cc38 /mail-client/mutt-wizard/mutt-wizard-9999.ebuild
parentxfce-base/libxfce4ui: Bump to 4.15.3 (diff)
downloadgentoo-cfb881f34b6b0be64a8fe737760ff16f4d5dab91.tar.gz
gentoo-cfb881f34b6b0be64a8fe737760ff16f4d5dab91.tar.bz2
gentoo-cfb881f34b6b0be64a8fe737760ff16f4d5dab91.zip
mail-client/mutt-wizard: added mutt-wizard with dated ebuild
Closes: https://bugs.gentoo.org/713890 A system for automatically configuring neomutt and isync with a simple interface and safe passwords. Support for multiple domains and automatic offline email sync. Integrable with a lot of other utilities for additional functionality for managing emails. Signed-off-by: Aisha Tammy <gentoo@aisha.cc> Closes: https://github.com/gentoo/gentoo/pull/14713 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'mail-client/mutt-wizard/mutt-wizard-9999.ebuild')
-rw-r--r--mail-client/mutt-wizard/mutt-wizard-9999.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/mail-client/mutt-wizard/mutt-wizard-9999.ebuild b/mail-client/mutt-wizard/mutt-wizard-9999.ebuild
new file mode 100644
index 000000000000..9eaf38595153
--- /dev/null
+++ b/mail-client/mutt-wizard/mutt-wizard-9999.ebuild
@@ -0,0 +1,48 @@
+# Copyright 2019-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit eutils
+
+DESCRIPTION="A system for automatically configuring neomutt and isync"
+HOMEPAGE="https://github.com/LukeSmithxyz/mutt-wizard"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/LukeSmithxyz/mutt-wizard.git"
+else
+ COMMIT=9ec2a49af03cf542c7db82bc0dd0ccdde81922d4
+ SRC_URI="https://github.com/LukeSmithxyz/${PN}/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/${PN}-${COMMIT}"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+
+RDEPEND="
+ app-admin/pass
+ mail-client/neomutt[notmuch]
+ mail-mta/msmtp
+ net-mail/isync[ssl]
+"
+
+# needed because there is no 'all' target defined in MAKEFILE
+src_compile() {
+ return 0;
+}
+
+src_install() {
+ emake PREFIX="/usr" DESTDIR="${D}" install
+ einstalldocs
+}
+
+pkg_postinst() {
+ optfeature "enable viewing html mails" www-client/lynx
+ optfeature "enable periodic syncing of mails" virtual/cron
+ optfeature "enable viewing of simple images" media-gfx/imagemagick
+ optfeature "enable notifications when syncing using mailsync" x11-libs/libnotify
+ optfeature "enable command line address book" app-misc/abook
+ optfeature "enable use of gpg for signing and verifying" app-crypt/gnupg
+}