summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /mail-client/nmh/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'mail-client/nmh/files')
-rw-r--r--mail-client/nmh/files/nmh-1.3-db5.patch17
-rw-r--r--mail-client/nmh/files/nmh-1.3-inc-login.patch27
-rw-r--r--mail-client/nmh/files/nmh-1.3-install.patch12
-rw-r--r--mail-client/nmh/files/nmh-1.3-m_getfld.patch29
-rw-r--r--mail-client/nmh/files/nmh-1.3-parallelmake.patch99
5 files changed, 184 insertions, 0 deletions
diff --git a/mail-client/nmh/files/nmh-1.3-db5.patch b/mail-client/nmh/files/nmh-1.3-db5.patch
new file mode 100644
index 000000000000..473e2b609aeb
--- /dev/null
+++ b/mail-client/nmh/files/nmh-1.3-db5.patch
@@ -0,0 +1,17 @@
+diff --git a/uip/slocal.c b/uip/slocal.c
+index 9697d84..d38a020 100644
+--- a/uip/slocal.c
++++ b/uip/slocal.c
+@@ -46,6 +46,12 @@
+ extern int initgroups(char*, int);
+ #endif
+
++/* This define is needed for Berkeley db v5 and above to
++ * make the header file expose the 'historical' ndbm APIs.
++ * We define it unconditionally because this is simple and
++ * harmless.
++ */
++#define HAVE_DBM
+ /* This define is needed for Berkeley db v2 and above to
+ * make the header file expose the 'historical' ndbm APIs.
+ * We define it unconditionally because this is simple and
diff --git a/mail-client/nmh/files/nmh-1.3-inc-login.patch b/mail-client/nmh/files/nmh-1.3-inc-login.patch
new file mode 100644
index 000000000000..631a03f3e35a
--- /dev/null
+++ b/mail-client/nmh/files/nmh-1.3-inc-login.patch
@@ -0,0 +1,27 @@
+diff --git a/uip/inc.c b/uip/inc.c
+index cf12ab8..b8384cd 100644
+--- a/uip/inc.c
++++ b/uip/inc.c
+@@ -496,8 +496,7 @@ main (int argc, char **argv)
+ * a POP server?
+ */
+ if (inc_type == INC_POP) {
+- if (user == NULL)
+- user = getusername ();
++
+ if ( strcmp( POPSERVICE, "kpop" ) == 0 ) {
+ kpop = 1;
+ }
+@@ -506,6 +505,12 @@ main (int argc, char **argv)
+ else
+ ruserpass (host, &user, &pass);
+
++ /*
++ * Do this _after_ ruserpass, otherwise the login field will be unusable
++ */
++ if (user == NULL)
++ user = getusername ();
++
+ /*
+ * initialize POP connection
+ */
diff --git a/mail-client/nmh/files/nmh-1.3-install.patch b/mail-client/nmh/files/nmh-1.3-install.patch
new file mode 100644
index 000000000000..25dc321fd180
--- /dev/null
+++ b/mail-client/nmh/files/nmh-1.3-install.patch
@@ -0,0 +1,12 @@
+diff --git a/uip/Makefile.in b/uip/Makefile.in
+index b3c6717..5ed34f8 100644
+--- a/uip/Makefile.in
++++ b/uip/Makefile.in
+@@ -267,7 +267,6 @@ install-lcmds:
+ rm -f $(DESTDIR)$(bindir)/folders
+ rm -f $(DESTDIR)$(bindir)/prev
+ rm -f $(DESTDIR)$(bindir)/next
+- rm -f $(DESTDIR)$(libdir)/install-mh
+ $(LN) $(DESTDIR)$(bindir)/flist $(DESTDIR)$(bindir)/flists
+ $(LN) $(DESTDIR)$(bindir)/folder $(DESTDIR)$(bindir)/folders
+ $(LN) $(DESTDIR)$(bindir)/show $(DESTDIR)$(bindir)/prev
diff --git a/mail-client/nmh/files/nmh-1.3-m_getfld.patch b/mail-client/nmh/files/nmh-1.3-m_getfld.patch
new file mode 100644
index 000000000000..6e0104c3d4c9
--- /dev/null
+++ b/mail-client/nmh/files/nmh-1.3-m_getfld.patch
@@ -0,0 +1,29 @@
+diff --git a/sbr/m_getfld.c b/sbr/m_getfld.c
+index caf9519..13c2c3d 100644
+--- a/sbr/m_getfld.c
++++ b/sbr/m_getfld.c
+@@ -731,18 +731,18 @@ matchc(int patln, char *pat, int strln, char *str)
+ register char *ep = pat + patln;
+ register char pc = *pat++;
+
+- for(;;) {
+- while (pc != *str++)
+- if (str > es)
+- return 0;
++ for(;str <= es; str++) {
++ if (pc != *str)
++ continue;
+ if (str > es+1)
+ return 0;
+- sp = str; pp = pat;
++ sp = str+1; pp = pat;
+ while (pp < ep && *sp++ == *pp)
+ pp++;
+ if (pp >= ep)
+- return ((unsigned char *)--str);
++ return ((unsigned char *)str);
+ }
++ return 0;
+ }
+
+
diff --git a/mail-client/nmh/files/nmh-1.3-parallelmake.patch b/mail-client/nmh/files/nmh-1.3-parallelmake.patch
new file mode 100644
index 000000000000..1ac2415e9845
--- /dev/null
+++ b/mail-client/nmh/files/nmh-1.3-parallelmake.patch
@@ -0,0 +1,99 @@
+diff --git a/etc/Makefile.in b/etc/Makefile.in
+index f1412b1..9af408d 100644
+--- a/etc/Makefile.in
++++ b/etc/Makefile.in
+@@ -86,13 +86,13 @@ sendfiles: $(srcdir)/sendfiles.in Makefile
+ install: install-bin-files install-etc-files
+
+ install-bin-files:
+- $(top_srcdir)/mkinstalldirs $(DESTDIR)$(bindir)
++ mkdir -p $(DESTDIR)$(bindir)
+ for script in $(GENERATED_BIN_FILES); do \
+ $(INSTALL_SCRIPT) $$script $(DESTDIR)$(bindir)/$$script; \
+ done
+
+ install-etc-files:
+- $(top_srcdir)/mkinstalldirs $(DESTDIR)$(etcdir)
++ mkdir -p $(DESTDIR)$(etcdir)
+ INSTALL_FILES="$(GENERATED_ETC_FILES)"; \
+ for file in $(STATIC_FILES); do \
+ INSTALL_FILES="$$INSTALL_FILES $(srcdir)/$$file"; \
+diff --git a/man/Makefile.in b/man/Makefile.in
+index 2ac26f3..7c613bf 100644
+--- a/man/Makefile.in
++++ b/man/Makefile.in
+@@ -130,14 +130,14 @@ install: install-man1 install-man5 install-man8
+
+ # install the man pages in man1
+ install-man1:
+- $(top_srcdir)/mkinstalldirs $(DESTDIR)$(mandir)/man$(manext1)
++ mkdir -p $(DESTDIR)$(mandir)/man$(manext1)
+ for file in $(MAN1); do \
+ $(INSTALL_DATA) $$file $(DESTDIR)$(mandir)/man$(manext1) ; \
+ done
+
+ # install the man pages in man5
+ install-man5:
+- $(top_srcdir)/mkinstalldirs $(DESTDIR)$(mandir)/man$(manext5)
++ mkdir -p $(DESTDIR)$(mandir)/man$(manext5)
+ for file in $(MAN5); do \
+ $(INSTALL_DATA) $$file $(DESTDIR)$(mandir)/man$(manext5) ; \
+ done
+@@ -148,7 +148,7 @@ install-man5:
+
+ # install the man pages in man8
+ install-man8:
+- $(top_srcdir)/mkinstalldirs $(DESTDIR)$(mandir)/man$(manext8)
++ mkdir -p $(DESTDIR)$(mandir)/man$(manext8)
+ for file in $(MAN8); do \
+ $(INSTALL_DATA) $$file $(DESTDIR)$(mandir)/man$(manext8) ; \
+ done
+diff --git a/mts/Makefile.in b/mts/Makefile.in
+index f739e30..f606fef 100644
+--- a/mts/Makefile.in
++++ b/mts/Makefile.in
+@@ -43,7 +43,7 @@ SUBDIRS = smtp
+
+ all: all-recursive libmts.a
+
+-all-recursive:
++all-recursive $(OBJS):
+ for subdir in $(SUBDIRS); do \
+ (cd $$subdir && $(MAKE) $(MAKEDEFS) all) || exit 1; \
+ done
+diff --git a/uip/Makefile.in b/uip/Makefile.in
+index 5ed34f8..c9239b1 100644
+--- a/uip/Makefile.in
++++ b/uip/Makefile.in
+@@ -256,13 +256,13 @@ install: install-cmds install-misc install-lcmds install-scmds
+
+ # install commands
+ install-cmds:
+- $(top_srcdir)/mkinstalldirs $(DESTDIR)$(bindir)
++ mkdir -p $(DESTDIR)$(bindir)
+ for cmd in $(CMDS); do \
+ $(INSTALL_PROGRAM) $$cmd $(DESTDIR)$(bindir)/$$cmd; \
+ done
+
+ # install links
+-install-lcmds:
++install-lcmds: install-cmds
+ rm -f $(DESTDIR)$(bindir)/flists
+ rm -f $(DESTDIR)$(bindir)/folders
+ rm -f $(DESTDIR)$(bindir)/prev
+@@ -274,13 +274,13 @@ install-lcmds:
+
+ # install misc support binaries
+ install-misc:
+- $(top_srcdir)/mkinstalldirs $(DESTDIR)$(libdir)
++ mkdir -p $(DESTDIR)$(libdir)
+ for misc in $(MISC); do \
+ $(INSTALL_PROGRAM) $$misc $(DESTDIR)$(libdir)/$$misc; \
+ done
+
+ # install commands with special installation needs (thus no $(SCMDS) use here)
+-install-scmds:
++install-scmds: install-cmds
+ if test x$(SETGID_MAIL) != x; then \
+ $(INSTALL_PROGRAM) -g $(MAIL_SPOOL_GRP) -m 2755 inc $(DESTDIR)$(bindir)/$$cmd; \
+ else \