summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2022-06-13 09:59:38 -0400
committerCraig Andrews <candrews@gentoo.org>2022-06-13 09:59:55 -0400
commit6abf930da0be4c984839ff1301f332d8e27599d4 (patch)
tree515e52073a4a6519ef9f6d3f4fcd0ef2af3773d2 /mail-client/roundcube
parentsys-libs/libcap: drop 2.63 (diff)
downloadgentoo-6abf930da0be4c984839ff1301f332d8e27599d4.tar.gz
gentoo-6abf930da0be4c984839ff1301f332d8e27599d4.tar.bz2
gentoo-6abf930da0be4c984839ff1301f332d8e27599d4.zip
mail-client/roundcube: 1.6_rc version bump
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'mail-client/roundcube')
-rw-r--r--mail-client/roundcube/Manifest1
-rw-r--r--mail-client/roundcube/roundcube-1.6_rc.ebuild97
2 files changed, 98 insertions, 0 deletions
diff --git a/mail-client/roundcube/Manifest b/mail-client/roundcube/Manifest
index 1a90ec52c2d6..08ae46a25337 100644
--- a/mail-client/roundcube/Manifest
+++ b/mail-client/roundcube/Manifest
@@ -3,3 +3,4 @@ DIST roundcubemail-1.5.0-complete.tar.gz 7802014 BLAKE2B d81a521c264b47b55b7f868
DIST roundcubemail-1.5.1-complete.tar.gz 7827081 BLAKE2B 1547ba369ef8e5f2b99ed72d562de3f76ff973d9617f4394bb89e281917264c9304aeb2b44cffd16952c2295111707215fe0426ce0f3f1d4a5c94df5f0811235 SHA512 bcea37859fbbee2f474cda024e5648b823a2da44ae69e5036a5b7e6add1d73dbfc1cd1cc32a3e01e59b0a3ba2ea03d1b028eec8e8f139fc4fb3eea8b52e28203
DIST roundcubemail-1.5.2-complete.tar.gz 7852981 BLAKE2B 36920aa30301b96e1157a586508f3d460c26cfd692919b803bc8cecb31d99ebec5f93a62c725dd5d1dbd1ff68d59c97278b07eaabec42c5fb02c320c72fac8bf SHA512 96faa8c95c23b538ebfa91f58fb918b37185dbd1c09f2d128c9f8c800a0e3d6a2abbfa52753fb6a7ee47b633f35e2b31c92623107116dc760dfa9a22a4b2a23c
DIST roundcubemail-1.6-beta-complete.tar.gz 5941128 BLAKE2B 2114a683cbf0c4ec6f5ba0b4d5eebb0a1f96121724861c1b1b5ce30f6b3a8fae02693878cae168af3d7f906a705814233aef024ddbc24d807ccd089f24b63fe1 SHA512 8a8bc9749203980d33ede7b221b96e0990b4afbe41db65fca74f0a49334adcae717306d4fe8fe1a5c938bf9fbcb5c4745d4d67bc5a587503aa3a2e9cb8f6384b
+DIST roundcubemail-1.6-rc-complete.tar.gz 5961003 BLAKE2B a21a42f69c223eb50b38f6d02ab69ebe3cf55cc2848fc49cc0e238eead5f19751801654c0b5fb6954022d9b24562c04ba085bf668591a5b7ff7b306d3a950d1c SHA512 f12f7858b19ce16613ed02a8b4cf7b4fe16753454b7c4cf4e92bbb2d11de4ba1e00b09ba70b387133613967654aadaaf09167ed16c54809885eb48adcf54de5f
diff --git a/mail-client/roundcube/roundcube-1.6_rc.ebuild b/mail-client/roundcube/roundcube-1.6_rc.ebuild
new file mode 100644
index 000000000000..44d89c9d3634
--- /dev/null
+++ b/mail-client/roundcube/roundcube-1.6_rc.ebuild
@@ -0,0 +1,97 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit webapp
+
+MY_PN=${PN}mail
+MY_PV=${PV/_/-}
+MY_P=${MY_PN}-${MY_PV}
+
+DESCRIPTION="A browser-based multilingual IMAP client with an application-like user interface"
+HOMEPAGE="https://roundcube.net"
+
+# roundcube is GPL-licensed, the rest of the licenses here are
+# for bundled PEAR components, googiespell and utf8.class.php
+LICENSE="GPL-3 BSD PHP-2.02 PHP-3 MIT public-domain"
+
+IUSE="change-password enigma exif fileinfo ldap mysql postgres sqlite ssl spell zip"
+REQUIRED_USE="|| ( mysql postgres sqlite )"
+
+# this function only sets DEPEND so we need to include that in RDEPEND
+need_httpd_cgi
+
+RDEPEND="
+ ${DEPEND}
+ >=dev-lang/php-7.3.0[exif?,fileinfo?,filter,gd,iconv,intl,json(+),ldap?,pdo,postgres?,session,sqlite?,ssl?,unicode,xml,zip?]
+ virtual/httpd-php
+ change-password? (
+ dev-lang/php[sockets]
+ )
+ enigma? (
+ app-crypt/gnupg
+ )
+ mysql? (
+ || (
+ dev-lang/php[mysql]
+ dev-lang/php[mysqli]
+ )
+ )
+ spell? ( dev-lang/php[curl,spell] )
+"
+
+if [[ ${PV} == *9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/roundcube/roundcubemail"
+ EGIT_BRANCH="master"
+ BDEPEND="${BDEPEND}
+ app-arch/unzip
+ dev-php/composer
+ net-misc/curl"
+else
+ SRC_URI="https://github.com/${PN}/${MY_PN}/releases/download/${MY_PV}/${MY_P}-complete.tar.gz"
+ S="${WORKDIR}/${MY_P}"
+ KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86"
+fi
+
+src_unpack() {
+ if [[ "${PV}" == *9999* ]]; then
+ git-r3_src_unpack
+ pushd "${S}" > /dev/null || die
+ rm Makefile || die
+ mv composer.json-dist composer.json || die
+ composer install --no-dev || die
+ ./bin/install-jsdeps.sh || die
+ popd > /dev/null || die
+ else
+ default
+ fi
+}
+
+src_install() {
+ webapp_src_preinst
+
+ dodoc CHANGELOG.md INSTALL README.md UPGRADING SECURITY.md
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r [[:lower:]]* SQL
+ doins .htaccess
+
+ webapp_serverowned "${MY_HTDOCSDIR}"/logs
+ webapp_serverowned "${MY_HTDOCSDIR}"/temp
+
+ webapp_configfile "${MY_HTDOCSDIR}"/config/defaults.inc.php
+ webapp_postupgrade_txt en "${FILESDIR}/POST-UPGRADE_complete.txt"
+
+ webapp_src_install
+}
+
+pkg_postinst() {
+ webapp_pkg_postinst
+
+ if [[ -n ${REPLACING_VERSIONS} ]]; then
+ elog "You can review the post-upgrade instructions at:"
+ elog "${EROOT}/usr/share/webapps/${PN}/${PV}/postupgrade-en.txt"
+ fi
+}