summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-12-10 23:02:54 +0100
committerMichał Górny <mgorny@gentoo.org>2019-12-11 00:22:38 +0100
commit064af661d0c9a31cecdf348632bc5603333a9149 (patch)
tree2202373a7cafcb8a761d32747d4f62263aed64d5 /mail-client
parentdev-python/passlib: keyworded 1.7.1-r2 for hppa, bug #700918 (diff)
downloadgentoo-064af661d0c9a31cecdf348632bc5603333a9149.tar.gz
gentoo-064af661d0c9a31cecdf348632bc5603333a9149.tar.bz2
gentoo-064af661d0c9a31cecdf348632bc5603333a9149.zip
*/*: [QA] Fix trivial cases of MissingTestRestrict
The result was achieved via the following pipeline: pkgcheck scan -c RestrictTestCheck -R FormatReporter \ --format '{category}/{package}/{package}-{version}.ebuild' | xargs -n32 grep -L RESTRICT | xargs -n32 sed -i -e '/^IUSE=.*test/aRESTRICT="!test? ( test )"' The resulting metadata was compared before and after the change. Few Go ebuilds had to be fixed manually due to implicit RESTRICT=strip added by the eclass. Two ebuilds have to be fixed because of multiline IUSE. Suggested-by: Robin H. Johnson <robbat2@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/13942 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'mail-client')
-rw-r--r--mail-client/alot/alot-0.5.1.ebuild3
-rw-r--r--mail-client/alot/alot-0.6.ebuild3
-rw-r--r--mail-client/alot/alot-0.7-r1.ebuild3
-rw-r--r--mail-client/alot/alot-0.7.ebuild3
-rw-r--r--mail-client/alot/alot-0.8.1.ebuild1
-rw-r--r--mail-client/trojita/trojita-0.7-r2.ebuild3
-rw-r--r--mail-client/trojita/trojita-9999.ebuild1
7 files changed, 12 insertions, 5 deletions
diff --git a/mail-client/alot/alot-0.5.1.ebuild b/mail-client/alot/alot-0.5.1.ebuild
index 868e96638b99..fde61c5f8263 100644
--- a/mail-client/alot/alot-0.5.1.ebuild
+++ b/mail-client/alot/alot-0.5.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -15,6 +15,7 @@ LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="doc test"
+RESTRICT="!test? ( test )"
DEPEND="
doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
diff --git a/mail-client/alot/alot-0.6.ebuild b/mail-client/alot/alot-0.6.ebuild
index 863187a6ee6d..9ac4153a9cdc 100644
--- a/mail-client/alot/alot-0.6.ebuild
+++ b/mail-client/alot/alot-0.6.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -15,6 +15,7 @@ LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="doc test"
+RESTRICT="!test? ( test )"
DEPEND="
dev-python/setuptools[${PYTHON_USEDEP}]
diff --git a/mail-client/alot/alot-0.7-r1.ebuild b/mail-client/alot/alot-0.7-r1.ebuild
index 55e4adc56b62..ab4df39fe3b8 100644
--- a/mail-client/alot/alot-0.7-r1.ebuild
+++ b/mail-client/alot/alot-0.7-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -15,6 +15,7 @@ LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="doc test"
+RESTRICT="!test? ( test )"
DEPEND="
dev-python/setuptools[${PYTHON_USEDEP}]
diff --git a/mail-client/alot/alot-0.7.ebuild b/mail-client/alot/alot-0.7.ebuild
index 3432cecd6bcf..9ac4153a9cdc 100644
--- a/mail-client/alot/alot-0.7.ebuild
+++ b/mail-client/alot/alot-0.7.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -15,6 +15,7 @@ LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="doc test"
+RESTRICT="!test? ( test )"
DEPEND="
dev-python/setuptools[${PYTHON_USEDEP}]
diff --git a/mail-client/alot/alot-0.8.1.ebuild b/mail-client/alot/alot-0.8.1.ebuild
index 3461bbe6f022..809ff797b5ab 100644
--- a/mail-client/alot/alot-0.8.1.ebuild
+++ b/mail-client/alot/alot-0.8.1.ebuild
@@ -15,6 +15,7 @@ LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="doc test"
+RESTRICT="!test? ( test )"
RDEPEND="
>=app-crypt/gpgme-1.9.0[python,${PYTHON_USEDEP}]
diff --git a/mail-client/trojita/trojita-0.7-r2.ebuild b/mail-client/trojita/trojita-0.7-r2.ebuild
index 9f0e744cd9c8..19df3d885167 100644
--- a/mail-client/trojita/trojita-0.7-r2.ebuild
+++ b/mail-client/trojita/trojita-0.7-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -17,6 +17,7 @@ fi
LICENSE="|| ( GPL-2 GPL-3 )"
SLOT="0"
IUSE="+crypt +dbus debug +password test +zlib"
+RESTRICT="!test? ( test )"
REQUIRED_USE="password? ( dbus )"
diff --git a/mail-client/trojita/trojita-9999.ebuild b/mail-client/trojita/trojita-9999.ebuild
index fb3c38171e0d..f6b3d85cf534 100644
--- a/mail-client/trojita/trojita-9999.ebuild
+++ b/mail-client/trojita/trojita-9999.ebuild
@@ -18,6 +18,7 @@ HOMEPAGE="http://trojita.flaska.net/"
LICENSE="|| ( GPL-2 GPL-3 )"
SLOT="0"
IUSE="+crypt +dbus debug +password pim +spell test +zlib"
+RESTRICT="!test? ( test )"
REQUIRED_USE="password? ( dbus )"