summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobert Siebeck <gentoo.2019@r123.de>2020-01-20 11:58:51 +0100
committerJoonas Niilola <juippis@gentoo.org>2020-01-23 16:28:26 +0200
commit0ff9d1545e4af92a4dabbf0670c88f40934b571e (patch)
tree91bdbe1dd6c7eda5ce27a24c1ada17c6b1e8a8e1 /mail-client
parentsys-libs/argp-standalone: stable on ppc (diff)
downloadgentoo-0ff9d1545e4af92a4dabbf0670c88f40934b571e.tar.gz
gentoo-0ff9d1545e4af92a4dabbf0670c88f40934b571e.tar.bz2
gentoo-0ff9d1545e4af92a4dabbf0670c88f40934b571e.zip
mail-client/alpine: add new version 2.22
Signed-off-by: Robert Siebeck <gentoo.2019@r123.de> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'mail-client')
-rw-r--r--mail-client/alpine/Manifest1
-rw-r--r--mail-client/alpine/alpine-2.22.ebuild84
2 files changed, 85 insertions, 0 deletions
diff --git a/mail-client/alpine/Manifest b/mail-client/alpine/Manifest
index 85c4e714c83e..967c89adbb10 100644
--- a/mail-client/alpine/Manifest
+++ b/mail-client/alpine/Manifest
@@ -1,4 +1,5 @@
DIST alpine-2.00-chappa-115-all.patch.gz 212705 BLAKE2B 99c21a7b74a4ea04c3bb54947868b31f0e65eef0e35e515d14d9a701e5809fa1a7191444a353de3ba08b821bdf71543faaf261d4a427c2d1e366bbc00d4bf337 SHA512 5e9fcb6a80dbd18bed26109caa6b7aa5eeb88de420861d9998c32f031e8279d6367c28b6670fb54203d1b14c3dc47cf5ad25b42e4949157de64f3f1fd36d0aa7
DIST alpine-2.00.tar.bz2 5222673 BLAKE2B 38a9cd1fe3e291119b889bca0d304333cdf9ad8c63bc7923ea0735d3528c933b7d4dfe70bb353fe7b6047dafdaee3218a35e561f542b6ac763b60cb986509371 SHA512 17c6e65fbe767d4f9ffb3d3c2bb3deeab9d3620cd046cbb0009290aa484c9254effa992957631f0603bd82b82aeca2923d391aee6d20a7684d5830fbca8ce4d2
DIST alpine-2.21.1.tar.gz 7490699 BLAKE2B f3aeafb55697701f6edda43659c9d27c7d7dab74f8e332e867f354ce555c26037f4b642af80f18db249dd7269f80bd880bc315ba4ae08ae7f63abc7998cea073 SHA512 78b47bd9e9dfc652bc407fe736d8b7526625782c332803cf01e5214a2b0a5af21736b8a2e685348913f6e2b10c80dced12081202294e9c61e3168b3a2b9657b7
+DIST alpine-2.22.tar.xz 6336604 BLAKE2B 65cab2000b6c606c002efcca6e731d2c87329b4685dec81d202e95598b4302175137ea84f079af1f766a6ef99d0b2cb51132e12539bea7f4d24954bb48af7bea SHA512 7737dce02ac94170948df7fccb61380c6cb101190e37f5b3ba281d573f54df1db24569d177b460f49bfff381a922be2e4b0f3a0f1a213d88a64d361aedc3c4f1
DIST alpine-843b2f1.tar.gz 7490140 BLAKE2B 13ac5ef43dd729a7cf21b44dcd6feace3e1813672aec537fd05d5ff90b67bec145ceef71cfcf35b0cb7e250bb307556f5dcf8ebb024bc6366fd0ace0a7c41161 SHA512 106caa7bfe86fd5e82554ba68b9ee579cd8495bcd0dfbf82d9d75da2df3bd292d42d67af8ec737091f2a820b2555c25bbf0058c9c7bb5de5f950b570ffc25c4d
diff --git a/mail-client/alpine/alpine-2.22.ebuild b/mail-client/alpine/alpine-2.22.ebuild
new file mode 100644
index 000000000000..75f6d6673383
--- /dev/null
+++ b/mail-client/alpine/alpine-2.22.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools toolchain-funcs
+
+DESCRIPTION="An easy to use text-based based mail and news client"
+HOMEPAGE="http://alpine.x10host.com/alpine/ https://repo.or.cz/alpine.git/"
+SRC_URI="http://alpine.x10host.com/alpine/release/src/${P}.tar.xz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86"
+IUSE="doc ipv6 kerberos ldap libressl nls onlyalpine passfile smime spell ssl threads"
+
+DEPEND=">=sys-libs/ncurses-5.1:0=
+ kerberos? ( app-crypt/mit-krb5 )
+ ldap? ( net-nds/openldap )
+ spell? ( app-text/aspell )
+ ssl? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ )
+"
+RDEPEND="${DEPEND}
+ app-misc/mime-types
+"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ myconf=(
+ --without-tcl
+ --with-system-pinerc="${EPREFIX}"/etc/pine.conf
+ --with-system-fixed-pinerc="${EPREFIX}"/etc/pine.conf.fixed
+ $(use_with ldap)
+ $(use_with ssl)
+ $(use_with passfile passfile .pinepwd)
+ $(use_with kerberos krb5)
+ $(use_with threads pthread)
+ $(use_with spell interactive-spellcheck /usr/bin/aspell)
+ $(use_enable nls)
+ $(use_with ipv6)
+ $(use_with smime)
+ )
+
+ if use ssl; then
+ myconf+=(
+ --with-ssl-include-dir="${EPREFIX}"/usr/include/openssl
+ --with-ssl-lib-dir="${EPREFIX}"/usr/$(get_libdir)
+ --with-ssl-certs-dir="${EPREFIX}"/etc/ssl/certs
+ )
+ fi
+ econf "${myconf[@]}"
+}
+
+src_compile() {
+ emake -j1 AR=$(tc-getAR)
+}
+
+src_install() {
+ if use onlyalpine ; then
+ dobin alpine/alpine
+ doman doc/man1/alpine.1
+ else
+ emake -j1 DESTDIR="${D}" install
+ doman doc/man1/*.1
+ fi
+
+ dodoc NOTICE README*
+
+ if use doc ; then
+ dodoc doc/brochure.txt
+
+ dodoc -r doc/tech-notes/
+ newdoc "${S}/doc/mailcap.unx" mailcap.unx.sample
+ newdoc "${S}/doc/mime.types" mime.types.sample
+ docompress -x /usr/share/doc/${PF}/mailcap.unx.sample /usr/share/doc/${PF}/mime.types.sample
+ fi
+}