summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobert Siebeck <gentoo.2019@r123.de>2020-10-11 15:23:47 +0200
committerJoonas Niilola <juippis@gentoo.org>2020-10-16 10:52:15 +0300
commit2117b64ae03654f006f0252e1254a389c33941f6 (patch)
treeb3b4898dfb67ca2bc5ac5c36e480c57c7594d93f /mail-client
parentapp-admin/recursos: Remove last-rited pkg (diff)
downloadgentoo-2117b64ae03654f006f0252e1254a389c33941f6.tar.gz
gentoo-2117b64ae03654f006f0252e1254a389c33941f6.tar.bz2
gentoo-2117b64ae03654f006f0252e1254a389c33941f6.zip
mail-client/alpine: add version 2.24
Signed-off-by: Robert Siebeck <gentoo.2019@r123.de> Closes: https://github.com/gentoo/gentoo/pull/17887 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'mail-client')
-rw-r--r--mail-client/alpine/Manifest2
-rw-r--r--mail-client/alpine/alpine-2.24.ebuild89
2 files changed, 91 insertions, 0 deletions
diff --git a/mail-client/alpine/Manifest b/mail-client/alpine/Manifest
index 673ec9627e6c..5a8cc2078417 100644
--- a/mail-client/alpine/Manifest
+++ b/mail-client/alpine/Manifest
@@ -1,2 +1,4 @@
DIST alpine-2.23-chappa.patch.gz 172604 BLAKE2B f814a269fe316dd42e73f98b09a67b26f8d0c5db9bc83ebcc6145f7f3373f14a5fa9f7991f60a4186c0f078428fa0a38bc81b0459998045ea433438f730f05a8 SHA512 5195db336651da161b3d94afeab8f46fd6bd3d1953db72b8f453355b46eafe8afe26eccb2466024f077fc3e40ff52e1a14a126ce3cc33fdcfcaeded67f9422d0
DIST alpine-2.23.tar.xz 6330784 BLAKE2B e7be73dc0ccf04cfbd8712e70f8b114063983b971c1d967765b41ab0bf86369815d954e85fc4d9622539b1e3a6324ffda635a2808b9439a123302e7f9c9f421d SHA512 abc3675b18d6bd20a547b8e2c3f1f4c668aee2f2d20f426f28b4b3d4cfd66762777007441da3b0fda74e625c71bc2ef05434089508c2af804e62cf216df5554b
+DIST alpine-2.24-chappa.patch.gz 172010 BLAKE2B 39f5336ead355a4b78bcdd5b44dc398888bf93f3c3efa95b3ad8a86f3a0dda13f03164a03fbed898150864130648a204a6b5d9e32c3437138878516d014c8bbe SHA512 7152a8e4a79a530345448267204a96bc2585b4fccb23f011fd4dc97bc713696b8eb7ca9563655d8da33570ef14bf29577f82fe0f104c80590a43b0e74ec89e81
+DIST alpine-2.24.tar.xz 7341676 BLAKE2B 63e2d9387f1a369f9a4623625524f25eec64c600672092608256fd2827c094fae1384b35da84ec5f5865295744982ede533551dc47b6f0c80f2405ed16cad546 SHA512 642a51f73732ebdf7c40e2b66370aa2f48fb13b349b477871b26295c3e8b860a0cc78dec9f80efc6ea74c548a080ceff04181eb18c35a9c8cae8d8ef831178c5
diff --git a/mail-client/alpine/alpine-2.24.ebuild b/mail-client/alpine/alpine-2.24.ebuild
new file mode 100644
index 000000000000..1767cfad25d8
--- /dev/null
+++ b/mail-client/alpine/alpine-2.24.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools toolchain-funcs
+
+DESCRIPTION="An easy to use text-based based mail and news client"
+HOMEPAGE="http://alpine.x10host.com/alpine/ https://repo.or.cz/alpine.git/"
+CHAPPA_PATCH_NAME="${P}-chappa.patch"
+SRC_URI="http://alpine.x10host.com/alpine/release/src/${P}.tar.xz
+ chappa? ( http://alpine.x10host.com/alpine/patches/${P}/all.patch.gz -> ${CHAPPA_PATCH_NAME}.gz ) "
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc x86"
+IUSE="+chappa doc ipv6 kerberos ldap libressl nls onlyalpine passfile smime spell ssl threads"
+
+DEPEND="sys-libs/ncurses
+ kerberos? ( app-crypt/mit-krb5 )
+ ldap? ( net-nds/openldap )
+ spell? ( app-text/aspell )
+ ssl? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ )
+"
+RDEPEND="${DEPEND}
+ app-misc/mime-types
+"
+
+src_prepare() {
+ default
+ use chappa && eapply "${WORKDIR}/${CHAPPA_PATCH_NAME}"
+ eautoreconf
+ tc-export CC RANLIB AR
+ export CC_FOR_BUILD=$(tc-getBUILD_CC)
+}
+
+src_configure() {
+ myconf=(
+ --without-tcl
+ --with-system-pinerc="${EPREFIX}"/etc/pine.conf
+ --with-system-fixed-pinerc="${EPREFIX}"/etc/pine.conf.fixed
+ $(use_with ldap)
+ $(use_with ssl)
+ $(use_with passfile passfile .pinepwd)
+ $(use_with kerberos krb5)
+ $(use_with threads pthread)
+ $(use_with spell interactive-spellcheck /usr/bin/aspell)
+ $(use_enable nls)
+ $(use_with ipv6)
+ $(use_with smime)
+ )
+
+ if use ssl; then
+ myconf+=(
+ --with-ssl-include-dir="${EPREFIX}"/usr/include/openssl
+ --with-ssl-lib-dir="${EPREFIX}"/usr/$(get_libdir)
+ --with-ssl-certs-dir="${EPREFIX}"/etc/ssl/certs
+ )
+ fi
+ econf "${myconf[@]}"
+}
+
+src_compile() {
+ emake -j1 AR=$(tc-getAR)
+}
+
+src_install() {
+ if use onlyalpine ; then
+ dobin alpine/alpine
+ doman doc/man1/alpine.1
+ else
+ emake -j1 DESTDIR="${D}" install
+ doman doc/man1/*.1
+ fi
+
+ dodoc NOTICE README*
+
+ if use doc ; then
+ dodoc doc/brochure.txt
+
+ dodoc -r doc/tech-notes/
+ newdoc "${S}/doc/mailcap.unx" mailcap.unx.sample
+ newdoc "${S}/doc/mime.types" mime.types.sample
+ docompress -x /usr/share/doc/${PF}/mailcap.unx.sample /usr/share/doc/${PF}/mime.types.sample
+ fi
+}