summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPhilippe Chaintreuil <gentoo_bugs_peep@parallaxshift.com>2020-01-03 07:14:41 -0500
committerMiroslav Šulc <fordfrog@gentoo.org>2020-02-09 23:33:29 +0100
commit2db4642378cb97be10c5e4858bcb7263e0e482b4 (patch)
tree58a1f08c7092e77959dfca045c8ccdfaabc28bf1 /mail-client
parentmedia-gfx/kphotoalbum: Drop 5.6 (r0) (diff)
downloadgentoo-2db4642378cb97be10c5e4858bcb7263e0e482b4.tar.gz
gentoo-2db4642378cb97be10c5e4858bcb7263e0e482b4.tar.bz2
gentoo-2db4642378cb97be10c5e4858bcb7263e0e482b4.zip
mail-client/roundcube: 1.4.2 version bump
- Also bumped copyright date: Happy New Year! Closes: https://bugs.gentoo.org/704690 Closes: https://github.com/gentoo/gentoo/pull/14226 Package-Manager: Portage-2.3.79, Repoman-2.3.16 Signed-off-by: Philippe Chaintreuil <gentoo_bugs_peep@parallaxshift.com> Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'mail-client')
-rw-r--r--mail-client/roundcube/Manifest1
-rw-r--r--mail-client/roundcube/roundcube-1.4.2.ebuild73
2 files changed, 74 insertions, 0 deletions
diff --git a/mail-client/roundcube/Manifest b/mail-client/roundcube/Manifest
index 09042d04c265..3a7c96218d0c 100644
--- a/mail-client/roundcube/Manifest
+++ b/mail-client/roundcube/Manifest
@@ -3,3 +3,4 @@ DIST roundcubemail-1.3.8-complete.tar.gz 5534385 BLAKE2B 2f0cb528d0901d267c74d57
DIST roundcubemail-1.3.9-complete.tar.gz 5521697 BLAKE2B 4689bb43ff02b99a9b2b06d6370a5dce0ec4eca4e4da2a74e33e77ec74ec14bf22b6bab415c8b5fde9bd76bfaed87f183a8979edb353da3ed947f9bfdb0ecb15 SHA512 42ae9b772272b3e82476beeeb0fc5a909fb07ed0bfbdb655627b1e31da1c292f67f5a305452de31b2d60fe5905bcacabd6874dea394a9b0fd66b7921d73500ac
DIST roundcubemail-1.4.0-complete.tar.gz 6997256 BLAKE2B b19a2d049512ceb53b3844f4680ed061044d2d142bef322c067b381e3be57ecb3181cac4f2492a162da1417fefb4028c36d34dae4bf9064c97568f681bd0c78b SHA512 274372793f1f3af761702f8972f6360f8c8e64a705ff96f1432f6a520d24c9ca0e8ccc3933f26433f1c864bd6c381066fc9eb48bf97e9497b4cbff855412d811
DIST roundcubemail-1.4.1-complete.tar.gz 6998687 BLAKE2B ff33e512bb202d37d77ae2a4c7820f1061598bee1eb01bed5f15b25ad0e27c0cfe3611b44d451982491b702abcf6d7ae1bc88cbd303bc9a2573fc79efc54bec5 SHA512 0c8e09e93c86aad0f3e3a5a81c5e9ad8ab8aee101ae8ebb78d29556575db94a51a07cbf955ec79235425a961427b826ad27fae750b8eae785eedd195161dabed
+DIST roundcubemail-1.4.2-complete.tar.gz 7006013 BLAKE2B f92b94de3ce58cd145ce3d30875902d44410cb039176be5c2d09a23741b08405b21107b03a0ae302cfdf5a845a49cf044f13a09b582f291639648aac3b2f4c81 SHA512 3f705bc38b44a0b7ea3241b0222f607b040ec01c8ea400b6b6222fbe346570c5f3450e5a188bab99ea171481453eb3f5b1e7457070ace1144558ec662a4273bb
diff --git a/mail-client/roundcube/roundcube-1.4.2.ebuild b/mail-client/roundcube/roundcube-1.4.2.ebuild
new file mode 100644
index 000000000000..6d3b3ede4e45
--- /dev/null
+++ b/mail-client/roundcube/roundcube-1.4.2.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit webapp
+
+MY_PN=${PN}mail
+MY_PV=${PV/_/-}
+MY_P=${MY_PN}-${MY_PV}
+
+DESCRIPTION="A browser-based multilingual IMAP client with an application-like user interface"
+HOMEPAGE="https://roundcube.net"
+SRC_URI="https://github.com/${PN}/${MY_PN}/releases/download/${MY_PV}/${MY_P}-complete.tar.gz"
+
+# roundcube is GPL-licensed, the rest of the licenses here are
+# for bundled PEAR components, googiespell and utf8.class.php
+LICENSE="GPL-3 BSD PHP-2.02 PHP-3 MIT public-domain"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86"
+
+IUSE="change-password enigma ldap mysql postgres sqlite ssl spell"
+REQUIRED_USE="|| ( mysql postgres sqlite )"
+
+# this function only sets DEPEND so we need to include that in RDEPEND
+need_httpd_cgi
+
+RDEPEND="
+ ${DEPEND}
+ >=dev-lang/php-5.4.0[filter,gd,iconv,json,ldap?,pdo,postgres?,session,sqlite?,ssl?,unicode,xml]
+ virtual/httpd-php
+ change-password? (
+ dev-lang/php[sockets]
+ )
+ enigma? (
+ app-crypt/gnupg
+ )
+ mysql? (
+ || (
+ dev-lang/php[mysql]
+ dev-lang/php[mysqli]
+ )
+ )
+ spell? ( dev-lang/php[curl,spell] )
+"
+
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+ webapp_src_preinst
+
+ dodoc CHANGELOG INSTALL README.md UPGRADING
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r [[:lower:]]* SQL
+ doins .htaccess
+
+ webapp_serverowned "${MY_HTDOCSDIR}"/logs
+ webapp_serverowned "${MY_HTDOCSDIR}"/temp
+
+ webapp_configfile "${MY_HTDOCSDIR}"/config/defaults.inc.php
+ webapp_postupgrade_txt en "${FILESDIR}/POST-UPGRADE_complete.txt"
+
+ webapp_src_install
+}
+
+pkg_postinst() {
+ webapp_pkg_postinst
+
+ if [[ -n ${REPLACING_VERSIONS} ]]; then
+ elog "You can review the post-upgrade instructions at:"
+ elog "${EROOT%/}/usr/share/webapps/${PN}/${PV}/postupgrade-en.txt"
+ fi
+}