summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Bock <nicolasbock@gentoo.org>2021-02-05 09:23:50 -0700
committerNicolas Bock <nicolasbock@gentoo.org>2021-02-05 11:58:44 -0700
commit30b0b12889fed698bd2cd4bad933d28bb7a20561 (patch)
treed5fe7093e93fcdb9f453f0044d98a6763e1ec4a2 /mail-client
parentsys-kernel/raspberrypi-sources: rename tarball for 5.10 (for now) (diff)
downloadgentoo-30b0b12889fed698bd2cd4bad933d28bb7a20561.tar.gz
gentoo-30b0b12889fed698bd2cd4bad933d28bb7a20561.tar.bz2
gentoo-30b0b12889fed698bd2cd4bad933d28bb7a20561.zip
mail-client/neomutt: Version bump to 2021-02-05
Signed-off-by: Nicolas Bock <nicolasbock@gentoo.org>
Diffstat (limited to 'mail-client')
-rw-r--r--mail-client/neomutt/Manifest1
-rw-r--r--mail-client/neomutt/neomutt-20210205.ebuild148
-rw-r--r--mail-client/neomutt/neomutt-99999999.ebuild4
3 files changed, 151 insertions, 2 deletions
diff --git a/mail-client/neomutt/Manifest b/mail-client/neomutt/Manifest
index ae5516386016..b99eaaa1de50 100644
--- a/mail-client/neomutt/Manifest
+++ b/mail-client/neomutt/Manifest
@@ -1,2 +1,3 @@
DIST neomutt-20201127.tar.gz 3456248 BLAKE2B 49d12285e4adfb15cd70f3c6cb06d0d260ccd3f3817ae6902ac5a58105c1fc36f2d6ead3927911b970bf2e72dcd8220340c900c20e011e09ac2159e7c4123987 SHA512 01e45aa00794cfb1c74a45a7f144962c8ab6dee03b0e5ce39a24d0c50817b909cac440a072c5d8b21ee7656c37b77bba4ba818de73710ccc3b0f76fd3ddd71cf
+DIST neomutt-20210205.tar.gz 3476980 BLAKE2B 2b8f07a957d668f0903ae3f48d72e0b00414b9ed0411723bc725cd2369ed16c31e461799a0161f3b6caecb8b3a182a0ad9ca7bbb5431ed9ff67cae5dc87b11e5 SHA512 4e9faaa989eb17d1f65e835d3ad37bbda3307f9a939f351776d4cb4677d856fa998ba0eff04bf0cf344485977077695e07c55e79e0800888f646c46fbfac8554
DIST neomutt-test-files-8629adab700a75c54e8e28bf05ad092503a98f75.tar.gz 3673 BLAKE2B 50354f19aedc5fc07d59ecb5b38fa65de16119bc0929f47014bd35dab4d3a4e5953c8b35670f3440003cf0cbccc2d0d2b3a869dc929cdc3cd60b02790270fb54 SHA512 3d4962210bc558234d818801dcaa7851a0aef011c96d91c054af535186ffda42059fc61fb148c48e1b076999fe3159b31589a69a29ed1897f8928f52fcc157d3
diff --git a/mail-client/neomutt/neomutt-20210205.ebuild b/mail-client/neomutt/neomutt-20210205.ebuild
new file mode 100644
index 000000000000..aec8ac349253
--- /dev/null
+++ b/mail-client/neomutt/neomutt-20210205.ebuild
@@ -0,0 +1,148 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit eutils
+
+if [[ ${PV} =~ 99999999$ ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/neomutt/neomutt.git"
+else
+ SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~ppc64 ~s390 ~x86"
+fi
+
+TEST_FILES_COMMIT=8629adab700a75c54e8e28bf05ad092503a98f75
+SRC_URI+=" test? ( https://github.com/${PN}/neomutt-test-files/archive/${TEST_FILES_COMMIT}.tar.gz -> neomutt-test-files-${TEST_FILES_COMMIT}.tar.gz )"
+
+DESCRIPTION="A small but very powerful text-based mail client"
+HOMEPAGE="https://neomutt.org/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="berkdb doc gdbm gnutls gpgme idn kerberos kyotocabinet libressl
+ lmdb nls notmuch pgp-classic qdbm sasl selinux slang smime-classic
+ ssl tokyocabinet test"
+
+CDEPEND="
+ app-misc/mime-types
+ berkdb? (
+ || (
+ sys-libs/db:6.2
+ sys-libs/db:5.3
+ sys-libs/db:4.8
+ )
+ <sys-libs/db-6.3:=
+ )
+ gdbm? ( sys-libs/gdbm:= )
+ kyotocabinet? ( dev-db/kyotocabinet )
+ lmdb? ( dev-db/lmdb:= )
+ nls? ( virtual/libintl )
+ qdbm? ( dev-db/qdbm )
+ tokyocabinet? ( dev-db/tokyocabinet )
+ gnutls? ( >=net-libs/gnutls-1.0.17:= )
+ gpgme? ( >=app-crypt/gpgme-1.13.1:= )
+ idn? ( net-dns/libidn:= )
+ kerberos? ( virtual/krb5 )
+ notmuch? ( net-mail/notmuch:= )
+ sasl? ( >=dev-libs/cyrus-sasl-2 )
+ !slang? ( sys-libs/ncurses:0= )
+ slang? ( sys-libs/slang )
+ ssl? (
+ !libressl? ( >=dev-libs/openssl-1.0.2u:0= )
+ libressl? ( dev-libs/libressl:= )
+ )
+"
+DEPEND="${CDEPEND}
+ dev-lang/tcl:=
+ net-mail/mailbase
+ doc? (
+ dev-libs/libxml2
+ dev-libs/libxslt
+ app-text/docbook-xsl-stylesheets
+ || (
+ www-client/lynx
+ www-client/w3m
+ www-client/elinks
+ )
+ )
+"
+RDEPEND="${CDEPEND}
+ selinux? ( sec-policy/selinux-mutt )
+"
+
+RESTRICT="!test? ( test )"
+
+src_configure() {
+ local myconf=(
+ "$(usex doc --full-doc --disable-doc)"
+ "$(use_enable nls)"
+ "$(use_enable notmuch)"
+
+ "$(use_enable gpgme)"
+ "$(use_enable pgp-classic pgp)"
+ "$(use_enable smime-classic smime)"
+
+ # Database backends.
+ "$(use_enable berkdb bdb)"
+ "$(use_enable gdbm)"
+ "$(use_enable kyotocabinet)"
+ "$(use_enable qdbm)"
+ "$(use_enable tokyocabinet)"
+
+ "$(use_enable idn)"
+ "$(use_enable kerberos gss)"
+ "$(use_enable lmdb)"
+ "$(use_enable sasl)"
+ "--with-ui=$(usex slang slang ncurses)"
+ "--sysconfdir=${EPREFIX}/etc/${PN}"
+ "$(use_enable ssl)"
+ "$(use_enable gnutls)"
+
+ "$(usex test --testing --disable-testing)"
+ )
+
+ econf CCACHE=none "${myconf[@]}"
+}
+
+src_test() {
+ local test_dir="$(readlink --canonicalize ${S}/../neomutt-test-files-${TEST_FILES_COMMIT})"
+ pushd ${test_dir} || die "Could not cd into test_dir"
+ NEOMUTT_TEST_DIR="${test_dir}" ./setup.sh \
+ || die "Failed to run the setup.sh script"
+ popd || die "Could not cd back"
+ NEOMUTT_TEST_DIR="${test_dir}" emake test
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ # A man-page is always handy, so fake one - here neomuttrc.5 (neomutt.1
+ # already exists)
+ if use !doc; then
+ sed -n \
+ -e '/^\(CC_FOR_BUILD\|CFLAGS_FOR_BUILD\)\s*=/p' \
+ -e '/^\(EXTRA_CFLAGS_FOR_BUILD\|LDFLAGS_FOR_BUILD\)\s*=/p' \
+ -e '/^\(EXEEXT\|SRCDIR\)\s*=/p' \
+ Makefile > docs/Makefile.fakedoc || die
+ sed -n \
+ -e '/^MAKEDOC_CPP\s*=/,/^\s*$/p' \
+ -e '/^docs\/\(makedoc$(EXEEXT)\|neomutt\.1\|neomuttrc\.5\)\s*:/,/^\s*$/p' \
+ docs/Makefile.autosetup >> docs/Makefile.fakedoc || die
+ emake -f docs/Makefile.fakedoc docs/neomutt.1
+ emake -f docs/Makefile.fakedoc docs/neomuttrc.5
+ doman docs/neomutt.1 docs/neomuttrc.5
+ fi
+
+ dodoc LICENSE* ChangeLog* README*
+}
+
+pkg_postinst() {
+ if use gpgme && ( use pgp-classic || use smime-classic ); then
+ ewarn " Note that gpgme (old gpg) includes both pgp and smime"
+ ewarn " support. You can probably remove pgp-classic (old crypt)"
+ ewarn " and smime-classic (old smime) from your USE-flags and"
+ ewarn " only enable gpgme."
+ fi
+}
diff --git a/mail-client/neomutt/neomutt-99999999.ebuild b/mail-client/neomutt/neomutt-99999999.ebuild
index c2227b88db2d..aec8ac349253 100644
--- a/mail-client/neomutt/neomutt-99999999.ebuild
+++ b/mail-client/neomutt/neomutt-99999999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -10,7 +10,7 @@ if [[ ${PV} =~ 99999999$ ]]; then
EGIT_REPO_URI="https://github.com/neomutt/neomutt.git"
else
SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~ppc64 ~x86"
+ KEYWORDS="~amd64 ~ppc64 ~s390 ~x86"
fi
TEST_FILES_COMMIT=8629adab700a75c54e8e28bf05ad092503a98f75