summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2018-09-28 13:43:37 +0200
committerThomas Deutschmann <whissi@gentoo.org>2018-09-28 13:43:53 +0200
commit34ae111abcc96ee08ef046f7b6dab0d4dd2dd2c6 (patch)
tree2e727dbecd8a93b7f7c04bf86079f5e64d973456 /mail-client
parentwww-client/firefox: add rust-1.29+ support (diff)
downloadgentoo-34ae111abcc96ee08ef046f7b6dab0d4dd2dd2c6.tar.gz
gentoo-34ae111abcc96ee08ef046f7b6dab0d4dd2dd2c6.tar.bz2
gentoo-34ae111abcc96ee08ef046f7b6dab0d4dd2dd2c6.zip
mail-client/thunderbird: add rust-1.29+ support
Closes: https://bugs.gentoo.org/666898 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org> Package-Manager: Portage-2.3.50, Repoman-2.3.11
Diffstat (limited to 'mail-client')
-rw-r--r--mail-client/thunderbird/files/thunderbird-60.0-rust-1.29-comp.patch37
-rw-r--r--mail-client/thunderbird/thunderbird-60.0-r3.ebuild1
2 files changed, 38 insertions, 0 deletions
diff --git a/mail-client/thunderbird/files/thunderbird-60.0-rust-1.29-comp.patch b/mail-client/thunderbird/files/thunderbird-60.0-rust-1.29-comp.patch
new file mode 100644
index 000000000000..6fbd13fe639a
--- /dev/null
+++ b/mail-client/thunderbird/files/thunderbird-60.0-rust-1.29-comp.patch
@@ -0,0 +1,37 @@
+https://bugs.gentoo.org/666898
+
+https://bugzilla.mozilla.org/show_bug.cgi?id=1479540
+--- a/build/moz.configure/init.configure
++++ b/build/moz.configure/init.configure
+@@ -572,17 +572,26 @@ option('--target', nargs=1,
+ @imports(_from='__builtin__', _import='KeyError')
+ @imports(_from='__builtin__', _import='ValueError')
+ def split_triplet(triplet, allow_unknown=False):
+ # The standard triplet is defined as
+ # CPU_TYPE-MANUFACTURER-OPERATING_SYSTEM
+ # There is also a quartet form:
+ # CPU_TYPE-MANUFACTURER-KERNEL-OPERATING_SYSTEM
+ # But we can consider the "KERNEL-OPERATING_SYSTEM" as one.
+- cpu, manufacturer, os = triplet.split('-', 2)
++ # Additionally, some may omit "unknown" when the manufacturer
++ # is not specified and emit
++ # CPU_TYPE-OPERATING_SYSTEM
++ parts = triplet.split('-', 2)
++ if len(parts) == 3:
++ cpu, _, os = parts
++ elif len(parts) == 2:
++ cpu, os = parts
++ else:
++ die("Unexpected triplet string: %s" % triplet)
+
+ # Autoconf uses config.sub to validate and canonicalize those triplets,
+ # but the granularity of its results has never been satisfying to our
+ # use, so we've had our own, different, canonicalization. We've also
+ # historically not been very consistent with how we use the canonicalized
+ # values. Hopefully, this will help us make things better.
+ # The tests are inherited from our decades-old autoconf-based configure,
+ # which can probably be improved/cleaned up because they are based on a
+
+
+
+
diff --git a/mail-client/thunderbird/thunderbird-60.0-r3.ebuild b/mail-client/thunderbird/thunderbird-60.0-r3.ebuild
index f9ecfc867915..86b25342c2a6 100644
--- a/mail-client/thunderbird/thunderbird-60.0-r3.ebuild
+++ b/mail-client/thunderbird/thunderbird-60.0-r3.ebuild
@@ -195,6 +195,7 @@ src_prepare() {
|| die
eapply "${WORKDIR}/firefox"
eapply "${FILESDIR}"/${PN}-60.0-blessings-TERM.patch # 654316
+ eapply "${FILESDIR}"/${PN}-60.0-rust-1.29-comp.patch
# Ensure that are plugins dir is enabled as default
sed -i -e "s:/usr/lib/mozilla/plugins:/usr/lib/nsbrowser/plugins:" \