summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-09-08 18:27:28 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-09-08 18:27:28 +0200
commit5c3995890446ce24d99ca96ee14ebe82ba200323 (patch)
tree48528a12ef52235acfaaf9aed84f978b552845e4 /mail-client
parentmail-client/trojita: Unconditionally enable the abook plugin (diff)
downloadgentoo-5c3995890446ce24d99ca96ee14ebe82ba200323.tar.gz
gentoo-5c3995890446ce24d99ca96ee14ebe82ba200323.tar.bz2
gentoo-5c3995890446ce24d99ca96ee14ebe82ba200323.zip
mail-client/trojita: USE addressbook -> pim for kde-apps/akonadi plugin
USE addressbook has become too generic since abook plugin is always being built. Thanks-to: Jan Kundrát <jkt@kde.org> Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'mail-client')
-rw-r--r--mail-client/trojita/metadata.xml2
-rw-r--r--mail-client/trojita/trojita-9999.ebuild6
2 files changed, 4 insertions, 4 deletions
diff --git a/mail-client/trojita/metadata.xml b/mail-client/trojita/metadata.xml
index 7a659b227afb..d5712067bc92 100644
--- a/mail-client/trojita/metadata.xml
+++ b/mail-client/trojita/metadata.xml
@@ -14,8 +14,8 @@
<name>Gentoo KDE Project</name>
</maintainer>
<use>
- <flag name="addressbook">Build <pkg>kde-apps/akonadi</pkg> addressbook plugin</flag>
<flag name="password">Store passwords securely via <pkg>dev-libs/qtkeychain</pkg></flag>
+ <flag name="pim">Enable support for KDE PIM resources integration via <pkg>kde-apps/akonadi</pkg> addressbook plugin</flag>
</use>
<upstream>
<remote-id type="sourceforge">trojita</remote-id>
diff --git a/mail-client/trojita/trojita-9999.ebuild b/mail-client/trojita/trojita-9999.ebuild
index 75c450faa1eb..78c9bfff1e45 100644
--- a/mail-client/trojita/trojita-9999.ebuild
+++ b/mail-client/trojita/trojita-9999.ebuild
@@ -17,7 +17,7 @@ HOMEPAGE="http://trojita.flaska.net/"
LICENSE="|| ( GPL-2 GPL-3 )"
SLOT="0"
-IUSE="addressbook +crypt +dbus debug +password +spell test +zlib"
+IUSE="+crypt +dbus debug +password pim +spell test +zlib"
REQUIRED_USE="password? ( dbus )"
@@ -34,13 +34,13 @@ DEPEND="
dev-qt/qtsvg:5
dev-qt/qtwebkit:5
dev-qt/qtwidgets:5
- addressbook? ( kde-apps/akonadi-contacts:5 )
crypt? (
>=app-crypt/gpgme-1.8.0[cxx,qt5]
dev-libs/mimetic
)
dbus? ( dev-qt/qtdbus:5 )
password? ( dev-libs/qtkeychain[qt5(+)] )
+ pim? ( kde-apps/akonadi-contacts:5 )
spell? ( kde-frameworks/sonnet:5 )
zlib? ( sys-libs/zlib )
"
@@ -59,12 +59,12 @@ src_prepare() {
src_configure() {
local mycmakeargs=(
-DWITH_ABOOKADDRESSBOOK_PLUGIN=ON
- -DWITH_AKONADIADDRESSBOOK_PLUGIN=$(usex addressbook)
-DWITH_CRYPTO_MESSAGES=$(usex crypt)
-DWITH_GPGMEPP=$(usex crypt)
-DWITH_MIMETIC=$(usex crypt)
-DWITH_DBUS=$(usex dbus)
-DWITH_QTKEYCHAIN_PLUGIN=$(usex password)
+ -DWITH_AKONADIADDRESSBOOK_PLUGIN=$(usex pim)
-DWITH_SONNET_PLUGIN=$(usex spell)
-DBUILD_TESTING=$(usex test)
-DWITH_ZLIB=$(usex zlib)