summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2023-07-04 19:17:37 +0200
committerBernard Cafarelli <voyageur@gentoo.org>2023-07-04 19:20:59 +0200
commit92eccfef050524124fad4d344739d2a8b2ae834e (patch)
tree83718ebf50acf290b20863d9b93df1fd088fa642 /mail-client
parentkernel-2.eclass: Preserve S during install (diff)
downloadgentoo-92eccfef050524124fad4d344739d2a8b2ae834e.tar.gz
gentoo-92eccfef050524124fad4d344739d2a8b2ae834e.tar.bz2
gentoo-92eccfef050524124fad4d344739d2a8b2ae834e.zip
mail-client/claws-mail: fix litehtml plugin compilation with gcc13
Closes: https://bugs.gentoo.org/905839 Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
Diffstat (limited to 'mail-client')
-rw-r--r--mail-client/claws-mail/claws-mail-4.1.1-r2.ebuild1
-rw-r--r--mail-client/claws-mail/files/claws-mail-4.1.1-litehtml_gcc13.patch37
2 files changed, 38 insertions, 0 deletions
diff --git a/mail-client/claws-mail/claws-mail-4.1.1-r2.ebuild b/mail-client/claws-mail/claws-mail-4.1.1-r2.ebuild
index 51002e15d537..323186d925d1 100644
--- a/mail-client/claws-mail/claws-mail-4.1.1-r2.ebuild
+++ b/mail-client/claws-mail/claws-mail-4.1.1-r2.ebuild
@@ -110,6 +110,7 @@ PATCHES=(
"${FILESDIR}/${PN}-3.17.5-enchant-2_default.patch"
"${FILESDIR}/${PN}-4.1.1-fix_lto.patch"
"${FILESDIR}/${P}-webkitgtk4.1.patch"
+ "${FILESDIR}/${P}-litehtml_gcc13.patch"
)
src_prepare() {
diff --git a/mail-client/claws-mail/files/claws-mail-4.1.1-litehtml_gcc13.patch b/mail-client/claws-mail/files/claws-mail-4.1.1-litehtml_gcc13.patch
new file mode 100644
index 000000000000..10da0463b843
--- /dev/null
+++ b/mail-client/claws-mail/files/claws-mail-4.1.1-litehtml_gcc13.patch
@@ -0,0 +1,37 @@
+From a9a16a253ed3865a51db5e306539d3494087dafd Mon Sep 17 00:00:00 2001
+From: Paul <paul@claws-mail.org>
+Date: Wed, 19 Apr 2023 16:42:07 +0100
+Subject: [PATCH] fix bug 4648, 'fails to build with gcc 13'
+
+---
+ src/plugins/litehtml_viewer/litehtml/html.h | 1 +
+ src/plugins/litehtml_viewer/litehtml/num_cvt.h | 1 +
+ 2 files changed, 2 insertions(+)
+
+diff --git a/src/plugins/litehtml_viewer/litehtml/html.h b/src/plugins/litehtml_viewer/litehtml/html.h
+index 4151b1225..20457f155 100644
+--- a/src/plugins/litehtml_viewer/litehtml/html.h
++++ b/src/plugins/litehtml_viewer/litehtml/html.h
+@@ -9,6 +9,7 @@
+ #include <cstring>
+ #include <algorithm>
+ #include <sstream>
++#include <cstdint>
+ #include "os_types.h"
+ #include "types.h"
+ #include "background.h"
+diff --git a/src/plugins/litehtml_viewer/litehtml/num_cvt.h b/src/plugins/litehtml_viewer/litehtml/num_cvt.h
+index 515e46d62..367dcc36a 100644
+--- a/src/plugins/litehtml_viewer/litehtml/num_cvt.h
++++ b/src/plugins/litehtml_viewer/litehtml/num_cvt.h
+@@ -2,6 +2,7 @@
+ #define NUM_CVT_H
+
+ #include <string>
++#include <cstdint>
+ #include "os_types.h"
+
+ namespace litehtml
+--
+2.25.1
+