summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2021-11-04 14:02:47 +0100
committerThomas Deutschmann <whissi@gentoo.org>2021-11-04 14:02:47 +0100
commit9cc6db756554a906b1f102014e47c97ef4c5daad (patch)
tree20878196836786e34746fb32414465fc22029e13 /mail-client
parentwww-client/firefox: allow access to GPU for USE=pgo (diff)
downloadgentoo-9cc6db756554a906b1f102014e47c97ef4c5daad.tar.gz
gentoo-9cc6db756554a906b1f102014e47c97ef4c5daad.tar.bz2
gentoo-9cc6db756554a906b1f102014e47c97ef4c5daad.zip
mail-client/thunderbird: sync with www-client/firefox
Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'mail-client')
-rw-r--r--mail-client/thunderbird/thunderbird-91.3.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/mail-client/thunderbird/thunderbird-91.3.0.ebuild b/mail-client/thunderbird/thunderbird-91.3.0.ebuild
index d71c5a29a672..8bd529e8302e 100644
--- a/mail-client/thunderbird/thunderbird-91.3.0.ebuild
+++ b/mail-client/thunderbird/thunderbird-91.3.0.ebuild
@@ -452,6 +452,34 @@ pkg_setup() {
# Build system is using /proc/self/oom_score_adj, bug #604394
addpredict /proc/self/oom_score_adj
+ if use pgo ; then
+ # Allow access to GPU during PGO run
+ local ati_cards mesa_cards nvidia_cards render_cards
+ shopt -s nullglob
+
+ ati_cards=$(echo -n /dev/ati/card* | sed 's/ /:/g')
+ if [[ -n "${ati_cards}" ]] ; then
+ addpredict "${ati_cards}"
+ fi
+
+ mesa_cards=$(echo -n /dev/dri/card* | sed 's/ /:/g')
+ if [[ -n "${mesa_cards}" ]] ; then
+ addpredict "${mesa_cards}"
+ fi
+
+ nvidia_cards=$(echo -n /dev/nvidia* | sed 's/ /:/g')
+ if [[ -n "${nvidia_cards}" ]] ; then
+ addpredict "${nvidia_cards}"
+ fi
+
+ render_cards=$(echo -n /dev/dri/renderD128* | sed 's/ /:/g')
+ if [[ -n "${render_cards}" ]] ; then
+ addpredict "${render_cards}"
+ fi
+
+ shopt -u nullglob
+ fi
+
if ! mountpoint -q /dev/shm ; then
# If /dev/shm is not available, configure is known to fail with
# a traceback report referencing /usr/lib/pythonN.N/multiprocessing/synchronize.py