summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillaume Seren <guillaumeseren@gmail.com>2019-12-29 18:40:36 +0100
committerJoonas Niilola <juippis@gentoo.org>2020-01-08 19:53:48 +0200
commitab3f99e27a7be206ac226fdca0ea8d59273d7a6d (patch)
treed75e317b3dc8781cb8e104f319cc66fd62722a81 /mail-client
parentmail-client/alot: Fix tests on version 0.8.1 (diff)
downloadgentoo-ab3f99e27a7be206ac226fdca0ea8d59273d7a6d.tar.gz
gentoo-ab3f99e27a7be206ac226fdca0ea8d59273d7a6d.tar.bz2
gentoo-ab3f99e27a7be206ac226fdca0ea8d59273d7a6d.zip
mail-client/alot: Add live-ebuild 9999
Closes: https://bugs.gentoo.org/704192 Package-Manager: Portage-2.3.79, Repoman-2.3.16 Signed-off-by: Guillaume Seren <guillaumeseren@gmail.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'mail-client')
-rw-r--r--mail-client/alot/alot-9999.ebuild88
-rw-r--r--mail-client/alot/files/9999-0001-remove-non-working-test.patch31
2 files changed, 119 insertions, 0 deletions
diff --git a/mail-client/alot/alot-9999.ebuild b/mail-client/alot/alot-9999.ebuild
new file mode 100644
index 000000000000..50fe8ee1241a
--- /dev/null
+++ b/mail-client/alot/alot-9999.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7} )
+
+inherit distutils-r1
+
+if [[ ${PV} == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/pazz/alot/"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/pazz/alot/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Experimental terminal UI for net-mail/notmuch written in Python"
+HOMEPAGE="https://github.com/pazz/alot"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="doc test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=app-crypt/gpgme-1.9.0[python,${PYTHON_USEDEP}]
+ >=dev-python/configobj-4.7.0[${PYTHON_USEDEP}]
+ dev-python/python-magic[${PYTHON_USEDEP}]
+ >=dev-python/urwid-1.3.0[${PYTHON_USEDEP}]
+ >=dev-python/urwidtrees-1.0[${PYTHON_USEDEP}]
+ >=dev-python/twisted-18.4[${PYTHON_USEDEP}]
+ net-mail/mailbase
+ >=net-mail/notmuch-0.27[crypt,python]
+ "
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? (
+ ${RDEPEND}
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+ "
+
+PATCHES=(
+ "${FILESDIR}/${PV}-0001-remove-non-working-test.patch"
+ )
+
+python_compile_all() {
+ if use doc; then
+ emake -C docs html
+ HTML_DOCS=( docs/build/html/. )
+ fi
+}
+
+src_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ insinto /usr/share/alot
+ doins -r extra
+}
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]] ; then
+ elog ""
+ elog "If you are new to Alot you may want to take a look at"
+ elog "the user manual:"
+ elog " https://alot.readthedocs.io/en/latest/"
+ elog ""
+ else
+ local rv
+ for rv in ${REPLACING_VERSIONS} ; do
+ if ver_test "${rv}" -le "0.5.1"; then
+ ewarn ""
+ ewarn "Since 0.6 version the GPG engine has switched to app-crypt/gpgme"
+ ewarn "to use GPG signing operations, you can pass the key id has arg"
+ ewarn "or setup the gpg_key value in your config file, see"
+ ewarn " https://alot.readthedocs.io/en/latest/usage/crypto.html?highlight=gpg"
+ ewarn ""
+ break
+ fi
+ done
+ fi
+}
diff --git a/mail-client/alot/files/9999-0001-remove-non-working-test.patch b/mail-client/alot/files/9999-0001-remove-non-working-test.patch
new file mode 100644
index 000000000000..7d0be5bee47a
--- /dev/null
+++ b/mail-client/alot/files/9999-0001-remove-non-working-test.patch
@@ -0,0 +1,31 @@
+From 513d05f198c9d8d7502dd1f536d1ee20845814f0 Mon Sep 17 00:00:00 2001
+From: Guillaume Seren <guillaumeseren@gmail.com>
+Date: Fri, 3 May 2019 18:17:05 +0200
+Subject: [PATCH] Remove non working test
+
+Some test are not working + fix for master
+---
+ tests/commands/test_global.py | 7 -------
+ 1 file changed, 7 deletions(-)
+
+diff --git a/tests/commands/test_global.py b/tests/commands/test_global.py
+index 94ad0672..379f87b8 100644
+--- a/tests/commands/test_global.py
++++ b/tests/commands/test_global.py
+@@ -121,13 +121,6 @@ class TestExternalCommand(unittest.TestCase):
+ await cmd.apply(ui)
+ ui.notify.assert_not_called()
+
+- @utilities.async_test
+- async def test_no_spawn_no_stdin_attached(self):
+- ui = utilities.make_ui()
+- cmd = g_commands.ExternalCommand('test -t 0', refocus=False)
+- await cmd.apply(ui)
+- ui.notify.assert_not_called()
+-
+ @utilities.async_test
+ async def test_no_spawn_stdin_attached(self):
+ ui = utilities.make_ui()
+--
+2.24.1
+